LINUX.ORG.RU

postfix+sasl+mysql


0

0

пытаюсь сделать smtp авторизацию, пользователи и пароли находятся в базе данных, прочитал что надо патч для sasl (у меня 2.1.21), скачал это:
http://www.viperstrike.com/~lopaka/sysadmin/cyrus-sasl-mysql-encrypt/software...
после чего при make install стало выдавать:
gcc -Wall -W -g -O2 -L/usr/lib -o .libs/dbconverter-2 dbconverter-2.o ../sasldb/.libs/libsasldb.al -lresolv -lpam ../lib/.libs/libsasl2.so -ldl -lresolv -lresolv -lpam -ldb-4.2 -lresolv -lresolv -lpam../lib/.libs/libsasl2.so: undefined reference to `crypt_set_format'
../lib/.libs/libsasl2.so: undefined reference to `strlcpy'
../lib/.libs/libsasl2.so: undefined reference to `crypt'
collect2: ld returned 1 exit status
в чём может быть проблема? или может есть другие варианты?

anonymous

Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.