LINUX.ORG.RU

glibc-2.5 && gcc-4.20


0

0

Товарищи линуксоиды, не поможите?... Я собрал новый компилятор gcc-4.20...

<i>вот так я его конфигурировал</i>
../build/configure --prefix=/usr --with-local-prefix=/usr/local --disable-nls --enable-shared
make bootstrap

...и столкнулся вот с такой проблемой.
Когда пытаюсь сконфигурировать glibc-2.5
../glibc-2.5/configure --prefix=/usr --disable-profile --enable-add-ons --enable-kernel=2.6.0 --without-gd --without-selinux

вываливается такое.

checking build system type... i686-pc-linux-gnu
checking host system type... i686-pc-linux-gnu
configure: running configure fragment for add-on nptl
checking sysdep dirs... sysdeps/i386/elf nptl/sysdeps/unix/sysv/linux/i386/i686 nptl/sysdeps/unix/sysv/linux/i386 sysdeps/unix/sysv/linux/i386 nptl/sysdeps/unix/sysv/linux nptl/sysdeps/pthread sysdeps/pthread sysdeps/unix/sysv/linux sysdeps/gnu sysdeps/unix/common sysdeps/unix/mman sysdeps/unix/inet sysdeps/unix/sysv/i386 nptl/sysdeps/unix/sysv sysdeps/unix/sysv sysdeps/unix/i386 nptl/sysdeps/unix sysdeps/unix sysdeps/posix sysdeps/i386/i686/fpu nptl/sysdeps/i386/i686 sysdeps/i386/i686 sysdeps/i386/i486 nptl/sysdeps/i386/i486 sysdeps/i386/fpu nptl/sysdeps/i386 sysdeps/i386 sysdeps/wordsize-32 sysdeps/ieee754/ldbl-96 sysdeps/ieee754/dbl-64 sysdeps/ieee754/flt-32 sysdeps/ieee754 sysdeps/generic/elf sysdeps/generic
checking for a BSD-compatible install... /usr/bin/install -c
checking whether ln -s works... yes
checking for gcc... gcc
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ANSI C... none needed
checking how to run the C preprocessor... gcc -E
checking for g++... g++
checking whether we are using the GNU C++ compiler... yes
checking whether g++ accepts -g... yes
checking for ranlib... ranlib
checking whether as is GNU as... yes
checking whether ld is GNU ld... yes
checking for as... as
checking version of as... 2.17, ok
checking for ld... ld
checking version of ld... 2.17, ok
checking for pwd... /bin/pwd
checking for gcc... gcc
checking version of gcc... 4.2.0, ok
checking for gnumake... no
checking for gmake... gmake
checking version of gmake... 3.79.1, ok
checking for gnumsgfmt... no
checking for gmsgfmt... no
checking for msgfmt... msgfmt
checking version of msgfmt... 0.10.38, ok
checking for makeinfo... makeinfo
checking version of makeinfo... 4.8, ok
checking for sed... sed
checking version of sed... 3.02, ok
checking for autoconf... autoconf
checking whether autoconf works... yes
checking whether ranlib is necessary... no
checking LD_LIBRARY_PATH variable... ok
checking whether GCC supports -static-libgcc... -static-libgcc
checking for bash... /bin/sh
checking for gawk... gawk
checking for perl... /usr/bin/perl
checking for install-info... /sbin/install-info
checking for bison... /usr/bin/bison
checking for signed size_t type... no
checking for libc-friendly stddef.h... yes
checking whether we need to use -P to assemble .S files... no
checking whether .text pseudo-op must be used... yes
checking for assembler global-symbol directive... .globl
checking for .set assembler directive... yes
checking for assembler .type directive prefix... @
checking for .symver assembler directive... yes
checking for ld --version-script... yes
checking for .previous assembler directive... yes
checking for .protected and .hidden assembler directive... yes
<b>checking whether __attribute__((visibility())) is supported... no</b>
<b>checking for broken __attribute__((alias()))... no</b>
checking for .preinit_array/.init_array/.fini_array support... yes
<b>checking for libunwind-support in compiler... no</b>
checking for -z nodelete option... yes
checking for -z nodlopen option... yes
checking for -z initfirst option... yes
checking for -z relro option... yes
checking for -Bgroup option... yes
checking for libgcc_s suffix...
checking for --as-needed option... yes
checking whether --noexecstack is desirable for .S files... yes
checking for -z combreloc... yes
checking for -z execstack... yes
checking for -fpie... no
checking for --hash-style option... no
checking for -fno-toplevel-reorder... yes
checking for -fstack-protector... yes
checking whether cc puts quotes around section names... no
checking for assembler .weak directive... yes
checking whether CFI directives are supported... yes
checking for ld --no-whole-archive... yes
checking for gcc -fexceptions... yes
checking for __builtin_expect... yes
checking for __builtin_memset... no
checking for redirection of built-in functions... yes
checking for __thread... yes
checking for tls_model attribute... yes
checking for libgd... no
checking for egrep... grep -E
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking for long double... yes
checking size of long double... 12
running configure fragment for sysdeps/i386/elf
checking for i386 TLS support... yes
running configure fragment for nptl/sysdeps/pthread

в итоге - сообщение
configure: error: working compiler support for visibility attribute is required

Что это за атрибут, и как его включить??? Вероятно это нужно во время компиляции...

Re: glibc-2.5 && gcc-4.20

ДА, я ещё перед этим поставил ядро 2.6.20-11... но это я думаю никак не повлияет, ибо gcc я компилил под 2.4.6-10

no_NaMe ()

Re: glibc-2.5 && gcc-4.20

--enable-threads=posix --enable-multilib --enable-long-long

birdie ★★★★★ ()
Ответ на: Re: glibc-2.5 && gcc-4.20 от birdie

Re: glibc-2.5 && gcc-4.20

Я так понял это при сборке gcc?

Спасибо. Надо попробовать. А можешь объяснить как это повлияет?

Как я понял, по говорящим именам аргументов Первая переводит логику работы потоков в стандарт posix вторая - включает поддржку нескольких библиотек (зачем?) а третья увеличивает длинну адресов...

Но как это влияет на visibility и alias + что такое libunwind?

no_NaMe ()
Ответ на: Re: glibc-2.5 && gcc-4.20 от birdie

Re: glibc-2.5 && gcc-4.20

> checking build system type... i686-pc-linux-gnu

> checking host system type... i686-pc-linux-gnu

Причём тут мультибы то? :)

Dimez ★★★★★ ()
Ответ на: Re: glibc-2.5 && gcc-4.20 от Dimez

Re: glibc-2.5 && gcc-4.20

Объясни, я не понимаю в чём проблема?

>>> Кстати, эти флиги не помогли. Я уже перекомпилировал gcc... б*ть

no_NaMe ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.