LINUX.ORG.RU

Сетевое устройство entered promiscuous mode, blocking state, disabled state в PVE после перехода на ZFS

 , , ,


1

1

Всем привет!

У меня на сервере был установлен Proxmox на одном системном NVMe M.2 диске в режиме LVM. Всё работало нормально.

Потом я добавил в сервер ещё один аналогичный NVMe M.2 диск и переинсталировал Proxmox , при этом настройки диска поставил в режим ZFS RAID1. Все остальные настройки - по умолчанию, кроме статического адреса сетевой карты хоста (адрес, маска, шлюз, днс-сервер).

PVE работает, но теперь на дисплее хоста выводятся сообщения:

Feb  7 08:27:52 pve kernel: [   11.557802] device tap100i0 entered promiscuous mode
Feb  7 08:27:52 pve kernel: [   11.587512] fwbr100i0: port 1(fwln100i0) entered blocking state
Feb  7 08:27:52 pve kernel: [   11.587553] fwbr100i0: port 1(fwln100i0) entered disabled state
Feb  7 08:27:52 pve kernel: [   11.587631] device fwln100i0 entered promiscuous mode
Feb  7 08:27:52 pve kernel: [   11.587706] fwbr100i0: port 1(fwln100i0) entered blocking state
Feb  7 08:27:52 pve kernel: [   11.587736] fwbr100i0: port 1(fwln100i0) entered forwarding state
Feb  7 08:27:52 pve kernel: [   11.590860] vmbr0: port 2(fwpr100p0) entered blocking state
Feb  7 08:27:52 pve kernel: [   11.590891] vmbr0: port 2(fwpr100p0) entered disabled state
Feb  7 08:27:52 pve kernel: [   11.590961] device fwpr100p0 entered promiscuous mode
Feb  7 08:27:52 pve kernel: [   11.591030] vmbr0: port 2(fwpr100p0) entered blocking state
Feb  7 08:27:52 pve kernel: [   11.591058] vmbr0: port 2(fwpr100p0) entered forwarding state
Feb  7 08:27:52 pve kernel: [   11.594126] fwbr100i0: port 2(tap100i0) entered blocking state
Feb  7 08:27:52 pve kernel: [   11.594159] fwbr100i0: port 2(tap100i0) entered disabled state
Feb  7 08:27:52 pve kernel: [   11.594241] fwbr100i0: port 2(tap100i0) entered blocking state
Feb  7 08:27:52 pve kernel: [   11.594288] fwbr100i0: port 2(tap100i0) entered forwarding state

Из-за чего это может быть? И как это исправить?

Информация о сетевых интерфейсах в хосте:

root@pve:~# ethtool
ethtool: bad command line argument(s)
For more information run ethtool -h
root@pve:~# ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: enp5s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast master vmbr0 state UP group default qlen 1000
    link/ether 00:e0:4c:a5:02:e7 brd ff:ff:ff:ff:ff:ff
3: vmbr0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
    link/ether 00:e0:4c:a5:02:e7 brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.201/24 scope global vmbr0
       valid_lft forever preferred_lft forever
    inet6 fe80::2e0:4cff:fea5:2e7/64 scope link
       valid_lft forever preferred_lft forever
4: tap100i0: <BROADCAST,MULTICAST,PROMISC,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast master fwbr100i0 state UNKNOWN group default qlen 1000
    link/ether 3e:5b:9b:c9:06:a2 brd ff:ff:ff:ff:ff:ff
5: fwbr100i0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
    link/ether 0a:ed:61:c8:56:34 brd ff:ff:ff:ff:ff:ff
6: fwpr100p0@fwln100i0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master vmbr0 state UP group default qlen 1000
    link/ether 16:69:a8:cc:ad:ea brd ff:ff:ff:ff:ff:ff
7: fwln100i0@fwpr100p0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master fwbr100i0 state UP group default qlen 1000
    link/ether 72:ae:3f:a3:a4:26 brd ff:ff:ff:ff:ff:ff
root@pve:~# ethtool enp5s0
Settings for enp5s0:
        Supported ports: [ TP    MII ]
        Supported link modes:   10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
                                1000baseT/Half 1000baseT/Full
        Supported pause frame use: Symmetric Receive-only
        Supports auto-negotiation: Yes
        Supported FEC modes: Not reported
        Advertised link modes:  10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
                                1000baseT/Half 1000baseT/Full
        Advertised pause frame use: Symmetric Receive-only
        Advertised auto-negotiation: Yes
        Advertised FEC modes: Not reported
        Link partner advertised link modes:  10baseT/Half 10baseT/Full
                                             100baseT/Half 100baseT/Full
                                             1000baseT/Full
        Link partner advertised pause frame use: No
        Link partner advertised auto-negotiation: Yes
        Link partner advertised FEC modes: Not reported
        Speed: 1000Mb/s
        Duplex: Full
        Auto-negotiation: on
        master-slave cfg: preferred slave
        master-slave status: slave
        Port: Twisted Pair
        PHYAD: 0
        Transceiver: external
        MDI-X: Unknown
        Supports Wake-on: pumbg
        Wake-on: d
        Link detected: yes

Ответ на: комментарий от Black_Shadow

Что конкретно не работает?

Вроде всё работает, но боюсь, что сетевые эти интерфейсы работают в ограниченном режиме и взамодействие по сети между ВМ от этого страдает.

Например, интерфейс tap100i0 работает на скорости всего 10 Мб/с

root@pve:~# ethtool tap100i0
Settings for tap100i0:
        Supported ports: [  ]
        Supported link modes:   Not reported
        Supported pause frame use: No
        Supports auto-negotiation: No
        Supported FEC modes: Not reported
        Advertised link modes:  Not reported
        Advertised pause frame use: No
        Advertised auto-negotiation: No
        Advertised FEC modes: Not reported
        Speed: 10Mb/s
        Duplex: Full
        Auto-negotiation: off
        Port: Twisted Pair
        PHYAD: 0
        Transceiver: internal
        MDI-X: Unknown
        Current message level: 0x00000000 (0)
                              
        Link detected: yes

Может я какие-то параметры в БИОС случайно изменил?

Garik368 ()
Ответ на: комментарий от Garik368

Это нормальное поведение proxmox. Что касается tap интерфейсов - это программные интерфейсы, никаких ограничений скорости (тем более 10 Mb/s) у них нет. Все эти сообщения - следствие запуска виртуальных машин с сетевыми интерфейсами.

Black_Shadow ★★★★★ ()
Для того чтобы оставить комментарий войдите или зарегистрируйтесь.