LINUX.ORG.RU

обновление libssh

 


0

1

Добрый вечер. Есть проблемка, может кто знает как решить. Стоит деб 8, и проблема в том что не может подключаться по ssh к деб 11, я так полагаю проблема в libssh2_1.4.3. На более свежей версии конект есть. Как обновить эту библиотеку и ничего не запороть?)


Предлагаю, что проблема в том, что в деб 11 по умолчанию запрещено использовать старые протоколы шифрования. Для более детального анализа требуются логи с обоих сторон.

einhander ★★★★★ ()
Ответ на: комментарий от einhander

да, как раз проблема с этими протоколами. На пк стоит старый putty и он как раз тоже жалуется на какие-то методы шифрования. А какие логи смотреть?

User01 ()

Самое простое: попробовать скачать отсюда https://packages.debian.org/search?keywords=libssh2-1 более новый пакет (.deb) и установить его через dpkg -i. Чем новее - тем больше шансов что всё заработает после установки, но тем меньше - что он установится (в зависимостях более новый glibc например чем у тебя стоит).

firkax ★★★ ()
Ответ на: комментарий от User01

я пробую с помощью php

А пользователем с помощью ssh работает?

einhander ★★★★★ ()

Есть проблемка, может кто знает как решить. Стоит деб 8

Обновить до debian 10.

zemidius ()
Для того чтобы оставить комментарий войдите или зарегистрируйтесь.