LINUX.ORG.RU

как задать версию какой либо проги как запускаемую по умолчанию?

 , , ,


0

1

Всем привет, собственно вопрос в теме, это если этих прог установлено сразу несколько разных версий, конкретно в моем случае - у меня установлены интерпретаторы языка Луа версий - 5.1, 5.2, 5.3, при выполнении команд и скриптов из консоли

lua -e «скрипт или команды»

Как я выяснил работает интерпретатор версии 5.2 А если я хочу выполнить тоже самое но с интерпретором 5.1 или 5.3?

меня установлены интерпретаторы языка Луа версий - 5.1, 5.2, 5.3 Как я выяснил работает интерпретатор версии 5.2 А если я хочу выполнить тоже самое но с интерпретором 5.1 или 5.3?

Ну так посмотри, как называются бинарники в этих пакетах, наверняка - lua-5.1 lua-5.2 lua-5.3 и имеется линк lua -> lua-5.2 Соответственно, либо измени текущий lua, либо вызывай нужный интерпретатор полным именем с номером версии lua-5.3 -e "..."

sigurd ★★★★ ()
Последнее исправление: sigurd (всего исправлений: 1)