LINUX.ORG.RU

физически либа есть,практически нету :(


0

0

Возникла такая проблема, ставлю из рпма драйвера fglrx, говорит нету либы libexpat.so.1 првоеряю, лежит в /usr/lib, смотрю прописаные либы в системе /sbin/ldconfig -v там libexpat.so.1 не прописана :( только so.0 подскажите как ее туда прописать? или как сделат ьчтобы пакет ее увидел?

★★

Re: физически либа есть,практически нету :(

Ну сделай симлинк.

UVV ★★★★★ ()

Re: физически либа есть,практически нету :(

Нету её ни физически, никак. Стоит либа другой версии. Либо ставь нужную версию, либо ищи другой рпм, либо на свой страх и риск делай симлминк (работает в половине случаев, но без гарантии, что что-нибудь потом не накроется).

Teak ★★★★★ ()

Re: физически либа есть,практически нету :(

Это кстати да, есть такой косяк. Но эта либка нужна только для fglrxconfig (qt-шная конфигурялка, короче) - АТИшнеГи собирают ее до сих пор с expat-1.95.x, у которой мажор = 0. В принципе можно сделать как:

ln -sfv /path-to/libexpat.so.0 ./libexpat.so.1

LD_LIBRARY_PATH=.:$LD_LIBRARY_PATH fglrxconfig

e ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.