LINUX.ORG.RU

выбор Linux для AMD Ryzen 3 2200G с встроенной графикой Vega 8

 ,


0

2

Здравствуйте. Посоветуйте лучший дистрибутив с графической оболочкой KDE и чтобы нормально работал со встроенными графическими ядрами ппооцесоров Raven Ridge. У меня AMD Ryzen 2200G в данный момент с графическим ядром AMD Vega 8. Сразу оговорка. Debian не предлагать. Из коробки в Debian у меня напрочь не работает X и соответственно графическая оболочка. Естественно я пробывал перезапускать X и толку это не дало. Да и при загрузке ошибка: https://ibb.co/R778ssK К слову даже Debian Live выдает теже симптомы. Что касается остальных сборок то начиная с Linux Mint остальные дебиан дестрибутивы нормально запускают графическую оболочку однако в kubuntu 20.04 lts заметил вот такой список ошибок при загрузке:

alexandr-5@alexandr-7:~$ dmesg | grep error
[    0.677512] ACPI Error: Aborting method \_SB.PCI0.GP17.VGA.LCD._BCM due to previous error (AE_NOT_FOUND) (20190816/psparse-529)
[    1.091823] kfd kfd: error getting iommu info. is the iommu enabled?
[    1.091917] kfd kfd: device 1002:15dd NOT added due to errors
[    3.867945] EXT4-fs (sda5): re-mounted. Opts: errors=remount-ro

Но стоить заметить что какихто серьезных проблем при работе не заметил. Возможно они проявится позже. Разве только что ярлыки .dekstop exe приложений поставленных в wine не работают. Точнее они не запускают приложение. Возможно это связано с тем что я использую winehq и не stable но тоже какуюто на s называемую. Короче думаю нафиг стереть кубунту и поставить стабильный линукс который будет работать с моим пролццесором нормально? От вас лишь прошу совета. Но важно чтобы сборка обладала КДЕ или туда можно было поставить КДЕ без проблем. Лично при попытке поставить КДЕ на Linux Mint с цинамоном то KDE нормально просто не работала. Как минимум это отсуствия заголовков с кнопками закрыть свернуть и тд. т.п Если брать не Дебиан дистрибутивы то например на Манджора линукс не работал Ацетон 2 для монтирования образов. Но в любом случае я нашел другую прогу под названием gcdemu. Она то что надо и естественно нужна сборка которая поддерживает данную программу.

Список программ которые мне нужно будет поставить wine gcdemu ONLYOFFICE Steam Gimp qBittorrent Lazarus Соответственно все приложения стима совместимые с линуксом Ну и другие приложения. Желательно все же подыскать дистрибутив Debian’а так как некоторые уникальные приложения не имеют других пакетов окромя deb. И поставить их на RPM или Pacman уже будет проблема.

Ядро linux = драйвера, чем новее ядро тем лучше, например в ubuntu 19.10 ядро 5.3, графика vega8 в 3550h работает без нареканий. В ubuntu 20.04 уже ядро 5.4, значит и там будет работать (если не было регреса). А в debian, скорее всего, более древнее ядро. Так что подбирай дистрибутив по версии ядра. Я не застал но по слухам vega раньше работала плохо, потому старые ядра могут вызывать проблемы.

anonymous ()
Ответ на: комментарий от anonymous

Очень смешно. Меня из Windows устраивает и обычная 10 за 1 исключением. На ней дико не хотят работать старые игры которые выходили на сд дисках на примере Gruntz и парочих. На wine данные игры работают нормально и это уже точно так как лично тестировал. Это тот момент когда старое WinAPI лучше чем то что в 10. Естественно возможности поставить ни 7 ни xp кроме как на виртуалку нет. Но Wine всяко разно будет лучше. Как минимум тем что загрузка на проц не будет высокой. И да. Я знаю про wsl но спасибо меня не устраивает тот факт что работать через wsl только через консоль.

Alexandr_7 ()
Ответ на: комментарий от anonymous

По сообщениям техже Debian они в своем 4.19 ядре обещали нормальную поддержку APU Ryzen но в другом месте читал что ядро 4.19 не поддерживает их. Учитывая что графическая оболочка не грузится то явно дебиан наврали про поддержку процессоров или тупо не тестировали. По поводу kubuntu то ставил я 20.04 и как можно судить по сообщениям dmesg то проблема с видеоядром есть: kfd kfd: device 1002:15dd NOT added due to errors device 1002:15dd - это и есть грапфическое ядро Хотя сама графическая оболочка на удивление работает.

Alexandr_7 ()

Полное название дистрибутива debian Debian GNU linux, а это значит что в дистрибутиве по умолчанию нет пакетов с закрытым программным обеспечением, т.е. firmware.

Их нужно только поставить.

А для этого подключить репозитории с non-free и contrib пакетами.

infomeh ★★ ()
Ответ на: комментарий от infomeh

установить пакет с firmware

Кстати да, но…

Из коробки в Debian у меня напрочь не работает X и соответственно графическая оболочка.

Даже если GPU не заводится графическая карта должна была работать в VGA/VESA режиме совместимости с отрисовкой интерфейса DE через llvm/softpipe (OGL силами процессора). При это могло быть не родное разрешение, тормоза, но изображение должно было быть, этого хватает чтоб доставить нужные вещи вроде firmware.

anonymous ()
Ответ на: комментарий от infomeh

Я вас не понял. Я скачивал последнюю сборку дебиана с оф сайта. Я не пользователь линукс. Я линукс еслиб не гребаная 10 винда и полная отсуствия поставить другую винду яб этот линукс даже и не ставил. А так мне важно чтобы система работала с коробки. Дебиан увы слало нафиг это. Тоесть мне исправлять ошибки нужно вручну. Спасибо но на этот случай лучше поставить другой линукс дистрибутив.

Alexandr_7 ()

Из коробки в Debian у меня напрочь не работает X и соответственно графическая оболочка.

Проверь, что у тебя хотя бы десяточка. Возможно, тебе нужно руками качнуть и распаковать в /lib/firmware/amdgpu прошивку для своей карточки.

В дебьяне кто-то умер, скорее всего, и firmware-amd-graphics не обновляется даже в sid.

Вот твоя проблема https://askubuntu.com/questions/1124253/missing-firmware-for-amdgpu

LamerOk ★★★★★ ()
Ответ на: комментарий от Alexandr_7

С таким подходом оставайся на windows.

Это не ошибки, а политика дистрибутива.

При установки в нем отсутствуют пакеты с несвободным софтом, но они есть в репозитории их нужно только поставить.

В Линукс лениться нельзя.

infomeh ★★ ()
Ответ на: комментарий от anonymous

Ну как видно нету. Я скинул скриншот с ошибками Debian.После этих ошибок открывается только консоль. Попытко запуска x сервера кроме логов ничего не дает. Я не такой мастер чтоб через консоль уметь разбираться в ошибках когда я в принципе с линуксом особо не знаком. Я хорошо знаю винду но не линукс.

Alexandr_7 ()
Ответ на: комментарий от Alexandr_7

еслиб не гребаная 10 винда и полная отсуствия поставить другую винду
Тоесть мне исправлять ошибки нужно вручну. Спасибо но на этот случай лучше поставить другой линукс дистрибутив.

Продай / подари свой компьютер / ноутбук кому-нибудь. Купи себе планшет или приставку.

LamerOk ★★★★★ ()
Ответ на: комментарий от LamerOk

Возможно, тебе нужно руками качнуть и распаковать в /lib/firmware/amdgpu прошивку для своей карточки

И зачем это всё, если человек сам сказал, что ему нужна работающая из коробки система? Пусть ставит Kubuntu 20.04 или Xubuntu 20.04

anonymous ()
Ответ на: комментарий от infomeh

С таким подходом можешь заткнуться. Мне линукс нужен по факту из за wine да и так чтоб потихоньку учить эту систему. По твоему как я должен уметь разбираться в линуксе если нет возможности практики на ней.

Alexandr_7 ()
Ответ на: комментарий от Alexandr_7

Если не мешает работать то просто игнорировать эти ошибки :) У закрытой винды есть преимущество, она логи ядра не показывает, тем самым не нервирует пользователей.

Все что содержит аббревиатуру ACPI связано с bios мат.платы.

anonymous ()
Ответ на: комментарий от anonymous

Kubuntu 20.04 хоть и работает ггрвфическая оболочка но я блин кому показал список проблем в ней:

alexandr-5@alexandr-7:~$ dmesg | grep error
[    0.677512] ACPI Error: Aborting method \_SB.PCI0.GP17.VGA.LCD._BCM due to previous error (AE_NOT_FOUND) (20190816/psparse-529)
[    1.091823] kfd kfd: error getting iommu info. is the iommu enabled?
[    1.091917] kfd kfd: device 1002:15dd NOT added due to errors
[    3.867945] EXT4-fs (sda5): re-mounted. Opts: errors=remount-ro

Я рылся в инете но исправить данные проблемы так и не смог. А вот это:

[    1.091917] kfd kfd: device 1002:15dd NOT added due to errors

Это так вообще ошибка видеоядра. Найти драйвер под AMD Ryzen 3 2200G мне так и не уалось. Сами AMD поддержку не делали. Они сами заявили что драйверов под данное графическое ядро выпускать не собираются.

Alexandr_7 ()
Ответ на: комментарий от Alexandr_7

Эти ошибки хоть как-то мешают тебе работать?

Они сами заявили что драйверов под данное графическое ядро выпускать не собираются

А знаешь почему? Потому что эти драйвера уже запилены и находятся в ядре системы. Ничего дополнительно ставить не нужно

anonymous ()
Ответ на: комментарий от LamerOk

Ну вообщето мне 25 лет. Хотя грубость ты заслужил. Сам лучше бы не грубил. Короче зря я сюда обратился. Здесь одни профи сидят которые новичков любят на все 4 стороны посылать. Хотя кое что я про линукс знаю но работать в ней без инструкций не могу. Тоесть чтоб разбираться как минимум нужен браузер.

Alexandr_7 ()
Ответ на: комментарий от Alexandr_7

Здесь не профи здесь обычные люди. Которые тебе подсказали что нужно сделать.

Нужно просто открыть google и набрать поисковый запрос как установить в debian прошивки для карт radeon как подключить репозиторий debian backports и как подключить ветки repositories несвободный софтом.

infomeh ★★ ()
Ответ на: комментарий от LamerOk

Ладно. Извини за грубость. Я честно был не прав но я обратилмся с помощью подсказки выбора дистрибутива а советовать мне на Винде оставаться хотя я на ней и сижу это грубость. Я от винды уходить и не собираюсь но Винда слала нафиг на поддержкук старых игр которые в wine работают нормавльно так что мне нужен линукс диструбутив.

Alexandr_7 ()
Ответ на: комментарий от infomeh

Ну именно поэтому я машину и не вожу. Запомнить не проблема. Проблема будет если не поможет это впустую будет потраченное время. Чтоб в этом разбираться нужно систему на изусть знать

Alexandr_7 ()

Не слушайте всех этих «диванных экспертов», посещающих Сосач. Проприетарный драйвер (он же «firmware») напрочь не нужен, т.к. есть свободный, который для обычного пользователя куда лучше и он уже в ядре. И, ЕМНИП, нормально 2200G начал «заводиться» с ядрами 4.20 и новее. 4.19 в Debian, вот и вся проблема.

Это первое. Второе: Kubuntu нормально работаeт, ошибки, которые вы получили, к видеоядру не имеют никакого отношения.

ярлыки .dekstop exe приложений поставленных в wine не работают

Те .desktop-ярлыки, что создают инсталляторы – на самом деле сами являются ярлыками ярлыков. Сносите смело и создавайте заново, прописав в «Команда» правильную команду для запуска приложения из-под консоли.

на Манджора линукс не работал Ацетон 2 для монтирования образов

4.2. Оно не может не работать, там фактически нечему «ломаться». Вот udftools нужно, это да.

Korchevatel ★★★★★ ()
Ответ на: комментарий от Korchevatel

4.19 в Debian, вот и вся проблема

Нет, проблема в том, что мейнтейнеры Debian не кладут дрова в своё ядро, иначе я не могу объяснить, почему в unstable (где, как бы, ядро по свежее будет) графика также не поднимается (у меня ряженка 2400G)

anonymous ()
Ответ на: комментарий от Korchevatel

На счет 1го это кокрастоки ошибки. Подозреваю что ошибко с видеоядром это жалоба что обычный драйвер vga работает. Мне бы все равно хотелось знать как установить свободный драйвер amd под мою видеокарту. А проприетарных драйверов amd не выпускали но в интернете в основном пишут про решенияч с установкой проприетарных драйверов котороых нету.

Alexandr_7 ()
Ответ на: комментарий от infomeh

Ну для большинства карт от AMD используется драйвер radeon для некоторых amdgpu но модулей ядра всё равно radeon, если не ошибаюсь

Ошибаешься, radeon drm это ядерная часть драйвера для старых gpu, начиная с polaris (rx4xx) только amdgpu drm. Часть чипов до polaris могли поддерживаться в обоих. vega новее поляриса, так что без вариантов - amdgpu drm.

anonymous ()
Ответ на: комментарий от anonymous

Очень смешно. DxWnd это программа для запуска игр в окне если не ошибаюсь. Спасибо но уж лучше Wine. А про совместимость с windows xp или установкой компоненты прежних версий можете не напоминать. Все это не помогает. Нормально работают только стимовские игры но касаемые тех что давно забыт и кроме как на торрентах их не достанешь те работать на 10 кроме как на 1 фпс не будут нормально. Они и на 7ке еле живы были. На XP они хорошо работают но как сказал для меня установка 7ки или XP невозможно . И именно что невозможно так как ASrock на пару с AMD послали нафиг эти системы

Alexandr_7 ()
Ответ на: комментарий от Alexandr_7

кокрастоки

Что за зверь? Надеюсь, не фурри?

Подозреваю что ошибко с видеоядром это жалоба что обычный драйвер vga работает

Что такое IOMMU: https://duckduckgo.com/?t=ffcm&q=iommu&ia=web

Конкретно эта ошибка указывает на подпорченный UEFI (скорее всего). Нужно в /etc/default/grub параметр прописать: https://unix.stackexchange.com/questions/263901/kfd-error-getting-iommu-info

как установить свободный драйвер amd под мою видеокарту

Его не надо устанавливать, модуль amdgpu уже в ядре.

Korchevatel ★★★★★ ()
Ответ на: комментарий от infomeh

Закрытое ПО так это не проприетарное ПО случаем. Я же сказал AMD драверов не выпускала так что то что в Дебиан нет проприетарных дров это вообще роли не какой не играет. Факт в том что из коробки икс сервер не зхагружается. Как минимум для начало надо лезть в логи те что выдает запуск икс сервера и разбираться что вот не зная линукс сделать просто невозможно.

Alexandr_7 ()
Ответ на: комментарий от Korchevatel

Я же сказал что wine лучше. У меня виртуалка загружает на 100 все. и озу и проц и диск. Тоесть покуда запущена виртуалка мне доступ к основной машине закрыт да и сама виртуалка дат говеную производительность.

Alexandr_7 ()