LINUX.ORG.RU

Кто-нибудь ставил grsecurity на Debian?


0

0

Сабж.

kernel-patch-grsecurity по-видимому устарел, т.к. судя по README - в дебиане слишком много наложено патчей, что делает исходники сильно отличающимися от ванильных, и соответственно поддерживать их крайне сложно.

kernel-patch-grsecurity2 вроде как должен применяться на последнее ядро (kernel-source-2.4.27), но, не применяется:

[root@fx kernel-source-2.4.27]# ../kernel-patches/all/apply/grsecurity2
START applying grsecurity2 patch (Greater Security for Linux 2.4 and 2.6)
Testing whether "Greater Security for Linux 2.4 and 2.6" patch for 2.4.27 applies (dry run):
3 out of 12 hunks FAILED -- saving rejects to file fs/binfmt_elf.c.rej
1 out of 17 hunks FAILED -- saving rejects to file fs/exec.c.rej
1 out of 7 hunks FAILED -- saving rejects to file include/linux/mm.h.rej
1 out of 2 hunks FAILED -- saving rejects to file net/ipv4/ip_output.c.rej
"Greater Security for Linux 2.4 and 2.6" patch for 2.4.27 does not apply cleanly


возможно ли все же поставить grsecurity на Debian Stable, не используя ванильное ядро?

Re: Кто-нибудь ставил grsecurity на Debian?

___(Greater Security for Linux 2.4 and 2.6)___
                                       ^^^

эээ?

Gharik ()

Re: Кто-нибудь ставил grsecurity на Debian?

После того, как на дебианское ядро наложены патчи SELinux?

Нет.

А зачем?

jackill ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.