LINUX.ORG.RU

Не могу установить русскую локаль в Centos 8

 , ,


0

0

Может показаться, что вопрос избитый, но я специально проверил настройки в centos 7 и 8, они одинаковые - локаль и /etc/vconsole.conf. Все ставлю из минималки со стандартными настройками. Но в 8 что-то не работает и русские символы отображаются или знаками вопроса или кодами utf8. localectl set-locale LANG=ru_RU.UTF-8 не отличается от LANG=ru_RU.utf8. Больше идей нет.

ls -al ...

drwxrwxrwx   2 1000 root 430 Jan  2 22:12 ''$'\320\244\320\270\320\273\321\214\320\274\321\213'

locale

LANG=ru_RU.UTF-8
LC_CTYPE="ru_RU.UTF-8"
LC_NUMERIC="ru_RU.UTF-8"
LC_TIME="ru_RU.UTF-8"
LC_COLLATE="ru_RU.UTF-8"
LC_MONETARY="ru_RU.UTF-8"
LC_MESSAGES="ru_RU.UTF-8"
LC_PAPER="ru_RU.UTF-8"
LC_NAME="ru_RU.UTF-8"
LC_ADDRESS="ru_RU.UTF-8"
LC_TELEPHONE="ru_RU.UTF-8"
LC_MEASUREMENT="ru_RU.UTF-8"
LC_IDENTIFICATION="ru_RU.UTF-8"
LC_ALL=

localectl status

   System Locale: LANG=ru_RU.UTF-8
       VC Keymap: us
      X11 Layout: ru,us
       X11 Model: pc105
     X11 Options: terminate:ctrl_alt_bksp,grp:shifts_toggle,grp_led:scroll

★★★★★

Должен быть установлен в консоли также шрифт с поддержкой кириллических символов.

infomeh ★★ ()
Ответ на: комментарий от Lordwind

А локаль точно есть, что показывает [code] locale -av [/code]

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.