LINUX.ORG.RU

Firefox и принудительные обновления

 , , ,


0

1

Относительно недавно вышел новый firefox-esr 68.2.0. Ну и ладно, подумал я обновляться я не планировал со своего firefox-esr 60.7.1. Заблокировал версию в synaptic и забил. Но он обновился. Ладно автообновление дело такое. Откатил, заблокировал, конфиги поотключал (в настройках пункта отключения автообновления нет). И через пару дней опять обновился. Опять откатил, ковырял конфиги и т.д. 10 дней бился и в итоге никак не хочет оставаться на 60.7.1.

А остаться на предыдущей версии я хочу по причине того, что там нет дикой утечки памяти. Шутка ли, 20 вкладок и 10GB оперативки съедает. На 60.7.1 такое возможно только при 50-80 открытых тяжелых вкладках. Что я делаю не так? И как это исправить? (Я про обновление)

20 вкладок и 10GB оперативки съедает

Утечка памяти в драйверах

Что я делаю не так?

Борешься со здравым смыслом.

как это исправить?

Разобраться в причинах утечек памяти в системе. Искать в багтрекере дебиана аналогичные открытые кейсы.

xDShot ★★★★★ ()
Ответ на: комментарий от xDShot

Утечка памяти в драйверах

Очень избирательная утечка драйвера который работает конкретно с firefox и с его конкретной версией.

Разобраться в причинах утечек памяти в системе. Искать в багтрекере дебиана аналогичные открытые кейсы.

Замечательно, пришел с проблемой которую я не могу решить и вместо адекватного совета и меня отправляют решать эту же проблему.

Im_not_robot ()

Звездец на ваших линуксах жить. Я, тупорылый раб винды, спокойно пользуюсь хоть 10 хоть 15 вкладками хоть на ФФ хоть на Хроме. У свободных людей, видимо, много лишнего времени.

anonymous ()

Не в первый раз замечаю, что после обновления лисы нет логов apt/dpkg. Он мимо пакетного менеджера обновляется что ли?..

anonymous ()

Может это e10s? Они же там увеличивают количество процессов по умолчанию между релизами. Какие-то настройки для этого должны быть.

xaizek ★★★★★ ()
Ответ на: комментарий от Im_not_robot

Замечательно, пришел с проблемой которую я не могу решить и вместо адекватного совета и меня отправляют решать эту же проблему.

Сам виноват. Пришел сюда без каких-либо подробностей: ни набора железа, ни версии пакетов, драйверов, ядра, ни того, что сделал с системой недавно. Только поныть походу.

ПыСы: на моем арче лиса с тамошнего репозитория со столькими вкладами не отъедает памяти.

xDShot ★★★★★ ()
Ответ на: комментарий от anonymous

Если только опакетили на основе официального бинарного дистрибутива, в котором встроена зондообновлялка. Хотя на дистрибутиве здоровых человеков такое обычно не происходит.

xDShot ★★★★★ ()
Ответ на: комментарий от xDShot

[code] -Computer- Processor : 4x Intel(R) Core(TM) i3-7020U CPU @ 2.30GHz Memory : 12212MB (4405MB used) Operating System : Debian GNU/Linux 9.5 User Name : Date/Time : Вс 15 дек 2019 16:30:31

-Display- Resolution : 1366x768 pixels OpenGL Renderer : Mesa DRI Intel(R) HD Graphics 620 (Kaby Lake GT2) X11 Vendor : The X.Org Foundation -Multimedia- Audio Adapter : HDA-Intel - HDA Intel PCH -Input Devices- AT Translated Set 2 keyboard SynPS/2 Synaptics TouchPad Lid Switch Power Button HP Wireless hotkeys Video Bus Video Bus PC Speaker HP WMI hotkeys HP Webcam: HP Webcam HDA Intel PCH Mic HDA Intel PCH Headphone HDA Intel PCH HDMI/DP,pcm : 3= HDA Intel PCH HDMI/DP,pcm : 7= HDA Intel PCH HDMI/DP,pcm : 8= HDA Intel PCH HDMI/DP,pcm : 9= HDA Intel PCH HDMI/DP,pcm : 10= Logitech USB Receiver Logitech USB Receiver Mouse Logitech USB Receiver Consumer Control Logitech USB Receiver System Control

[/code]

[code] -Version- Kernel : Linux 4.19.0-5-amd64 (x86_64) Compiled : #1 SMP Debian 4.19.37-5 (2019-06-19) C Library : Unknown Default C Compiler : GNU C Compiler version 8.3.0 (Debian 8.3.0-7) Distribution : Debian GNU/Linux 9.5 -Current Session- Home Directory : /home/user Desktop Environment : XFCE 4 -Misc- Uptime : 23 days, 2 hours and 45 minutes Load Average : 4,00, 0,00, 0,00

[/code]

Версию лисы написал. Или тебе нужен весь список пакетов в системе?

Из недавнего устанавливал слетевший mtp, а более месяца назад удалил у пользователя sudoers флаги. Починил насколько возможно переустановкой politkit.

Im_not_robot ()

Что я делаю не так?

Юзаешь всякое старьё. Бери последнюю версию Firefox(71) и всё там норм. Я по 100 вкладок держу и столько не жрёт. Более того, у меня оперативки столько нет, сколько у тебя жрёт.

th3m3 ★★★★★ ()
Ответ на: комментарий от th3m3

У меня firefox-esr. Т.е там нет 71 версии. Максимальная 63. Хотя можно подключить репозиторий и скачать. Лишним не будет.

Но всё же, возращаясь к проблеме. У кого-нибудь есть варианты почему firefox-esr не смотря на блокировку в synaptic и отключенных конфигах (в about:config) обновляется? Ничего не спрашивая и не о чем не предупреждая?

Im_not_robot ()
Ответ на: комментарий от xDShot
-Computer-
Processor		: 4x Intel(R) Core(TM) i3-7020U CPU @ 2.30GHz
Memory		: 12212MB (4405MB used)
Operating System		: Debian GNU/Linux 9.5
User Name		: 
Date/Time		: Вс 15 дек 2019 16:30:31
-Display-
Resolution		: 1366x768 pixels
OpenGL Renderer		: Mesa DRI Intel(R) HD Graphics 620 (Kaby Lake GT2) 
X11 Vendor		: The X.Org Foundation
-Multimedia-
Audio Adapter		: HDA-Intel - HDA Intel PCH
-Input Devices-
 AT Translated Set 2 keyboard
 SynPS/2 Synaptics TouchPad
 Lid Switch
 Power Button
 HP Wireless hotkeys
 Video Bus
 Video Bus
 PC Speaker
 HP WMI hotkeys
 HP Webcam: HP Webcam
 HDA Intel PCH Mic
 HDA Intel PCH Headphone
 HDA Intel PCH HDMI/DP,pcm		: 3=
 HDA Intel PCH HDMI/DP,pcm		: 7=
 HDA Intel PCH HDMI/DP,pcm		: 8=
 HDA Intel PCH HDMI/DP,pcm		: 9=
 HDA Intel PCH HDMI/DP,pcm		: 10=
 Logitech USB Receiver
 Logitech USB Receiver Mouse
 Logitech USB Receiver Consumer Control
 Logitech USB Receiver System Control
-Version-
Kernel		: Linux 4.19.0-5-amd64 (x86_64)
Compiled		: #1 SMP Debian 4.19.37-5 (2019-06-19)
C Library		: Unknown
Default C Compiler		: GNU C Compiler version 8.3.0 (Debian 8.3.0-7) 
Distribution		: Debian GNU/Linux 9.5
-Current Session-
Home Directory		: /home/user
Desktop Environment		: XFCE 4
-Misc-
Uptime		: 23 days, 2 hours and 45 minutes
Load Average		: 4,00, 0,00, 0,00

Версию лисы написал. Или тебе нужен весь список пакетов в системе?

Из недавнего устанавливал слетевший mtp, а более месяца назад удалил у пользователя sudoers флаги. Починил насколько возможно переустановкой politkit.

Im_not_robot ()

Что нужно открывать чтобы

20 вкладок и 10GB оперативки съедает

серьезно без шуток, почему я открываю те же 50-80 вкладок и всё помещается в 4Гб да еще место остается.

Может вы конечно без адблока и блокировщика скриптов живете, ну тогда ССЗБ и покупать еще 10 гигов оперативки.

BLOBster ()
Ответ на: комментарий от Rootlexx

Да! Спасибо! Оно!

Start-Date: 2019-12-05  07:11:18
Commandline: /usr/bin/unattended-upgrade
Upgrade: firefox-esr-l10n-ru:amd64 (60.7.1esr-1~deb9u1, 68.2.0esr-1~deb9u2), firefox-esr:amd64 (60.7.1esr-1~deb9u1, 68.2.0esr-1~deb9u2)
End-Date: 2019-12-05  07:11:48

Start-Date: 2019-12-05  07:12:48
Commandline: apt install sudo
Upgrade: sudo:amd64 (1.8.27-1, 1.8.29-1)
End-Date: 2019-12-05  07:12:54

Start-Date: 2019-12-05  07:13:02
Commandline: apt install nfs-common
Install: libtirpc-common:amd64 (1.1.4-1, automatic), libtirpc3:amd64 (1.1.4-1, automatic), libevent-2.1-7:amd64 (2.1.11-stable-1, automatic), rpcbind:amd64 (1.2.5-8, automatic), nfs-common:amd64 (1:1.3.4-2.5+b1), libnfsidmap2:amd64 (0.25-5.1, automatic)
End-Date: 2019-12-05  07:13:18

Start-Date: 2019-12-06  23:09:20
Commandline: /usr/sbin/synaptic
Requested-By: user (1000)
Downgrade: firefox-esr-l10n-ru:amd64 (68.2.0esr-1~deb9u2, 60.7.1esr-1~deb9u1), firefox-esr:amd64 (68.2.0esr-1~deb9u2, 60.7.1esr-1~deb9u1)
End-Date: 2019-12-06  23:09:44

Start-Date: 2019-12-06  23:12:05
Commandline: /usr/sbin/synaptic
Requested-By: user (1000)
Install: libfreetype-dev:amd64 (2.10.1-2)
Upgrade: libsqlite3-0:amd64 (3.27.2-3, 3.30.1-1), libsqlite3-0:i386 (3.27.2-3, 3.30.1-1), zlib1g:amd64 (1:1.2.8.dfsg-5, 1:1.2.11.dfsg-1+b1), zlib1g:i386 (1:1.2.8.dfsg-5, 1:1.2.11.dfsg-1+b1), zlib1g-dev:amd64 (1:1.2.8.dfsg-5, 1:1.2.11.dfsg-1+b1), sqlite3:amd64 (3.27.2-3, 3.30.1-1), libfreetype6-dev:amd64 (2.9.1-3, 2.10.1-2), libnss3:amd64 (2:3.42.1-1, 2:3.47.1-1), libnss3:i386 (2:3.42.1-1, 2:3.47.1-1), libfreetype6:amd64 (2.9.1-3, 2.10.1-2), libfreetype6:i386 (2.9.1-3, 2.10.1-2), libnspr4:amd64 (2:4.20-1, 2:4.23-1), libnspr4:i386 (2:4.20-1, 2:4.23-1)
End-Date: 2019-12-06  23:12:20

Start-Date: 2019-12-07  11:32:20
Commandline: /usr/bin/unattended-upgrade
Upgrade: firefox-esr-l10n-ru:amd64 (60.7.1esr-1~deb9u1, 68.2.0esr-1~deb9u2), firefox-esr:amd64 (60.7.1esr-1~deb9u1, 68.2.0esr-1~deb9u2)
End-Date: 2019-12-07  11:32:31


Im_not_robot ()
Ответ на: комментарий от Im_not_robot

В таком случае у вас несколько вариантов:

  1. Зафиксировать firefox, как предложил @Qathos. unattended-upgrades не должен обновлять такие пакеты.

  2. Отключить автоматические обновления через unattended-upgrades, тем более что в buster так по умолчанию. sudo dpkg-reconfigure unattended-upgrades.

Rootlexx ()