LINUX.ORG.RU

установка программ


0

0

при попытке установить какю-либо программу из исходников в FC5 после набора ./cjnfigure возникает сообщение bash: ./configure Отказано в доступе. что делать? когда в главном меню запускаю Add/Remove Software он начинает лезть в интернет. как его отучить это делать? и еще один вопрос если у меня есть пакет rpm как мне узнать его зависимости?


Re: установка программ

>при попытке установить какю-либо программу из исходников в FC5 после набора ./cjnfigure возникает сообщение bash: ./configure Отказано в доступе. что делать? хз, отсюда не видно >когда в главном меню запускаю Add/Remove Software он начинает лезть в интернет. как его отучить это делать? настроить yum >и еще один вопрос если у меня есть пакет rpm как мне узнать его зависимости? для этого есть yum. за подробностями man yum простой способ: rpm -qp --requires /path/to/rpm за подробностями man rpm

vyv ★★ ()

Re: установка программ

>после набора ./cjnfigure возникает сообщение bash: ./configure Отказано в доступе.

Возможно, просто не установлен бит исполняемости. Попробуйте chmod +x ./configure

>и еще один вопрос если у меня есть пакет rpm как мне узнать его зависимости?

rpm -qpR имя_пакета.rpm

php-coder ★★★★★ ()
Ответ на: Re: установка программ от php-coder

Re: установка программ

Или скорей сброшен, если попытаться собрать что-нибудь, распаковав на диск с FAT, например.

dn2010 ★★★★★ ()
Ответ на: Re: установка программ от dn2010

Re: установка программ

с первой проблемой разобрался, просто диск был смонтирован в режиме showexec я изменил его на exec и все стало нормально. а вот нормально настроить yum пока не получается. пробовал скинуть rpm'ы с dvd на диск потом createrepo /path/to/rpms, после этого делал файл /etc/yum.repos.d/my.repo с содержимым

[main] gpgcheck=1 [My] name=My baseurl=file:///path/to/rpms

проверяю yum list он мне пишет что не может найти путь к main репозитарию, а из локального ничего ставить не хочет.

aniv ()
Ответ на: Re: установка программ от jackill

Re: установка программ

наконец-то настроил yum. так и не понял в чем проблема была. повторил все шаги с самого начала и все заработало

aniv ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.