LINUX.ORG.RU

Ошибка сегментирования

 ,


0

1

Приветствую, подскажите пожалуйста.

Есть программа myBase, она не устанавливается в систему, а просто извлекается из архива в домашней каталоге и запускается. С ней рядом идут библиотеки: libQtCore.so.4, libQtGui.so.4, libQtNetwork.so.4, libQtScript.so.4, libQtSvg.so.4, libQtWebKit.so.4. И файл myBase.run, в котором, как я понял, указывается путь к библиотекам (export LD_LIBRARY_PATH=«$PROGDIR:$LD_LIBRARY_PATH»). В стандартной директории /usr/lib/x86_64-linux-gnu/ у меня тоже есть эти библиотеки (только это ссылки на них). Так вот, когда запускаю командой

./myBase.run
, то программа запускается (используются библиотеки из поставки), но не работает скачивание и отображение изображений с https сайтов (а это мне очень нужно (с http работает)). Если запускаю командой
./myBase
, то программа не запускается (используются библиотеки из /usr/lib/x86_64-linux-gnu/) и появляется «Ошибка сегментирования». Если запускаю командой
sudo QT_X11_NO_MITSHM=1 ./myBase
, то программа работает и скачивание с https сайтов тоже! Но не работает открытие ссылок в браузере (xdg-open) (это тоже нужно).

Вот вывод

ldd myBase:
linux-vdso.so.1 (0x00007ffc8012e000)
	libz.so.1 => /lib/x86_64-linux-gnu/libz.so.1 (0x00007fc454f71000)
	libQtWebKit.so.4 => /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4 (0x00007fc452abf000)
	libQtScript.so.4 => /usr/lib/x86_64-linux-gnu/libQtScript.so.4 (0x00007fc4525fe000)
	libQtGui.so.4 => /usr/lib/x86_64-linux-gnu/libQtGui.so.4 (0x00007fc451910000)
	libQtNetwork.so.4 => /usr/lib/x86_64-linux-gnu/libQtNetwork.so.4 (0x00007fc4515bc000)
	libQtCore.so.4 => /usr/lib/x86_64-linux-gnu/libQtCore.so.4 (0x00007fc4510c9000)
	libstdc++.so.6 => /usr/lib/x86_64-linux-gnu/libstdc++.so.6 (0x00007fc450d47000)
	libm.so.6 => /lib/x86_64-linux-gnu/libm.so.6 (0x00007fc450a43000)
	libgcc_s.so.1 => /lib/x86_64-linux-gnu/libgcc_s.so.1 (0x00007fc45082c000)
	libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007fc45048d000)
	libXrender.so.1 => /usr/lib/x86_64-linux-gnu/libXrender.so.1 (0x00007fc450283000)
	libjpeg.so.62 => /usr/lib/x86_64-linux-gnu/libjpeg.so.62 (0x00007fc450018000)
	libpng16.so.16 => /usr/lib/x86_64-linux-gnu/libpng16.so.16 (0x00007fc44fde5000)
	libgstapp-1.0.so.0 => /usr/lib/x86_64-linux-gnu/libgstapp-1.0.so.0 (0x00007fc44fbd7000)
	libgstpbutils-1.0.so.0 => /usr/lib/x86_64-linux-gnu/libgstpbutils-1.0.so.0 (0x00007fc44f9a2000)
	libgstvideo-1.0.so.0 => /usr/lib/x86_64-linux-gnu/libgstvideo-1.0.so.0 (0x00007fc44f717000)
	libgstaudio-1.0.so.0 => /usr/lib/x86_64-linux-gnu/libgstaudio-1.0.so.0 (0x00007fc44f4ac000)
	libgstbase-1.0.so.0 => /usr/lib/x86_64-linux-gnu/libgstbase-1.0.so.0 (0x00007fc44f248000)
	libgstreamer-1.0.so.0 => /usr/lib/x86_64-linux-gnu/libgstreamer-1.0.so.0 (0x00007fc44ef16000)
	libgobject-2.0.so.0 => /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0 (0x00007fc44ecc3000)
	libglib-2.0.so.0 => /lib/x86_64-linux-gnu/libglib-2.0.so.0 (0x00007fc44e9af000)
	libsqlite3.so.0 => /usr/lib/x86_64-linux-gnu/libsqlite3.so.0 (0x00007fc44e6a7000)
	libfontconfig.so.1 => /usr/lib/x86_64-linux-gnu/libfontconfig.so.1 (0x00007fc44e469000)
	libpthread.so.0 => /lib/x86_64-linux-gnu/libpthread.so.0 (0x00007fc44e24c000)
	libQtXmlPatterns.so.4 => /usr/lib/x86_64-linux-gnu/libQtXmlPatterns.so.4 (0x00007fc44dbc7000)
	libQtOpenGL.so.4 => /usr/lib/x86_64-linux-gnu/libQtOpenGL.so.4 (0x00007fc44d8c5000)
	libGL.so.1 => /usr/lib/x86_64-linux-gnu/libGL.so.1 (0x00007fc44d653000)
	libX11.so.6 => /usr/lib/x86_64-linux-gnu/libX11.so.6 (0x00007fc44d313000)
	libaudio.so.2 => /usr/lib/x86_64-linux-gnu/libaudio.so.2 (0x00007fc44d0f9000)
	libfreetype.so.6 => /usr/lib/x86_64-linux-gnu/libfreetype.so.6 (0x00007fc44ce4a000)
	libSM.so.6 => /usr/lib/x86_64-linux-gnu/libSM.so.6 (0x00007fc44cc42000)
	libICE.so.6 => /usr/lib/x86_64-linux-gnu/libICE.so.6 (0x00007fc44ca25000)
	libXext.so.6 => /usr/lib/x86_64-linux-gnu/libXext.so.6 (0x00007fc44c813000)
	libdl.so.2 => /lib/x86_64-linux-gnu/libdl.so.2 (0x00007fc44c60f000)
	librt.so.1 => /lib/x86_64-linux-gnu/librt.so.1 (0x00007fc44c407000)
	/lib64/ld-linux-x86-64.so.2 (0x00007fc45518b000)
	libgsttag-1.0.so.0 => /usr/lib/x86_64-linux-gnu/libgsttag-1.0.so.0 (0x00007fc44c1cc000)
	liborc-0.4.so.0 => /usr/lib/x86_64-linux-gnu/liborc-0.4.so.0 (0x00007fc44bf4e000)
	libgmodule-2.0.so.0 => /usr/lib/x86_64-linux-gnu/libgmodule-2.0.so.0 (0x00007fc44bd4a000)
	libffi.so.6 => /usr/lib/x86_64-linux-gnu/libffi.so.6 (0x00007fc44bb41000)
	libpcre.so.3 => /lib/x86_64-linux-gnu/libpcre.so.3 (0x00007fc44b8ce000)
	libexpat.so.1 => /lib/x86_64-linux-gnu/libexpat.so.1 (0x00007fc44b6a4000)
	libxcb-dri3.so.0 => /usr/lib/x86_64-linux-gnu/libxcb-dri3.so.0 (0x00007fc44b4a1000)
	libxcb-present.so.0 => /usr/lib/x86_64-linux-gnu/libxcb-present.so.0 (0x00007fc44b29e000)
	libxcb-sync.so.1 => /usr/lib/x86_64-linux-gnu/libxcb-sync.so.1 (0x00007fc44b097000)
	libxshmfence.so.1 => /usr/lib/x86_64-linux-gnu/libxshmfence.so.1 (0x00007fc44ae95000)
	libglapi.so.0 => /usr/lib/x86_64-linux-gnu/libglapi.so.0 (0x00007fc44ac66000)
	libXdamage.so.1 => /usr/lib/x86_64-linux-gnu/libXdamage.so.1 (0x00007fc44aa63000)
	libXfixes.so.3 => /usr/lib/x86_64-linux-gnu/libXfixes.so.3 (0x00007fc44a85d000)
	libX11-xcb.so.1 => /usr/lib/x86_64-linux-gnu/libX11-xcb.so.1 (0x00007fc44a65b000)
	libxcb.so.1 => /usr/lib/x86_64-linux-gnu/libxcb.so.1 (0x00007fc44a433000)
	libxcb-glx.so.0 => /usr/lib/x86_64-linux-gnu/libxcb-glx.so.0 (0x00007fc44a218000)
	libxcb-dri2.so.0 => /usr/lib/x86_64-linux-gnu/libxcb-dri2.so.0 (0x00007fc44a013000)
	libXxf86vm.so.1 => /usr/lib/x86_64-linux-gnu/libXxf86vm.so.1 (0x00007fc449e0d000)
	libdrm.so.2 => /usr/lib/x86_64-linux-gnu/libdrm.so.2 (0x00007fc449bfd000)
	libXt.so.6 => /usr/lib/x86_64-linux-gnu/libXt.so.6 (0x00007fc449994000)
	libXau.so.6 => /usr/lib/x86_64-linux-gnu/libXau.so.6 (0x00007fc449790000)
	libuuid.so.1 => /lib/x86_64-linux-gnu/libuuid.so.1 (0x00007fc44958b000)
	libbsd.so.0 => /lib/x86_64-linux-gnu/libbsd.so.0 (0x00007fc449375000)
	libXdmcp.so.6 => /usr/lib/x86_64-linux-gnu/libXdmcp.so.6 (0x00007fc44916f000)

Но если положить библиотеки, которые шли с программой в /usr/lib/x86_64-linux-gnu/, то вывод короче:

	linux-vdso.so.1 (0x00007ffc37bfd000)
	libz.so.1 => /lib/x86_64-linux-gnu/libz.so.1 (0x00007f231cf15000)
	libQtWebKit.so.4 => /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4 (0x00007f231b3fb000)
	libQtScript.so.4 => /usr/lib/x86_64-linux-gnu/libQtScript.so.4 (0x00007f231af54000)
	libQtGui.so.4 => /usr/lib/x86_64-linux-gnu/libQtGui.so.4 (0x00007f231a2b3000)
	libQtNetwork.so.4 => /usr/lib/x86_64-linux-gnu/libQtNetwork.so.4 (0x00007f2319f9b000)
	libQtCore.so.4 => /usr/lib/x86_64-linux-gnu/libQtCore.so.4 (0x00007f2319aaa000)
	libstdc++.so.6 => /usr/lib/x86_64-linux-gnu/libstdc++.so.6 (0x00007f2319728000)
	libm.so.6 => /lib/x86_64-linux-gnu/libm.so.6 (0x00007f2319424000)
	libgcc_s.so.1 => /lib/x86_64-linux-gnu/libgcc_s.so.1 (0x00007f231920d000)
	libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007f2318e6e000)
	libX11.so.6 => /usr/lib/x86_64-linux-gnu/libX11.so.6 (0x00007f2318b2e000)
	libXrender.so.1 => /usr/lib/x86_64-linux-gnu/libXrender.so.1 (0x00007f2318924000)
	libpthread.so.0 => /lib/x86_64-linux-gnu/libpthread.so.0 (0x00007f2318707000)
	libglib-2.0.so.0 => /lib/x86_64-linux-gnu/libglib-2.0.so.0 (0x00007f23183f3000)
	libpng12.so.0 => /lib/x86_64-linux-gnu/libpng12.so.0 (0x00007f23181cc000)
	libfreetype.so.6 => /usr/lib/x86_64-linux-gnu/libfreetype.so.6 (0x00007f2317f1d000)
	libfontconfig.so.1 => /usr/lib/x86_64-linux-gnu/libfontconfig.so.1 (0x00007f2317cdf000)
	libXext.so.6 => /usr/lib/x86_64-linux-gnu/libXext.so.6 (0x00007f2317acd000)
	libdl.so.2 => /lib/x86_64-linux-gnu/libdl.so.2 (0x00007f23178c9000)
	librt.so.1 => /lib/x86_64-linux-gnu/librt.so.1 (0x00007f23176c1000)
	/lib64/ld-linux-x86-64.so.2 (0x00007f231d12f000)
	libxcb.so.1 => /usr/lib/x86_64-linux-gnu/libxcb.so.1 (0x00007f2317499000)
	libpcre.so.3 => /lib/x86_64-linux-gnu/libpcre.so.3 (0x00007f2317226000)
	libpng16.so.16 => /usr/lib/x86_64-linux-gnu/libpng16.so.16 (0x00007f2316ff3000)
	libexpat.so.1 => /lib/x86_64-linux-gnu/libexpat.so.1 (0x00007f2316dc9000)
	libXau.so.6 => /usr/lib/x86_64-linux-gnu/libXau.so.6 (0x00007f2316bc5000)
	libXdmcp.so.6 => /usr/lib/x86_64-linux-gnu/libXdmcp.so.6 (0x00007f23169bf000)
	libbsd.so.0 => /lib/x86_64-linux-gnu/libbsd.so.0 (0x00007f23167a9000)

Найди исходные коды этой программы и скомпилируй ее в своей системе под свои библиотеки.

anonymous ()

Проверь зависимости библиотек из поставки программы посредством утилиты ldd и задания LD_LIBRARY_PATH.

anonymous ()

sudo
sudo
sudo

обнови программу, куте4 остался в 2010.

А зачем тебе от другого пользователя запускать?

anonymous ()
Ответ на: комментарий от anonymous

Найди исходные коды этой программы и скомпилируй ее в своей системе под свои библиотеки.

Не могу, она проприетарная!

Проверь зависимости библиотек из поставки программы посредством утилиты ldd и задания LD_LIBRARY_PATH.

Так я же написал вывод ldd

обнови программу, куте4 остался в 2010.

А зачем тебе от другого пользователя запускать?

Это последняя версия программы. Я запускаю от рута, потому что только через него программа работает и скачивает изображения с https сайтов! А без рута эта ошибка сегментации

PokerMagnat ()
Ответ на: комментарий от PokerMagnat

Простой вариант, запускай браузер от рута. Что это не работает? У меня xdg-open постоянно норовит открыть браузер от рута. Хотя нет, то у mc проблема такая. Ещё можно логиниться в DE от рута. Будет работать?

Только учитывай, что ты напрашиваешься на вирусню в таком случае. Браузер это основной вектор заражения рабочей станции, и при наличии прав всякой дряни надёжно прописаться труда не составит.

anonymous ()
Ответ на: комментарий от anonymous

Вот вывод программы при открытии ссылки:

[15191:15191:1117/163105.822942:ERROR:zygote_host_impl_linux.cc(89)] Running as root without --no-sandbox is not supported. See https://crbug.com/638180.
[15201:15201:1117/163105.854877:ERROR:zygote_host_impl_linux.cc(89)] Running as root without --no-sandbox is not supported. See https://crbug.com/638180.
Running Firefox as root in a regular user's session is not supported.  ($XAUTHORITY is /run/user/1000/gdm/Xauthority which is owned by george.)
/usr/bin/xdg-open: 778: /usr/bin/xdg-open: iceweasel: not found
/usr/bin/xdg-open: 778: /usr/bin/xdg-open: seamonkey: not found
/usr/bin/xdg-open: 778: /usr/bin/xdg-open: mozilla: not found
/usr/bin/xdg-open: 778: /usr/bin/xdg-open: epiphany: not found
/usr/bin/xdg-open: 778: /usr/bin/xdg-open: konqueror: not found
/usr/bin/xdg-open: 778: /usr/bin/xdg-open: chromium-browser: not found
[15229:15229:1117/163105.906982:ERROR:zygote_host_impl_linux.cc(89)] Running as root without --no-sandbox is not supported. See https://crbug.com/638180.
/usr/bin/xdg-open: 778: /usr/bin/xdg-open: www-browser: not found
/usr/bin/xdg-open: 778: /usr/bin/xdg-open: links2: not found
/usr/bin/xdg-open: 778: /usr/bin/xdg-open: elinks: not found
/usr/bin/xdg-open: 778: /usr/bin/xdg-open: links: not found
/usr/bin/xdg-open: 778: /usr/bin/xdg-open: lynx: not found
/usr/bin/xdg-open: 778: /usr/bin/xdg-open: w3m: not found
xdg-open: no method available for opening 'https://en.wikipedia.org/wiki/C_(programming_language)'

Запустил chrome под рутом, не помогло. И вирусов не хочется!

PokerMagnat ()
Ответ на: комментарий от PokerMagnat

Если она проприетарная, то ставь дистрибутива Linux того периода когда была скомпилирована программа, а луче даже той версии под которой собиралась программа и запускай её в этом дистрибутиве.

А так, что это за программа, что она делает, может проще использовать другой инструмент для решения выполняемых ею задач?

anonymous ()
Ответ на: комментарий от anonymous

Если она проприетарная, то ставь дистрибутива Linux того периода когда была скомпилирована программа, а луче даже той версии под которой собиралась программа и запускай её в этом дистрибутиве.

А так, что это за программа, что она делает, может проще использовать другой инструмент для решения выполняемых ею задач?

Нет, она не имеет аналогов, это лучшая программа в своем роде! Я спросил у человека с такой же версией debian, у него все нормально работает! Причем вывод ldd myBase точно такой же я сравнил! Да и последняя версия в октябре вышла!

PokerMagnat ()
Ответ на: комментарий от PokerMagnat

Я спросил у человека с такой же версией debian

С какой конкретно. Для Debian 9 уже вышло 6 обновлений с исправлением ошибок и обновлением пакетов, попроси у человека вывод dpkg -l и сравни его со своим, какие версии пакетов стоят у тебя, а какие у него.

В идеале скопируй у него систему и используй её.

Ты так и не ответил что делает эта программа.

anonymous ()
Ответ на: комментарий от anonymous

В идеале скопируй у него систему и используй её.

Ты так и не ответил что делает эта программа.

Это программа - аутлайнер. Лучшая в своей области! Её делает вручную 1 китаец из провинции! Я не знаю говорит ли он по-английски, надо спросить у него!

С какой конкретно. Для Debian 9 уже вышло 6 обновлений с исправлением ошибок и обновлением пакетов, попроси у человека вывод dpkg -l и сравни его со своим, какие версии пакетов стоят у тебя, а какие у него.

Вполне возможно, что версии библиотек разные, попробую узнать!

PokerMagnat ()
Ответ на: комментарий от PokerMagnat

Проприетарная проограмма, которую делает какой-то китаец из провинции - тебя здесь ничто не напрягает?

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.