LINUX.ORG.RU

Помогите победить неработающий таймер планировщика

 , ,


0

1

Есть скрипт (сервис), вроде работает.Для автоматизации создан таймер, но не работает почему то.Подскажите что не так?Надо что бы он работал без прав админа от обычного пользователя.

[Unit]
Description=Delete old /home/ files

[Service]
Type=oneshot
Nice=10
ExecStart=/usr/bin/find /home/test/Изображения/ -type f -mtime +77 -delete


[Install]
WantedBy=multi-user.target


и сам таймер для планировщика 
[Unit]
Description=Execute Delete old /home/ files daily

[Timer]
OnBootSec=15min
OnUnitActiveSec=1w 

[Install]
WantedBy=timers.target

[Install]
WantedBy=multi-user.target

/etc/systemd/system/del_old_home_files.timer

все это добро заброшено в /etc/systemd/system/

Ответ на: комментарий от Radjah
ruman@ruman-VirtualBox:~$ systemctl status del_old_home_files.timer
● del_old_home_files.timer - Execute Delete old /home/ files daily
   Loaded: error (Reason: Invalid argument)
   Active: inactive (dead)

Авг 03 13:00:34 ruman-VirtualBox systemd[1]: [/etc/systemd/system/del_old_home_files.timer:14] Missing '='.
ruman@ruman-VirtualBox:~$ 

iROCK ()
Ответ на: комментарий от iROCK

Сейчас у тебя ошибка в юните. Тебе про это парсер юнитов говорит.

В юните таймера у тебя две секции [Install], чего быть не должно. Секция [Install] в юните-сервисе, который будет запускаться по таймеру, вообще не нужна.

Для добавления таймера не достаточно положить файлы юнитов в нужные каталоги, еще надо сделать systemctl enable и systemctl start для твоего таймера.

Ну и добавь тег systemd.

Radjah ★★★★★ ()
Последнее исправление: Radjah (всего исправлений: 1)