LINUX.ORG.RU

ubuntu 16 не работает alias

 


0

1

Всех категорически приветствую. Столкнулся с такой проблемой. Установлена ubuntu: Linux ubs-Default-string 4.13.0-43-generic #48~16.04.1-Ubuntu SMP Thu May 17 12:56:46 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

при даче команды alias ничего не выдает...

в файле .basrc вот что:

miner@ubs-Default-string:~$ cat ~/.bashrc

# ~/.bashrc: executed by bash(1) for non-login shells.
# see /usr/share/doc/bash/examples/startup-files (in the package bash-doc)
# for examples

# If not running interactively, don't do anything
case $- in
    *i*) ;;
      *) return;;
esac

# don't put duplicate lines or lines starting with space in the history.
# See bash(1) for more options
HISTCONTROL=ignoreboth

# append to the history file, don't overwrite it
shopt -s histappend

# for setting history length see HISTSIZE and HISTFILESIZE in bash(1)
HISTSIZE=1000
HISTFILESIZE=2000

# check the window size after each command and, if necessary,
# update the values of LINES and COLUMNS.
shopt -s checkwinsize

# If set, the pattern "**" used in a pathname expansion context will
# match all files and zero or more directories and subdirectories.
#shopt -s globstar

# make less more friendly for non-text input files, see lesspipe(1)
[ -x /usr/bin/lesspipe ] && eval "$(SHELL=/bin/sh lesspipe)"

# set variable identifying the chroot you work in (used in the prompt below)
if [ -z "${debian_chroot:-}" ] && [ -r /etc/debian_chroot ]; then
    debian_chroot=$(cat /etc/debian_chroot)
fi

# set a fancy prompt (non-color, unless we know we "want" color)
case "$TERM" in
    xterm-color|*-256color) color_prompt=yes;;
esac

# uncomment for a colored prompt, if the terminal has the capability; turned
# off by default to not distract the user: the focus in a terminal window
# should be on the output of commands, not on the prompt
#force_color_prompt=yes

if [ -n "$force_color_prompt" ]; then
    if [ -x /usr/bin/tput ] && tput setaf 1 >&/dev/null; then
        # We have color support; assume it's compliant with Ecma-48
        # (ISO/IEC-6429). (Lack of such support is extremely rare, and such
        # a case would tend to support setf rather than setaf.)
        color_prompt=yes
    else
        color_prompt=
    fi
fi

if [ "$color_prompt" = yes ]; then
    PS1='${debian_chroot:+($debian_chroot)}\[\033[01;32m\]\u@\h\[\033[00m\]:\[\033[01;34m\]\w\[\033[00m\]\$ '
else
    PS1='${debian_chroot:+($debian_chroot)}\u@\h:\w\$ '
fi
unset color_prompt force_color_prompt

# If this is an xterm set the title to user@host:dir
case "$TERM" in
xterm*|rxvt*)
    PS1="\[\e]0;${debian_chroot:+($debian_chroot)}\u@\h: \w\a\]$PS1"
    ;;
*)
    ;;
esac

# enable color support of ls and also add handy aliases
if [ -x /usr/bin/dircolors ]; then
    test -r ~/.dircolors && eval "$(dircolors -b ~/.dircolors)" || eval "$(dircolors -b)"
    alias ls='ls --color=auto'
    #alias dir='dir --color=auto'
    #alias vdir='vdir --color=auto'

    alias grep='grep --color=auto'
    alias fgrep='fgrep --color=auto'
    alias egrep='egrep --color=auto'
fi

# colored GCC warnings and errors
#export GCC_COLORS='error=01;31:warning=01;35:note=01;36:caret=01;32:locus=01:quote=01'

# some more ls aliases
alias ll='ls -alF'
alias la='ls -A'
alias l='ls -CF'
alias miner='tail -20f claymore/miner.output'

# Add an "alert" alias for long running commands.  Use like so:
#   sleep 10; alert
alias alert='notify-send --urgency=low -i "$([ $? = 0 ] && echo terminal || echo error)" "$(history|tail -n1|sed -e '\''s/^\s*[0-9]\+\s*//;s/[;&|]\s*alert$//'\'')"'


# Alias definitions.
# You may want to put all your additions into a separate file like
# ~/.bash_aliases, instead of adding them here directly.
# See /usr/share/doc/bash-doc/examples in the bash-doc package.

if [ -f ~/.bash_aliases ]; then
    . ~/.bash_aliases
fi

# enable programmable completion features (you don't need to enable
# this, if it's already enabled in /etc/bash.bashrc and /etc/profile
# sources /etc/bash.bashrc).
if ! shopt -oq posix; then
  if [ -f /usr/share/bash-completion/bash_completion ]; then
    . /usr/share/bash-completion/bash_completion
  elif [ -f /etc/bash_completion ]; then
    . /etc/bash_completion
  fi
fi

так же пробовал через файл .bash_aliases, прописал там строку вида:

alias miner='tail -20f claymore/miner.output'
перегружаюсь и так же ничего... Но, если прописать source ~/.bash_aliases то все благополучно видится. Можете подсказать куда копнуть? Спасибо.

прописать source ~/.bash_aliases

прописать куда? в .bashrc? Если да, то inline alias тоже должен работать. Как проверяешь результат?

Deleted ()
Ответ на: комментарий от Deleted

я прошу прощения, я не большой специалист, проверяю просто дав команду в терминале alias, там пусто, в то же время на другой машине все работает. inline alias мне к сожалению не знаком.

kolka88 ()

У вас это не внутри скрипта какого-нибудь случайно? Поведение оболочки когда вы терминал открываете и когда у вас какой-то скрипт неинтерактивно работает отличаются.

inline alias мне к сожалению не знаком.

Имелось ввиду просто выполнить команду alias имяАлиаса=<...> (ну вот это что вы в файл пишете) и проверить что ответит alias после этого.

micronekodesu ★★ ()
Последнее исправление: micronekodesu (всего исправлений: 1)
Ответ на: комментарий от micronekodesu

Нет, это не скрипт, alias прописан именно в ~/.bashrc при выполнении в терминале alias miner='tail -20f miner/miner.output' ничего не показывает, однако начинает работать команда miner то есть alias начинает работать в текущей сессии ssh, как только релогин alias отваливается :)

kolka88 ()
Ответ на: комментарий от kolka88

Так при выполнении этой команды ничего и не будет отображаться - она выполнилась, ошибок нет, на экран ничего выводить не нужно. Вы можете посмотреть все алиасы, определенные на данный момент, просто выполнив команду alias без каких-то параметров.

После релогина оно работать не будет и это нормально, потому что так вот алиасы эти сделаны, они работают только в рамках текущей сессии - нужно их «прописывать» каждый раз (руками или через ~/.bashrc или другие скрипты, которые оболочка читает при запуске).

Вообще я не вижу причин почему должно быть описываемое вами поведение. Откройте новую вкладку терминала и просто посмотрите какие алиасы есть (просто команда alias). Дальше исходя из этого уже будет видно.

И, кстати, вы бы полный путь к файлу указали, типа alias miner='tail -20f /home/kolka88/claymore/miner.output' (ну или где он у вас там)

micronekodesu ★★ ()
Ответ на: комментарий от micronekodesu

оно и прописано в .bashrc. При даче команды alias вообще ни одного alias не показывает... Полный путь указал, перезагрузил, результата не принесло :(

kolka88 ()
Ответ на: комментарий от kolka88

А что за терминал?

Покажите результат выполнения вот этой вот конструкции

[[ $- == *i* ]] && echo 'Interactive' || echo 'Not interactive' ; shopt -q login_shell && echo 'Login shell' || echo 'Not login shell'
micronekodesu ★★ ()
Ответ на: комментарий от kolka88

When an interactive shell that is not a login shell is started, bash reads and executes commands from /etc/bash.bashrc and ~/.bashrc, if these files exist

Для login shell вмсто ~/.bashrc одно из этого:

~/.bash_profile
~/.bash_login
~/.profile

Посмотри, что уже имеется(вангую наличие .profile) и туда допиши алиас. Но! Вот у меня на системе(Debian 9.4) ~/.profile исполняет ~/.bashrc:

# if running bash
if [ -n "$BASH_VERSION" ]; then
    # include .bashrc if it exists
    if [ -f "$HOME/.bashrc" ]; then
        . "$HOME/.bashrc"   #Лол
    fi
fi
Странно, так что выложи твой ~/.profile

Deleted ()
Ответ на: комментарий от Deleted

вот что в profile

# if running bash
if [ -n "$BASH_VERSION" ]; then
    # include .bashrc if it exists
    if [ -f "$HOME/.bashrc" ]; then
        . "$HOME/.bashrc"
    fi
fi

# set PATH so it includes user's private bin directories
PATH="$HOME/bin:$HOME/.local/bin:$PATH"

kolka88 ()
Ответ на: комментарий от kolka88

Коль скоро ты пишешь, что

Но, если прописать source ~/.bash_aliases то все благополучно видится

alias непосредственно в ~/.bashrc тоже должен работать. Ищи, ты на какой-то мелочи запоролся. man bash в помощь(секция INVOCATION в частности). Ну и из невероятного: проверь, что у тебя действительно bash в качестве шелла(echo "$SHELL $0").

P. S.: выше по треду вот такое видел:

текущей сессии ssh

ssh - это не опечатка от sh? Может ты по ssh ходишь, а bashrc на локалке поправил?

Deleted ()
Ответ на: комментарий от Deleted
admin@miner-15:~$ echo «$SHELL $0» 
/bin/bash -bash

ssh это не опечатка. Man поизучаю, просто надеюсь что кто то сталкивался с таким, потому что как то странно, на другой машине все работает, хотя все одно и то же.

kolka88 ()
Ответ на: комментарий от kolka88

ssh это не опечатка

Ну я надеюсь ты на удалённом хосте(куда по ssh ходишь) bashrc менял, а не на своём?

Deleted ()
Ответ на: комментарий от kolka88

ну в общем, если кому интересно, победили так, в файле ~/.bash_profile прописали следующее:

if [ -f ~/.bashrc ]; then
        . ~/.bashrc
fi

отключаемся, подключаемся заново и вуаля, alias работает. всем спасибо.

kolka88 ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.