LINUX.ORG.RU

Проблема с LUKS на LVM: Linux не видит зашифрованный swap-раздел при загрузке.

 , , ,


0

1

Есть свежеустановленный на LVM Debian 9. Три раздела в этом LVM зашифрованы cryptsetup.

При загрузке появляется такое сообщение:

WARNING: Failed to connect to lvmetad. Falling back to device scanning.
Gave up waiting for suspend/resume device
resume: Could not stat the resume device file '/dev/disk/by-uuid/1b082d18-...'
Please type in the full path name to try again
or press ENTER to boot the system: _"

При нажатии на Enter система не реагирует пару минут, после чего загружается в нормальном режиме. После загрузки swap все-таки подключился и работает:
$ sudo swapon --show
NAME TYPE SIZE USED PRIO
/dev/dm-7 partition 3,7G 0B -1

По какой-то причине нужный LVM раздел, Debian-SWAP, вообще не имеет своего UUID:
$ lsblk -o NAME,UUID

sda
├─sda1 2E3E-8F79
└─sda2 b21woQ-kFnl-atYO-gAiD-7gMG-N9gZ-OnbkKc
├─Debian-ROOT 8777a547-609a-41e5-bda6-b8c35f631efc
├─Debian-VAR d45af268-6629-4cc0-bc36-942c5380b8dd
├─Debian-USR 5209a445-2765-43bc-b2eb-c9497c0c8405
├─Debian-OPT 2b7a4a46-b796-4afe-90a9-58d36c9d7284
├─Debian-HOME d4a8caec-c318-4c20-8dc7-ee869de026ce
│ └─Debian-HOME_crypt 07d618a0-e0ad-4723-a899-2dca86f0baa1
├─Debian-SWAP
│ └─Debian-SWAP_crypt 4801349f-8692-4223-b774-5f481d7c54df
└─Debian-DATA b9d591f8-7dad-4a48-a1c3-67d22cc2ad3e
└─Debian-DATA_crypt 763b5fbe-80a5-46e5-b0f3-defaec8b3b1b

> По какой-то причине нужный LVM раздел, Debian-SWAP, вообще не имеет своего UUID:

Всё правильно делает LUKS.
Опять же - встроенная защита от лишних глаз.

Сравни вывод lsblk -f и sudo blkid.

blitz ()