LINUX.ORG.RU

пересобрать deb пакет FF57

 , ,


0

1

Хочется пересобрать firefox с парой патчей для Ubuntu (16.04).

Проблема в том, что build-dep не находит зависимостей. Говорит, нужен новый rust, а его нигде нет, ни в universe, ни в multiverse.

Попытался поставить rust тремя разными способами: локально (и передать PATH debuild), глобально из ppa:jonathonf/rustlang, и глобально из ppa mozilla security (вместе с их clang).

Во время комиляции вылетает ошибка cstddef file not found, err: true (подробнее тут).

1. Это вообще нормально, что build-dep поломанный?

2. В каком окружении нужно собирать deb пакет для firefox57?

★★★★

1. Это вообще нормально, что build-dep поломанный?

Он не поломанный - просто у тебя нет нужных пакетов.

В каком окружении нужно собирать deb пакет для firefox57?

В пакете должен быть адрес мейнтейнера - спроси его. Возможно, он собирает пакет со свежим Rust локально. Скажем, берет его из Buster.

tailgunner ★★★★★ ()
Последнее исправление: tailgunner (всего исправлений: 1)
Ответ на: комментарий от tailgunner

Он не поломанный - просто у тебя нет нужных пакетов.

Я наивно предполагал, что официальные пакеты стабильных версий debian и ubuntu воспроизводимо собираются на билдферме с той же версией дистрибутива. И если собрать что-то локально, то оно просто не попадет в дистрибутив.

В пакете должен быть адрес мейнтейнера - спроси его.

Maintainer: Ubuntu Mozilla Team <ubuntu-mozillateam@lists.ubuntu.com>; последняя активность 2012 год, подозреваю, что лист сдох. Вики не обновлялась несколько лет, там идет обсуждение Firefox 3.x и т.п.

В итоге будет проще не заморачиваться с пакетом, скоре всего.

Возможно, он собирает пакет со свежим Rust локально. Скажем, берет его из Buster.

По крайней мере с Rust 1.22.1 не собирается. А что такой buster? Не гуглится.

Davidov ★★★★ ()
Ответ на: комментарий от Davidov

Возможно, он собирает пакет со свежим Rust локально. Скажем, берет его из Buster.

По крайней мере с Rust 1.22.1 не собирается.

Этой версии Rust должно хватать и FF 57, и FF 58.

А что такой buster? Не гуглится.

Следующая версия Debian.

tailgunner ★★★★★ ()

Не путаем зёрна и плевела.
Firefox, изначально сделан для сборки `it's own way', без зависимостей от дистрибутивов.

За rust - могу сказать, что он не корректно установлен, по мнению Firefox.

Корректно, когда скачаешь rust с сайта rust, но не с депозитории debian.
Сделай это сначала, и не стесняйся спрашивать.

blitz ()
Ответ на: комментарий от Davidov

Как евr'ей евr'ею, поведаю тебе, Давид:

По крайней мере с Rust 1.22.1 не собирается. А что такой buster? Не гуглится.

таки собирается, и преотлично:

0:01.26   --enable-rust-simd
0:01.26   --enable-elf-hack
0:01.26   --enable-gold
...
03.45 checking for rustc... /home/blitz/.cargo/bin/rustc
03.45 checking for cargo... /home/blitz/.cargo/bin/cargo
03.53 checking rustc version... 1.21.0
03.55 checking cargo version... 0.22.0

blitz ()

1. Это вообще нормально, что build-dep поломанный?

Нет.

Так что либо вы что-то упустили, либо это баг.

2. В каком окружении нужно собирать deb пакет для firefox57?

В том, которое ставится на основную систему приказом # aptitude build-dep <package>.

Zmicier ★★★★★ ()
Ответ на: комментарий от tailgunner

В пакете должен быть адрес мейнтейнера - спроси его. Возможно, он собирает пакет со свежим Rust локально. Скажем, берет его из Buster.

Речь не о васянской сборке. В Xenial’e 57-й Файрфокс из коробки.

Zmicier ★★★★★ ()
Ответ на: комментарий от tailgunner

Он не поломанный

Да нет, похоже, что поломанный.

просто у тебя нет нужных пакетов.

Да нет, судя по тому, что я вижу в хранилице [0][1], их таки вообще нет.

[0] http://archive.ubuntu.com/ubuntu/dists/xenial-updates/universe/binary-amd64/P...
[1] http://archive.ubuntu.com/ubuntu/dists/xenial-security/universe/binary-amd64/...

Zmicier ★★★★★ ()
Последнее исправление: Zmicier (всего исправлений: 1)
Ответ на: комментарий от tailgunner

Таки нет!

[build-depends] rustc (>= 1.19.0)

https://packages.ubuntu.com/source/xenial/firefox

Package: rustc (1.17.0+dfsg2-8~ubuntu0.16.04.2) [security] [universe]

https://packages.ubuntu.com/xenial/rustc

Понимая, что оно может запаздывать, я перепроверил прямо по хранилищу (см. выше) — и это правда.

Zmicier ★★★★★ ()
Ответ на: комментарий от Zmicier

Речь не о васянской сборке. В Xenial’e 57-й Файрфокс из коробки.

Судя по проблемам - именно о васянской.

Таки нет!

А, ну тогда всё в порядке. Build-req удовлетворяются, пакеты собираются.

tailgunner ★★★★★ ()
Ответ на: комментарий от Davidov

В пакете должен быть адрес мейнтейнера - спроси его.

Maintainer: Ubuntu Mozilla Team <ubuntu-mozillateam@lists.ubuntu.com>; последняя активность 2012 год, подозреваю, что лист сдох. Вики не обновлялась несколько лет, там идет обсуждение Firefox 3.x и т.п.

Uploaded by: Chris Coulson on 2017-11-29 (инфа отсюда), попробуй с ним связатся. Погляди на лог билда (на той же страничке есть), сравни с тем что у тебя получается, может прояснится чего.

Возможно, проблема связана с тем что места в корне не хватает под сборку, оперативки/свопа, или еще чего-нибудь.

anonymous ()
Ответ на: комментарий от anonymous

Спасибо, анон. Попробовал собрать на другой машине, где больше места. Все получилось. У меня теперь firefox с опцией, чтобы работали мышиные жесты и менюшка. И можно скроллить табы мышкой.

Использовал ppa:ubuntu-mozilla-security/ppa для раста.

Davidov ★★★★ ()