LINUX.ORG.RU

Лаги видео

 , ,


1

3

Переодически начинается нечто такое: http://joxi.ru/J2bXNkPIXaOX8r И оно все чаще и чаще случается. Лаги с отрисовкой страшные. Тыкакаешь по вкладке - он не переключается.

в dmesg:

# dmesg | tail
[   63.208497] logitech-hidpp-device 0003:046D:101A.0004: HID++ 1.0 device connected.
[  117.868132] perf: interrupt took too long (2504 > 2500), lowering kernel.perf_event_max_sample_rate to 79000
[  164.862038] perf: interrupt took too long (3136 > 3130), lowering kernel.perf_event_max_sample_rate to 63000
[  368.986524] perf: interrupt took too long (3945 > 3920), lowering kernel.perf_event_max_sample_rate to 50000
[  771.767200] perf: interrupt took too long (4936 > 4931), lowering kernel.perf_event_max_sample_rate to 40000
[  776.436798] TCP: request_sock_TCP: Possible SYN flooding on port 45623. Sending cookies.  Check SNMP counters.
[ 1283.122732] TCP: request_sock_TCP: Possible SYN flooding on port 50923. Sending cookies.  Check SNMP counters.
[ 1572.903676] perf: interrupt took too long (5307 > 2500), lowering kernel.perf_event_max_sample_rate to 37000
[ 1581.473458] perf: interrupt took too long (5302 > 2500), lowering kernel.perf_event_max_sample_rate to 37000
[ 1698.716491] perf: interrupt took too long (5505 > 2500), lowering kernel.perf_event_max_sample_rate to 36000

Если сделать # echo 100000 > /proc/sys/kernel/perf_event_max_sample_rate - держится пару секунд, потом опять скидывается до 3x000.

# uname -a 
Linux alex-laptop 4.13.0-16-lowlatency #19~16.04.3-Ubuntu SMP PREEMPT Mon Oct 16 20:09:58 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux
# lspci
00:00.0 Host bridge: Intel Corporation Mobile 4 Series Chipset Memory Controller Hub (rev 09)
00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 09)
00:02.1 Display controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 09)
00:1a.0 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #4 (rev 03)
00:1a.1 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #5 (rev 03)
00:1a.2 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #6 (rev 03)
00:1a.7 USB controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #2 (rev 03)
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 1 (rev 03)
00:1c.3 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 4 (rev 03)
00:1d.0 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #1 (rev 03)
00:1d.1 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #2 (rev 03)
00:1d.2 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #3 (rev 03)
00:1d.7 USB controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #1 (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev 93)
00:1f.0 ISA bridge: Intel Corporation ICH9M LPC Interface Controller (rev 03)
00:1f.2 SATA controller: Intel Corporation 82801IBM/IEM (ICH9M/ICH9M-E) 4 port SATA Controller [AHCI mode] (rev 03)
00:1f.3 SMBus: Intel Corporation 82801I (ICH9 Family) SMBus Controller (rev 03)
02:00.0 Network controller: Qualcomm Atheros AR9285 Wireless Network Adapter (PCI-Express) (rev 01)

Чипсет GL40, камень Core2Duo T8600, 8Gb DDR3.

Сейчас вообще поймал такую фигню: https://pastebin.com/Qy0ZeW3v

При этом один из экранов на некторое время (около минуты) стал сплошного серого цвета (((

Suntechnic ★★★★★ ()

Какой-то драйвер/устройство жутко лажает и виснет в прерывании. Когда обработка прерывания занимает значительное время как раз такие лаги и происходят. Как определить конкретный драйвер/устройство - не знаю, честно говоря. Разве что отключать по-очереди через /sys. Я бы поставил на SATA. Покажи ещё /proc/interrupts

Kosyak ★★★★ ()
Ответ на: комментарий от Suntechnic

Ну там явно в видеодрайвере же косяк.

anonymous ()
Ответ на: комментарий от Suntechnic

О, пропустил эту пасту. Да, похоже именно драйвер видяхи и лажает.

Kosyak ★★★★ ()

Как вариант - попробовать другое ядро. Хотя, если прогрессирует само по себе, значит железо помирает.

Kosyak ★★★★ ()
Ответ на: комментарий от Kosyak

Как вариант - попробовать другое ядро. Хотя, если прогрессирует само по себе, значит железо помирает.

Уже ставил дрова из oibaf и возвращал назад. Пробовал на ядре 4.11 и загружался с LiveUSB Ubuntu 17.10 - там тоже самое (((

Умирает чипсет?

Suntechnic ★★★★★ ()
Ответ на: комментарий от anonymous

Или оперативка.

Memtest запускал - вроде нет ошибок. Планки местами менял.

Suntechnic ★★★★★ ()
Ответ на: комментарий от Kosyak

Может ли это быть следствием замены камня?

Родной Celeron T3300, после этого стоял Core2Duo T6600, а сейчас стоит T8300. Менял недавно относительно.

А проблемой плохого контакта на шлейфе матрицы? Он там глючил при последней сборке, поэтому не хочу лишний раз разбирать - менять камень.

Suntechnic ★★★★★ ()
Ответ на: комментарий от Suntechnic

я хз у меня такая же проблема, тоже не пойму в чем дело. пробовал разные опции ядра не помогло:


cat /proc/interrupts 
           CPU0       CPU1       CPU2       CPU3       
  0:         48          0          0          0   IO-APIC   0-edge      timer
  8:          0          0          0          0   IO-APIC   8-edge      rtc0
  9:          0          0          0          0   IO-APIC   9-edge      acpi
 14:          0          0          0          0   IO-APIC  14-edge      pata_amd
 15:          0          0          0          0   IO-APIC  15-edge      pata_amd
 20:          0          0          0          0   IO-APIC  20-fasteoi   sata_nv
 21:      36710     154764          0          0   IO-APIC  21-fasteoi   sata_nv, snd_hda_intel:card0
 22:          3          0          0          0   IO-APIC  22-fasteoi   ehci_hcd:usb1
 23:      63092          0          0          0   IO-APIC  23-fasteoi   sata_nv, ohci_hcd:usb2
 24:        124          0          0          0   PCI-MSI 526336-edge      snd_hda_intel:card1
 25:         13          0          0      76231   PCI-MSI 524288-edge      radeon
 26:      36926          0      52032          0   PCI-MSI 278528-edge      enp0s17
NMI:        165        146        136        163   Non-maskable interrupts
LOC:     370920     255584     257624     373158   Local timer interrupts
SPU:          0          0          0          0   Spurious interrupts
PMI:        165        146        136        163   Performance monitoring interrupts
IWI:          1          0          0          0   IRQ work interrupts
RTR:          0          0          0          0   APIC ICR read retries
RES:      39778      35746      34436      42463   Rescheduling interrupts
CAL:      83061      73946      58094     102739   Function call interrupts
TLB:      62071      63478      51266      79915   TLB shootdowns
TRM:          0          0          0          0   Thermal event interrupts
THR:          0          0          0          0   Threshold APIC interrupts
DFR:          0          0          0          0   Deferred Error APIC interrupts
MCE:          0          0          0          0   Machine check exceptions
MCP:          8          8          8          8   Machine check polls
HYP:          0          0          0          0   Hypervisor callback interrupts
ERR:          1
MIS:          0
PIN:          0          0          0          0   Posted-interrupt notification event
NPI:          0          0          0          0   Nested posted-interrupt event
PIW:          0          0          0          0   Posted-interrupt wakeup event

rw amdgpu.dc=1 acpi_os_name=Windows 2009 acpi_osi=!Windows2009 acpi_osi=Linux acpi_osi=!! radeon.dpm=0 radeon.audio=0 acpi_apic_instance=2 acpi_force_32bit_fadt_addr acpi_mask_gpe=0x7f acpi_sci=edge spectre_v2=auto pti=auto x2apic_phys acpi_osi=Linux acpi=acpi_pm hpet=disable clocksource=hpet quiet

мать striker ii nse киты правда памяти разные слегка 2хпо 4гб итого 8гб озу, одни 10800 другие какие то8700 уже не помню как inxi модули из SPD посмотреть:

Graphics:  Card: Advanced Micro Devices [AMD/ATI] Caicos [Radeon HD 6450/7450/8450 / R5 230 OEM]
           Display Server: x11 (X.Org 1.19.6 )
           drivers: ati,radeon (unloaded: modesetting,fbdev,vesa)
           Resolution: 1920x1080@60.00hz
           OpenGL: renderer: AMD CAICOS (DRM 2.50.0 / 4.14.15-1-ARCH, LLVM 5.0.1)
           version: 3.3 Mesa 17.3.3
Audio:     Card-1 Advanced Micro Devices [AMD/ATI] Caicos HDMI Audio [Radeon HD 6450 / 7450/8450/8490 OEM / R5 230/235/235X OEM]
           driver: snd_hda_intel
           Card-2 NVIDIA MCP55 High Def. Audio driver: snd_hda_intel
           Sound: Advanced Linux Sound Architecture v: k4.14.15-1-ARCH

я тоже грешил на IO nvsata или видяху, ноо radeon.dpm=0 не помогает да и radeon.audio=0 тоже. DSDT пока не доправил до конца, начал и забил там адски много править надо биос 2009 года ACPI 2.0 наверное.

короче жопа, проще 7ку поставить и старые дрова нвшки...
zor1984qq ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.