LINUX.ORG.RU

Centos статический IP

 ,


0

1

Здравствуйте. не могу настроить статический IP на Centos.

# статическая конфигурация интерфейса
DEVICE="eth0"
BOOTPROTO="static"
DNS1=8.8.8.8
IPADDR0=192.168.1.4
PREFIX0=24
GATEWAY0=192.168.1.1
NM_CONTROLLED="no"
DEFROUTE="yes"
NAME="eth0"
UUID="0692785f-e4ea-4c60-a22b-69aa5207143c"
ONBOOT="yes"

но когда стартую сервис, ошибка.

[root@centos-rpi3 network-scripts]# systemctl status network.service
● network.service - LSB: Bring up/down networking
   Loaded: loaded (/etc/rc.d/init.d/network; bad; vendor preset: disabled)
   Active: failed (Result: exit-code) since Fri 2017-10-20 09:48:01 UTC; 11min ago
     Docs: man:systemd-sysv-generator(8)
  Process: 1151 ExecStart=/etc/rc.d/init.d/network start (code=exited, status=6)

Oct 20 09:48:01 centos-rpi3 systemd[1]: Starting LSB: Bring up/down networking...
Oct 20 09:48:01 centos-rpi3 systemd[1]: network.service: control process exited, code=exited status=6
Oct 20 09:48:01 centos-rpi3 systemd[1]: Failed to start LSB: Bring up/down networking.
Oct 20 09:48:01 centos-rpi3 systemd[1]: Unit network.service entered failed state.
Oct 20 09:48:01 centos-rpi3 systemd[1]: network.service failed.

Интерфейса eth0 хоть есть? Ты выключил предсказуемые сетевые имена?

Покажи

ip a
И если мне не изменяет память, в конфигурационном файле сетевого адаптера указывается привязка к мак адресу.

kostik87 ★★★★★ ()
Ответ на: комментарий от kostik87
[root@centos-rpi3 network-scripts]# ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN qlen 1
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP qlen 1000
    link/ether b8:27:eb:05:7e:22 brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.4/24 brd 192.168.1.255 scope global dynamic eth0
       valid_lft 86360sec preferred_lft 86360sec
    inet6 fe80::ba27:ebff:fe05:7e22/64 scope link
       valid_lft forever preferred_lft forever
3: wlan0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN qlen 1000
    link/ether 42:81:15:49:c7:27 brd ff:ff:ff:ff:ff:ff
[root@centos-rpi3 network-scripts]#
Apophis ()

А чем тебе nmtui не угодил? Не кошерный?

kerneliq ★★★★★ ()
Ответ на: комментарий от Apophis
# статическая конфигурация интерфейса
DEVICE="eth0"
BOOTPROTO="static"
DNS1=8.8.8.8
IPADDR=192.168.1.4
PREFIX=24
GATEWAY=192.168.1.1
NM_CONTROLLED="no"
DEFROUTE="yes"
NAME="eth0"
UUID="0692785f-e4ea-4c60-a22b-69aa5207143c"
ONBOOT="yes"

Вот так должно быть, а не GATEWAY0, IPADDR0, PREFIXO.

И вместо PREFIX=24 должно быть NETMASK=255.255.255.0

kostik87 ★★★★★ ()
Последнее исправление: kostik87 (всего исправлений: 1)
Ответ на: комментарий от kostik87
Спасибо. но пока что не стартует.
[root@centos-rpi3 network-scripts]# systemctl status network.service
● network.service - LSB: Bring up/down networking
   Loaded: loaded (/etc/rc.d/init.d/network; bad; vendor preset: disabled)
   Active: failed (Result: exit-code) since Fri 2017-10-20 10:13:39 UTC; 23s ago
     Docs: man:systemd-sysv-generator(8)
  Process: 1922 ExecStart=/etc/rc.d/init.d/network start (code=exited, status=6)

Oct 20 10:13:39 centos-rpi3 systemd[1]: Starting LSB: Bring up/down networking...
Oct 20 10:13:39 centos-rpi3 systemd[1]: network.service: control process exited, code=exited status=6
Oct 20 10:13:39 centos-rpi3 systemd[1]: Failed to start LSB: Bring up/down networking.
Oct 20 10:13:39 centos-rpi3 systemd[1]: Unit network.service entered failed state.
Oct 20 10:13:39 centos-rpi3 systemd[1]: network.service failed.
[root@centos-rpi3 network-scripts]#
Apophis ()
Ответ на: комментарий от Apophis
DEVICE="eth0"
HWADDR="b8:27:eb:05:7e:22"
NM_CONTROLLED="no"
ONBOOT="yes"
BOOTPROTO=static
IPADDR=192.168.1.4
NETMASK=255.255.255.0
GATEWAY=192.168.1.1
DNS1=8.8.8.8

Что в выводе

dmesg | tail
после попытки старта?

kostik87 ★★★★★ ()
Последнее исправление: kostik87 (всего исправлений: 1)
Ответ на: комментарий от kostik87

Странно. тут только это:

[root@centos-rpi3 network-scripts]# dmesg | tail
[ 8979.763259] brcmfmac: brcmf_cfg80211_add_iface: add iface p2p-dev-wlan0 type 10 failed: err=-16
[ 8979.790525] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 9198.024961] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 9198.029840] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 9198.033124] brcmfmac: power management disabled
[ 9198.566099] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 9198.569453] brcmfmac: power management disabled
[ 9198.689856] brcmfmac: brcmf_p2p_create_p2pdev: set p2p_disc error
[ 9198.693063] brcmfmac: brcmf_cfg80211_add_iface: add iface p2p-dev-wlan0 type 10 failed: err=-16
[ 9198.721835] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[root@centos-rpi3 network-scripts]#
Apophis ()
Ответ на: комментарий от Apophis

Запуск network.service приводит к инициализации всех сетевых интерфейсов, в конфигурационный файлах которых прописано ONBOOT=«yes», если конфигурационного файла для wlan0 нет, то читай какое поведение по умолчанию в таком случае.

В выводе

ip a
видно, что интерфейсу eth0 уже назначен нужный IP адрес.

А то что у тебя в выводе

systemctl status network.service
Есть ошибки так это от поднятия wlan0.

kostik87 ★★★★★ ()
Последнее исправление: kostik87 (всего исправлений: 1)
Ответ на: комментарий от Apophis

Если ты ничего больше не трогал, то должна грузиться.

Подход в виде переустановки не выход, так у тебя не получится ничего.

kostik87 ★★★★★ ()
Ответ на: комментарий от kostik87

вместо PREFIX=24 должно быть NETMASK=255.255.255.0

PREFIX=24 тоже работает

imul ★★★★★ ()

Дружище, а у тебя оно ТОЧНО eth0 зовется?

Если ты специально не отключал, то сетевые интерфейсы у тебя должны быть ensXXXX

slamd64 ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.