LINUX.ORG.RU

Не работает виртуальный хост в lamp

 


0

1

Dzien dobry, проблема вот какая. Устанавливал командой:

sudo apt-get install apache2 libapache2-mod-php7.0 php7.0 php7.0-fpm phpmyadmin mariadb-server mariadb client <-- насчет последнего - точной версии не помню
Параллельно смотрел ролик на ютубе: watch?v=zsAXaX3Z9FQ Только у меня fastcgi что-то не нашелся. В общем, я создал хост путем создания конфига:
<VirtualHost *:80>
        ServerName cycles.off
        ServerAlias cycles.off *.cycles.off
        ServerAdmin webmaster@cycles.off
        DocumentRoot /home/ovin-off/www/cycles.off
        ErrorLog ${APACHE_LOG_DIR}/cycles.off-error.log
        CustomLog ${APACHE_LOG_DIR}/cycles.off-access.log combined
        ProxyPassMatch ^/(.*\.php(/.*)?)$ unix:/run/php/php7.0-fpm.sock|fcgi://localhost/home/ovin-off/www/cycles.off
</VirtualHost>

# vim: syntax=apache ts=4 sw=4 sts=4 sr noet

Ощущение, что нужно по-другому настроить ProxyPassMatch, ибо не стоит у меня fastcgi. Далее a2ensite cycles.off.conf перезапускаю apache, localhost открывается, cycles.off - нет. Что думаете?

P.S. поставил слеш в конце DocumentRoot, получаю теперь 403 Forbidden

Все получилось вот с таким конфигом:

 <VirtualHost *:80>
    ServerName ovin-off.off
     DirectoryIndex index.php
     DocumentRoot /home/ovin-off/www/ovin-off
     <Directory /home/ovin-off/www/ovin-off>
        Options Indexes FollowSymLinks MultiViews
         Require all granted
         Order allow,deny
         Allow from all
         AllowOverride All
     </Directory>
     ErrorLog ${APACHE_LOG_DIR}/error.log
     CustomLog ${APACHE_LOG_DIR}/access.log combined
 </VirtualHost>

sudoLife ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.