LINUX.ORG.RU

не собирается ruby gem на ubuntu 16

 , ,


0

1

Всем привет!

Пытаюсь установить ruby gem pg, получаю такую ошибку:

checking for PQconnectdb() in -lpq... no
checking for PQconnectdb() in -llibpq... no
checking for PQconnectdb() in -lms/libpq... no
Can't find the PostgreSQL client library (libpq)
потому что:
In file included from conftest.c:3:0:
/usr/include/postgresql/libpq-fe.h:250:16: note: declared here
 extern PGconn *PQconnectdb(const char *conninfo);
conftest.c: In function ‘t’:
conftest.c:15:15: error: too few arguments to function ‘PQconnectdb’
 int t(void) { PQconnectdb(); return 0; }

все нужные libpq-dev и прочие установлены, версия postgresql 9.5

Если я правильно понял версия postgres'a новее чем этот гем и pg-функции имеют другое кол-во аргументов.

Подскажите пожалуйста кто-нибудь сталкивался с подобным и как такое исправить?

спасибо.

★★★

Ответ на: комментарий от Anatolik

RVM делает много лишних вещей, поэтому я предпочитаю вместо него использовать ruby-build для сборки и chruby для переключения.

Anatolik ★★ ()
Ответ на: комментарий от Anatolik

используется:

bundle install --deployment
никаких rvm в системе нету.

установлено всё «что можно»:

ii  postgresql                         9.5+173                                    all          object-relational SQL database (supported version)
ii  postgresql-9.5                     9.5.8-0ubuntu0.16.04.1                     amd64        object-relational SQL database, version 9.5 server
ii  postgresql-client                  9.5+173                                    all          front-end programs for PostgreSQL (supported version)
ii  postgresql-client-9.5              9.5.8-0ubuntu0.16.04.1                     amd64        front-end programs for PostgreSQL 9.5
ii  postgresql-client-common           173                                        all          manager for multiple PostgreSQL client versions
ii  postgresql-common                  173                                        all          PostgreSQL database-cluster manager
ii  postgresql-contrib                 9.5+173                                    all          additional facilities for PostgreSQL (supported version)
ii  postgresql-contrib-9.5             9.5.8-0ubuntu0.16.04.1                     amd64        additional facilities for PostgreSQL
ii  libpq-dev                          9.5.8-0ubuntu0.16.04.1                     amd64        header files for libpq5 (PostgreSQL library)
ii  libpq5:amd64                       9.5.8-0ubuntu0.16.04.1                     amd64        PostgreSQL C client library
ii  libpqxx-4.0                        4.0.1+dfsg-3ubuntu2                        amd64        C++ library to connect to PostgreSQL
ii  libpqxx-dev                        4.0.1+dfsg-3ubuntu2                        amd64        C++ library to connect to PostgreSQL (development files)

fura13 ★★★ ()
Ответ на: комментарий от fura13

никаких rvm в системе нету

То есть, используется MRI, поставленный из репов? Можно посмотреть

which ruby
?

bundle install --deployment

Можно посмотреть Gemfile.lock?

Anatolik ★★ ()
Ответ на: комментарий от fura13

/opt/puppetlabs/puppet/bin//ruby

Похоже, проблема в том, что завендоренный Puppet'ом Ruby не видит системных библиотек.

Заведите отдельного пользователя для puppet-dashboard. Убедитесь, что когда вы делаете bundle install --deployment, which ruby возвращает другой путь(/usr/bin/ruby, например).

Anatolik ★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.