LINUX.ORG.RU

undefined reference to ... @OPENSSL_1.0.0'

 , ,


0

1

имеется арч, gcc{7.1.1, 5.4.0}, openssl1.0.1.{e,f,l,u}, boost1.57, db4.8.30

нужно: собрать сие чудо

делаю:

-->LC_ALL=POSIX qmake cannabiscoin-qt.pro \
BDB_INCLUDE_PATH=/usr/include/db4.8 \
OPENSSL_INCLUDE_PATH=/home/safff/git/openssl1.0.1.f/usr/include \
OPENSSL_LIB_PATH=/home/safff/git/openssl1.0.1.f/usr/lib \
BDB_LIB_SUFFIX="-4.8" USE_UPNP= \
BOOST_INCLUDE_PATH=/home/safff/git/boost57/usr/include \
BOOST_LIB_PATH=/home/safff/git/boost57/usr/lib

-->LC_ALL=POSIX make -j5


получаем

полученный MakeFile после конфигурации qmake'ом

★★

Ответ на: комментарий от safocl

может у разработчика на его машине всё работает, другая версия линкера м.б., х.з.

но в общем библиотеки при линковке должны перечисляться упорядоченно, сначала те, что требуют зависимостей, потом те, которые эти зависимости удовлетворяют

Harald ★★★★★ ()
Ответ на: комментарий от Harald

сначала те, что требуют зависимостей, потом те, которые эти зависимости удовлетворяют

мб наоборот? сначвала те которые предоставляют зависимости а потом которые требуют?

safocl ★★ ()
Ответ на: комментарий от Harald

ну я изменил:

было так

LIBS          = $(SUBLIBS) /home/safff/git/cannabiscoin420/src/leveldb/libleveldb.a /home/safff/git/cannabiscoin420/src/leveldb/libmemenv.a -lrt -L/home/safff/git/boost57/usr/lib -L/home/safff/git/openssl1.0.1.f/usr/lib -lssl -lcrypto -ldb_cxx-4.8 -lboost_system -lboost_filesystem -lboost_program_options -lboost_thread -lQt5Widgets -lQt5Gui -lQt5Network -lQt5Core -lpthread -lGL 


стало так
LIBS          = $(SUBLIBS) /home/safff/git/cannabiscoin420/src/leveldb/libleveldb.a /home/safff/git/cannabiscoin420/src/leveldb/libmemenv.a -lrt -L/home/safff/git/boost57/usr/lib -L/home/safff/git/openssl1.0.1.f/usr/lib -lQt5Widgets -lQt5Gui -lQt5Network -lQt5Core -lssl -lcrypto -ldb_cxx-4.8 -lboost_system -lboost_filesystem -lboost_program_options -lboost_thread -lpthread -lGL 

safocl ★★ ()
Ответ на: комментарий от safocl

а собранные библиотеки у тебя в /home/safff/git/openssl1.0.1.f/usr/lib лежат? Они там в результате «make install» в директории исходников openssl появились?

Harald ★★★★★ ()

вообще с версией openssl1.0.1.u (которая указана в .pro-файле) ошибки BIGNUM происходят, почему я хз, мб какуюто версию компилятора надо, или буста, но все вроде сделал как написано, версии уже много перепробывал.
с gcc5.4.0 тоже самое, с gcc4.3.3 ваще не понимает -fstack-protector-strong параметр... значит собиралось не им

safocl ★★ ()
Ответ на: комментарий от Harald

да он чото не хатит отвечать. раньше была ошибка бигнум и я задал вопрос, он до сих пор не ответил, да и другие недавние вопросы игнорятся

safocl ★★ ()
Ответ на: комментарий от Harald

с ним какие то траблы, я уже не помню, но до ентого момента даже не доходит. вроде ошибка бигнум, сча выложу с актуальной версией ssl1.1.0 лог

safocl ★★ ()
Ответ на: комментарий от Harald

и я не пойму с какого пакета его брать?

`--> find /usr -name 'bignum.h' 2>&-                                    
/usr/include/nettle/bignum.h
/usr/include/double-conversion/bignum.h
/usr/include/mbedtls/bignum.h

по идее с /usr/include/mbedtls/bignum.h, т.к. ентот пакет «Portable cryptographic and SSL/TLS library, aka polarssl»

safocl ★★ ()
Последнее исправление: safocl (всего исправлений: 1)
Ответ на: комментарий от Harald

дада, я понял, но я думал просто чо он мб устарел и его надо обновить, или енто тока для ентой проги он свой?

если скопить его из нынешних хедеров?

safocl ★★ ()
Ответ на: комментарий от safocl

походу разрабы openssl меняли алгоритм метода шифрования

Никакой алгоритм не меняли! Изменили название либы с древней ssleay на современную openssl (которая является форком и продолжателем ssleay).

sigurd ★★★★ ()
Последнее исправление: sigurd (всего исправлений: 1)

libQt5Network.so: undefined reference to `EC_curve_nist2nid@OPENSSL_1.0.2'

libQt5Network требует openssl 1.0.2

sigurd ★★★★ ()

Вообщем - надоело мне компилировать в уме - скачал исходники и откомпилировал с системным gcc (6.3.1), системным openssl 1.0.2k, штатным boost 1.60. Только добавить пришлось пакеты libdb4 и libdb4-cxx (+devel). Все откомпилировалось (только варнинги) и запускается. Да - еще отключил использование miniupnpc (лень ее искать)

sigurd ★★★★ ()
Последнее исправление: sigurd (всего исправлений: 2)
Ответ на: комментарий от sigurd

оО.. ну миниюпинпи я тож отключил...

сча сию минуту же попробую с ентими же версиями.

safocl ★★ ()
Последнее исправление: safocl (всего исправлений: 1)
Ответ на: комментарий от sigurd

https://ptpb.pw/-Oad  — в общем ничо нового

запускал так:

qmake cannabiscoin-qt.pro BDB_INCLUDE_PATH=/usr/include/db4.8 BDB_LIB_SUFFIX="-4.8" USE_UPNP=- BOOST_INCLUDE_PATH=/home/safff/git/boost-1.60.0/usr/include BOOST_LIB_PATH=/home/safff/git/boost-1.60.0/usr/lib OPENSSL_INCLUDE_PATH=/home/safff/git/openssl-1.0.2.k/usr/include OPENSSL_LIB_PATH=/home/safff/git/openssl-1.0.2.k/usr/lib

PATH=/home/safff/git/gcc-6.3.1/usr/bin:$PATH make -j5

safocl ★★ ()
Ответ на: комментарий от safocl

ёпрст, я пути к openssl указал неверные... там они почему то немного подругому были

safocl ★★ ()
Ответ на: комментарий от sigurd

а у тебя как я понимаю дебиан? т.к. лазил енти дни в его пакетах, там как раз вроде gcc 6.3.1 версии? енто так к сведению, чо бы было ориентироваться в последующих подобных моментах

safocl ★★ ()
Ответ на: комментарий от safocl

воу.... наканец таки собрался... именно с версией openssl1.0.2.k 4 сборки арча... с первой сборкой той же версии отказался...

safocl ★★ ()
Ответ на: комментарий от safocl

еще вопрос, компилил как? так же как и я?

никаких опций ни для qmake? ни для make я не передавал, только makefile чуть поправил - отключил miniupnpc и ldb_cxx-4 подправил

sigurd ★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.