LINUX.ORG.RU

Не отрабатывает sendmail.

 ,


0

1

Имею при себе ubuntu 16.04 и там и там, postfix + sendmail без шифрования.

Postfix же работает как положено, а вот после переезда sendmail`а с centos на Ubuntu с аналогичной конфигруацией не работает.

Как настраивался Sendmail:

apt-get -y install sendmail

define(`MAIL_HUB',`[192.168.1.5]')dnl (в самый конец конфига(адрес postfix))

make -C /etc/mail

/etc/init.d/sendmail reload

Лог: mail.log

 
May 28 12:00:01 Web-Server sendmail[5756]: v4S901or005756: from=root, size=729, class=0, nrcpts=1, msgid=<201705280900.v4S901or005756@Web-Server>, bodytype=8BITMIME, relay=root@localhost

May 28 12:00:01 Web-Server sm-mta[5757]: v4S9013O005757: from=<root@Web-Server>, size=985, class=0, nrcpts=1, msgid=<201705280900.v4S901or005756@Web-Server>, bodytype=7BIT, proto=ESMTP, daemon=MTA-v4, relay=localhost [127.0.0.1]

May 28 12:00:01 Web-Server sendmail[5756]: v4S901or005756: to=root, ctladdr=root (0/0), delay=00:00:00, xdelay=00:00:00, mailer=relay, pri=30729, relay=[127.0.0.1] [127.0.0.1], dsn=2.0.0, stat=Sent (v4S9013O005757 Message accepted for delivery)

May 28 12:00:01 Web-Server sm-mta[5759]: STARTTLS=client, relay=[192.168.1.5], version=TLSv1.2, verify=FAIL, cipher=ECDHE-RSA-AES256-GCM-SHA384, bits=256/256

May 28 12:00:02 Web-Server sm-mta[5759]: v4S9013O005757: to=<root@Web-Server>, ctladdr=<root@Web-Server> (0/0), delay=00:00:00, xdelay=00:00:00, mailer=relay, pri=120985, relay=[192.168.1.5] [192.168.1.5], dsn=2.0.0, stat=Sent (Ok: queued as ECF6354002F)

Лог syslog:

May 28 12:00:01 Web-Server CRON[5731]: (root) CMD (test -x /usr/bin/certbot -a \! -d /run/systemd/system && perl -e 'sleep int(rand(3600))' && certbot -q renew)

May 28 12:00:01 Web-Server CRON[5732]: (smmsp) CMD (test -x /etc/init.d/sendmail && test -x /usr/share/sendmail/sendmail && test -x /usr/lib/sm.bin/sendmail && /usr/share/sendmail/sendmail cron-msp)

May 28 12:00:01 Web-Server CRON[5733]: (root) CMD (certbot renew)

May 28 12:00:01 Web-Server sendmail[5756]: v4S901or005756: from=root, size=729, class=0, nrcpts=1, msgid=<201705280900.v4S901or005756@Web-Server>, bodytype=8BITMIME, relay=root@localhost

May 28 12:00:01 Web-Server sm-mta[5757]: v4S9013O005757: from=<root@Web-Server>, size=985, class=0, nrcpts=1, msgid=<201705280900.v4S901or005756@Web-Server>, bodytype=7BIT, proto=ESMTP, daemon=MTA-v4, relay=localhost [127.0.0.1]

May 28 12:00:01 Web-Server sendmail[5756]: v4S901or005756: to=root, ctladdr=root (0/0), delay=00:00:00, xdelay=00:00:00, mailer=relay, pri=30729, relay=[127.0.0.1] [127.0.0.1], dsn=2.0.0, stat=Sent (v4S9013O005757 Message accepted for delivery)

May 28 12:00:01 Web-Server sm-mta[5759]: STARTTLS=client, relay=[192.168.1.5], version=TLSv1.2, verify=FAIL, cipher=ECDHE-RSA-AES256-GCM-SHA384, bits=256/256

May 28 12:00:02 Web-Server sm-mta[5759]: v4S9013O005757: to=<root@Web-Server>, ctladdr=<root@Web-Server> (0/0), delay=00:00:00, xdelay=00:00:00, mailer=relay, pri=120985, relay=[192.168.1.5] [192.168.1.5], dsn=2.0.0, stat=Sent (Ok: queued as ECF6354002F)

cerbot сюда какого-то влез с Lets Encrypt'ом...

★★

Строки в логах кто обрезал?

mky ★★★★★ ()
Ответ на: комментарий от BitSum

По логу видно, что письмо отдано 192.168.1.5, который его принял и поставил в очередь, и даже указан идентификатор, по которому его можно поискать в логах постфикса. В чём именно проблема?

mky ★★★★★ ()
Ответ на: комментарий от BitSum

stat=Sent (Ok: queued as ECF6354002F)

норм sendmail отработал. по логу проблем нет.

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.