LINUX.ORG.RU

firefox kde-debian and apt-get error

 , , ,


1

2

Решил попробовать дебиан тестинг. Чтобы установить firefox, добавил анстейбл репу:

# 

# deb cdrom:[Debian GNU/Linux stretch-DI-rc2 _Stretch_ - Official Snapshot amd64 NETINST Binary-1 20$

#deb cdrom:[Debian GNU/Linux stretch-DI-rc2 _Stretch_ - Official Snapshot amd64 NETINST Binary-1 201$

deb http://mirror.yandex.ru/debian/ stretch main contrib non-free
deb-src http://mirror.yandex.ru/debian/ stretch main contrib non-free

deb http://security.debian.org/debian-security stretch/updates main contrib non-free
deb-src http://security.debian.org/debian-security stretch/updates main contrib non-free



deb http://http.debian.net/debian unstable main 

Чтобы не превратить тестинг в зоопарк, создал /etc/apt/preferences


Package: *
Pin: release a=stable
Pin-Priority: 500

Package: *
Pin: release a=testing
Pin-Priority: 600

Package: *
Pin: release a=unstable
Pin-Priority: 50

После чего sudo apt-get update:

sudo apt-get update            
Пол:1 http://mirror.yandex.ru/debian stretch InRelease [184 kB]
Сущ:2 http://security.debian.org/debian-security stretch/updates InRelease                          
Игн:4 http://dl.google.com/linux/chrome/deb stable InRelease                                        
Игн:5 http://mirror.yandex.ru/debian stretch/main amd64 DEP-11 Metadata                             
Игн:6 http://mirror.yandex.ru/debian stretch/main DEP-11 64x64 Icons                                
Игн:7 http://mirror.yandex.ru/debian stretch/main DEP-11 128x128 Icons                              
Игн:8 http://mirror.yandex.ru/debian stretch/contrib amd64 DEP-11 Metadata                          
Игн:9 http://mirror.yandex.ru/debian stretch/contrib DEP-11 64x64 Icons                             
Игн:10 http://mirror.yandex.ru/debian stretch/contrib DEP-11 128x128 Icons                          
Игн:11 http://mirror.yandex.ru/debian stretch/non-free amd64 DEP-11 Metadata                        
Игн:12 http://mirror.yandex.ru/debian stretch/non-free DEP-11 64x64 Icons                           
Игн:13 http://mirror.yandex.ru/debian stretch/non-free DEP-11 128x128 Icons                         
Сущ:14 http://dl.google.com/linux/chrome/deb stable Release                                         
Пол:5 http://mirror.yandex.ru/debian stretch/main amd64 DEP-11 Metadata [3 074 kB]                  
Сущ:3 http://cdn-fastly.deb.debian.org/debian unstable InRelease                                    
Ошк:5 http://mirror.yandex.ru/debian stretch/main amd64 DEP-11 Metadata             
  Хеш сумма не совпадает
  Hashes of expected file:
   - Filesize:3073792 [weak]
   - SHA256:d2c91412c96c136c792c12659b08f31f960ca6e7b97e757ac5b6b18063922661
   - MD5Sum:c3b5ecc41643b0e186deddf84aa3659b [weak]
  Hashes of received file:
   - SHA256:cc701bb7ec34a6b74a1e26cee26263adf6705243ba6c4ccd5fdeed113de95745
   - MD5Sum:cb6a050ad8a114af3b858717e2aafa83 [weak]
   - Filesize:3073244 [weak]
  Last modification reported: Fri, 17 Feb 2017 02:33:48 +0000
  Release file created at: Fri, 17 Feb 2017 14:30:21 +0000
Пол:7 http://mirror.yandex.ru/debian stretch/main DEP-11 128x128 Icons [15,8 MB]
Ошк:7 http://mirror.yandex.ru/debian stretch/main DEP-11 128x128 Icons
  
Пол:8 http://mirror.yandex.ru/debian stretch/contrib amd64 DEP-11 Metadata [8 760 B]
Ошк:8 http://mirror.yandex.ru/debian stretch/contrib amd64 DEP-11 Metadata
  
Пол:9 http://mirror.yandex.ru/debian stretch/contrib DEP-11 64x64 Icons [112 kB]
Ошк:9 http://mirror.yandex.ru/debian stretch/contrib DEP-11 64x64 Icons
  
Пол:10 http://mirror.yandex.ru/debian stretch/contrib DEP-11 128x128 Icons [296 kB]
Ошк:10 http://mirror.yandex.ru/debian stretch/contrib DEP-11 128x128 Icons
  
Пол:11 http://mirror.yandex.ru/debian stretch/non-free amd64 DEP-11 Metadata [7 136 B]
Ошк:11 http://mirror.yandex.ru/debian stretch/non-free amd64 DEP-11 Metadata
  
Пол:12 http://mirror.yandex.ru/debian stretch/non-free DEP-11 64x64 Icons [34,4 kB]
Ошк:12 http://mirror.yandex.ru/debian stretch/non-free DEP-11 64x64 Icons
  
Пол:13 http://mirror.yandex.ru/debian stretch/non-free DEP-11 128x128 Icons [91,6 kB]
Ошк:13 http://mirror.yandex.ru/debian stretch/non-free DEP-11 128x128 Icons
  
Получено 19,3 MБ за 3с (6 429 kБ/c)       
Чтение списков пакетов… Готово
E: Не удалось получить http://mirror.yandex.ru/debian/dists/stretch/main/dep11/Components-amd64.yml.xz  Хеш сумма не совпадает
   Hashes of expected file:
    - Filesize:3073792 [weak]
    - SHA256:d2c91412c96c136c792c12659b08f31f960ca6e7b97e757ac5b6b18063922661
    - MD5Sum:c3b5ecc41643b0e186deddf84aa3659b [weak]
   Hashes of received file:
    - SHA256:cc701bb7ec34a6b74a1e26cee26263adf6705243ba6c4ccd5fdeed113de95745
    - MD5Sum:cb6a050ad8a114af3b858717e2aafa83 [weak]
    - Filesize:3073244 [weak]
   Last modification reported: Fri, 17 Feb 2017 02:33:48 +0000
   Release file created at: Fri, 17 Feb 2017 14:30:21 +0000
E: Не удалось получить http://mirror.yandex.ru/debian/dists/stretch/main/dep11/icons-64x64.tar.gz  404  Not Found
E: Не удалось получить http://mirror.yandex.ru/debian/dists/stretch/main/dep11/icons-128x128.tar.gz  
E: Не удалось получить http://mirror.yandex.ru/debian/dists/stretch/contrib/dep11/Components-amd64.yml.xz  
E: Не удалось получить http://mirror.yandex.ru/debian/dists/stretch/contrib/dep11/icons-64x64.tar.gz  
E: Не удалось получить http://mirror.yandex.ru/debian/dists/stretch/contrib/dep11/icons-128x128.tar.gz  
E: Не удалось получить http://mirror.yandex.ru/debian/dists/stretch/non-free/dep11/Components-amd64.yml.xz  
E: Не удалось получить http://mirror.yandex.ru/debian/dists/stretch/non-free/dep11/icons-64x64.tar.gz  
E: Не удалось получить http://mirror.yandex.ru/debian/dists/stretch/non-free/dep11/icons-128x128.tar.gz  
E: Некоторые индексные файлы не скачались. Они были проигнорированы или вместо них были использованы старые версии.

Где проблема? Все скрины тут http://imgur.com/a/KvXh5

И побочный вопрос, какого черта warning'и громкость сбрасывается на 100%? периодически долбят на полную громкость? Как починить?

вроде в тесте родные репы имеют iceweasel - нафига огород с лисой, теже яйца вид с боку...

amd_amd ()

omnicide

Где проблема?

Ты используешь псевдонимы и кодовые имена веток и выпусков в разных местах перемешивая их. Еще конкретное зеркало может быть какой-то момент рассинхронизировано, нужно подождать или использовать механизм автоматического выбора зеркала (в моём примере именно он).

Приведи к такому виду, если хочешь использовать кодовые имена:

## Репозитории jessie ветки, стабильная ветка
# Основной репозиторий jessie 
deb http://httpredir.debian.org/debian jessie main
deb-src http://httpredir.debian.org/debian jessie main

# Репозиторий обновлений jessie
deb http://httpredir.debian.org/debian jessie-updates main
deb-src http://httpredir.debian.org/debian jessie-updates main

# Репозиторий обновлений безопасности jessie
deb http://security.debian.org/ jessie/updates main contrib non-free
deb-src http://security.debian.org/ jessie/updates main contrib non-free

# Бекпорты jessie
deb http://httpredir.debian.org/debian jessie-backports main contrib non-free
deb-src http://httpredir.debian.org/debian jessie-backports main contrib non-free

# Предложенные обновления для следующей редакции
deb http://httpredir.debian.org/debian jessie-proposed-updates main contrib non-free
deb-src http://httpredir.debian.org/debian jessie-proposed-updates main contrib non-free

## Репозитории stretch, пока тестовые
# Основной репозиторий stretch
deb http://httpredir.debian.org/debian stretch main contrib non-free
deb-src http://httpredir.debian.org/debian stretch main contrib non-free

# Репозиторий обновлений stretch
deb http://httpredir.debian.org/debian stretch-updates main contrib non-free
deb-src http://httpredir.debian.org/debian stretch-updates main contrib non-free

# Репозиторий обновлений безопасности stretch
deb http://security.debian.org/ stretch/updates main contrib non-free
deb-src http://security.debian.org/ stretch/updates main contrib non-free

# Бекпорты stretch, отключены до релиза
#deb http://httpredir.debian.org/debian stretch-backports main contrib non-free
#deb-src http://httpredir.debian.org/debian stretch-backports main contrib non-free

## Unstable имеет только один репозиторий
# Репозиторий unstable-ветки, кодовое имя 'sid' -- ни когда не будет выпущен.
deb http://httpredir.debian.org/debian sid main contrib non-free
deb-src http://httpredir.debian.org/debian sid main contrib non-free

И /etc/apt/preferences

Package: *
Pin: release a=jessie
Pin-Priority: 500

Package: *
Pin: release a=stretch
Pin-Priority: 600

Package: *
Pin: release a=sid
Pin-Priority: 50

А вот если хочешь использовать псевдонимы веток разработки, то такой вид:

## Репозитории stable ветки, стабильная ветка всегда, при релизе переход произойдет внезапно!
# Основной репозиторий stable 
deb http://httpredir.debian.org/debian stable main
deb-src http://httpredir.debian.org/debian stable main

# Репозиторий обновлений stable
deb http://httpredir.debian.org/debian stable-updates main
deb-src http://httpredir.debian.org/debian stable-updates main

# Репозиторий обновлений безопасности stable
deb http://security.debian.org/ stable/updates main contrib non-free
deb-src http://security.debian.org/ stable/updates main contrib non-free

# Бекпорты stable
deb http://httpredir.debian.org/debian stable-backports main contrib non-free
deb-src http://httpredir.debian.org/debian stable backports main contrib non-free

# Предложенные обновления для следующей редакции
deb http://httpredir.debian.org/debian stable-proposed-updates main contrib non-free
deb-src http://httpredir.debian.org/debian stable-proposed-updates main contrib non-free

## Репозитории testing ветки, всегда тестовые
# Основной репозиторий testing
deb http://httpredir.debian.org/debian testing main contrib non-free
deb-src http://httpredir.debian.org/debian testing main contrib non-free

# Репозиторий обновлений testing
deb http://httpredir.debian.org/debian testing-updates main contrib non-free
deb-src http://httpredir.debian.org/debian testing-updates main contrib non-free

# Репозиторий обновлений безопасности testing 
deb http://security.debian.org/ stretch/updates main contrib non-free
deb-src http://security.debian.org/ stretch/updates main contrib non-free

## Unstable имеет только один репозиторий
# Репозиторий unstable-ветки, кодовое имя 'sid' -- ни когда не будет выпущен.
deb http://httpredir.debian.org/debian unstable main contrib non-free
deb-src http://httpredir.debian.org/debian unstable main contrib non-free

И /etc/apt/preferences

Package: *
Pin: release a=stable
Pin-Priority: 500

Package: *
Pin: release a=testing
Pin-Priority: 600

Package: *
Pin: release a=unstable
Pin-Priority: 50

Имей в виду, что второй вариант тебя автоматически обновит на новый релиз, безопасней использовать кодовые имена.

mandala ★★★★ ()
Ответ на: комментарий от Cactus64k

Ну если только лиса нужна, то этого более чем достаточно, да. Но если он уже обновлялся, то всё.

mandala ★★★★ ()
Ответ на: комментарий от mandala

mandala Спасибо, за подробный ответ. Такой список обновления нормален после первого варианта?

Пакеты, которые будут обновлены:
  apt-listchanges bind9-host binutils btrfs-progs console-setup console-setup-linux dbus dbus-x11
  dirmngr firefox fonts-noto-cjk fonts-opensymbol gcc-5-base geoip-database gir1.2-gdkpixbuf-2.0
  gir1.2-gtk-3.0 gir1.2-javascriptcoregtk-4.0 gir1.2-webkit2-4.0 gnupg gnupg-agent gnupg2 gpgv
  grub-common grub-pc grub-pc-bin grub2-common gtk-update-icon-cache keyboard-configuration
  kwin-common kwin-data kwin-x11 libasound2 libasound2-data libbind9-140 libdbus-1-3
  libdebconfclient0 libdirectfb-1.2-9 libdns-export162 libdns162 libevent-2.0-5 libgdk-pixbuf2.0-0
  libgdk-pixbuf2.0-common libglib2.0-0 libglib2.0-bin libglib2.0-data libgme0 libgtk-3-0
  libgtk-3-bin libgtk-3-common libisc-export160 libisc160 libisccc140 libisccfg140
  libjavascriptcoregtk-4.0-18 libkwin4-effect-builtins1 libkwineffects9 libkwinglutils9
  libkwinxrenderutils9 liblwres141 libnghttp2-14 libnm0 libp11-kit0 libpam-systemd libpcre16-3
  libpcre3 libpq5 libproxy-tools libproxy1v5 libreoffice libreoffice-avmedia-backend-gstreamer
  libreoffice-base libreoffice-base-core libreoffice-base-drivers libreoffice-calc
  libreoffice-common libreoffice-core libreoffice-draw libreoffice-help-en-us libreoffice-help-ru
  libreoffice-impress libreoffice-java-common libreoffice-kde libreoffice-l10n-ru
  libreoffice-librelogo libreoffice-math libreoffice-nlpsolver libreoffice-ogltrans
  libreoffice-pdfimport libreoffice-report-builder libreoffice-report-builder-bin
  libreoffice-script-provider-bsh libreoffice-script-provider-js libreoffice-script-provider-python
  libreoffice-sdbc-hsqldb libreoffice-sdbc-postgresql libreoffice-style-breeze
  libreoffice-style-galaxy libreoffice-wiki-publisher libreoffice-writer libsnappy1v5 libssl1.1
  libsystemd0 libudev1 libv4l-0 libv4lconvert0 libvlc-bin libvlc5 libvlccore8 libwebkit2gtk-4.0-37
  libwebkit2gtk-4.0-37-gtk2 linux-kbuild-4.9 make network-manager nodejs openssl python3-reportbug
  python3-uno reportbug systemd systemd-sysv sysvinit-utils udev uno-libs3 ure vlc vlc-bin vlc-data
  vlc-l10n vlc-plugin-base vlc-plugin-notify vlc-plugin-qt vlc-plugin-samba vlc-plugin-skins2
  vlc-plugin-video-output vlc-plugin-video-splitter vlc-plugin-visualization wget wpasupplicant
обновлено 138, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 1 пакетов не обновлено.
Необходимо скачать 311 MБ архивов.
После данной операции, объём занят

omnicide ()
Ответ на: комментарий от mandala

вот это репа - применил не задумываясь - все прошло как по маслу без единой ошибки - прикольно debian 9 с ядром 3.16.0-4 - conkyrc пришлось подправить так как старый неподхватило, дальше главное что бы held пакетов не было - время покажет...

amd_amd ()
Ответ на: комментарий от omnicide

Да, ты же обновляешь целиком дистрибутив на новый выпуск.

mandala ★★★★ ()
Ответ на: комментарий от mandala

Кажется я теперь ничего не понимаю :D Изначально, стоял нетинсталл тестинга, а не jessie. Цель, в том чтобы оставаться на тестинге, по крайней мере пока не выйдет девятый дебиан и куча новых пакетов в один момент не окажется в тестинге.

omnicide ()
Ответ на: комментарий от omnicide

Изначально, стоял нетинсталл тестинга

Ну так тогда всё равно нормально, в тестинге постоянно что-то обновляется. У меня сейчас 13 кандидатов на установку, но у меня очень мало пакетов, а у тебя там либреофис обновляется — половина это он.

Цель, в том чтобы оставаться на тестинге, по крайней мере пока не выйдет девятый дебиан и куча новых пакетов в один момент не окажется в тестинге.

Тогда первый вариант настройки, который я давал (репы jessie можешь тогда выкинуть) с кодовыми именами, подходит.

mandala ★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.