LINUX.ORG.RU

Не могу перевести карту в режим монитора

 , , ,


1

2

Машина: toshiba satellite l750
пробую:

ifconfig wlan0 down
iwconfig wlan0 mode monitor
ifconfig wlan0 up
Все эти команды проходят без проблем и ошибок, но карта все равно не находится в режиме монитора, каким образом еще можно чекнуть, и что я не правильно делаю?
UPD: После выполнения команд она в режиме Monitor:
wlp9s0    IEEE 802.11  Mode:Monitor  Frequency:2.462 GHz  Tx-Power=15 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
Но после запуска того же airgeddon (https://github.com/v1s1t0r1sh3r3/airgeddon), то он пишет что карта не в режиме монитора, проверяю снова iwconfig, и тут:
wlp9s0    IEEE 802.11  ESSID:"***"  
          Mode:Managed  Frequency:2.462 GHz  Access Point: 64:70:**:**:B5:2E   
          Bit Rate=150 Mb/s   Tx-Power=17 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=52/70  Signal level=-58 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:30   Missed beacon:0


OS: Antergos (Arch)

★★★

Начнем с простого: а для этой карты этот режим официально вообще поддерживается?

cvv ★★★★★ ()
Ответ на: комментарий от cvv

Загуглил, у ребят на backtrack такие карточки были:

Qualcomm Atheros AR9285 Wireless Network Adapter
У них заводилось, много инфы смотрел по этому поводу.
Пробовал так же:
airmon-ng start wlan0
Тут вроде все ок, airgeddon видит что режим монитора, НО, подключения к wifi нет, соотвественно и выхода в сеть нет. Может ли это быть что airmon переименовывает девайс и добавляет «mon» в конец? К примеру wlan0mon.

foozzi ★★★ ()
Ответ на: комментарий от foozzi

airmon-ng check посмотри что мешает.

добавляет «mon» в конец?

добавляет, карта же в режим монитора переходит.

julixs ★★ ()
Последнее исправление: julixs (всего исправлений: 1)
Ответ на: комментарий от foozzi

Не помню. Я давно не ковырялся в вай-фае.

cvv ★★★★★ ()
Ответ на: комментарий от julixs
[foozzi@foozzi ~]$ sudo airmon-ng check
[sudo] пароль для foozzi: 
Your kernel supports rfkill but you don't have rfkill installed.
To ensure devices are unblocked you must install rfkill.

Found 2 processes that could cause trouble.
If airodump-ng, aireplay-ng or airtun-ng stops working after
a short period of time, you may want to run 'airmon-ng check kill'

  PID Name
 8725 NetworkManager
 8811 wpa_supplicant

Убить эти процессы?

foozzi ★★★ ()
Ответ на: комментарий от foozzi

Остановить и выключить службы, особенно суппликанта

cvv ★★★★★ ()
Ответ на: комментарий от foozzi

Да



Checking for interfering processes

When putting a card into monitor mode, it will automatically check for interfering processes. It can also be done manually by running the following command:

~# airmon-ng check
Found 5 processes that could cause trouble.
If airodump-ng, aireplay-ng or airtun-ng stops working after
a short period of time, you may want to kill (some of) them!

  PID Name
  718 NetworkManager
  870 dhclient
 1104 avahi-daemon
 1105 avahi-daemon
 1115 wpa_supplicant

Killing interfering processes

This command stops network managers then kill interfering processes left:

~# airmon-ng check kill
Killing these processes:

  PID Name
  870 dhclient
 1115 wpa_supplicant

Enable monitor mode




julixs ★★ ()
Ответ на: комментарий от julixs

убил, отпал инет, запустил airmon на режим монитора, толку 0)

foozzi ★★★ ()
Ответ на: комментарий от foozzi

а что ты хочешь от режима монитора?

airmon-ng
ifconfig mode monitor


просто переводят карту из режима обслуживания в режим монитора, дальше какие твои действия?

julixs ★★ ()
Последнее исправление: julixs (всего исправлений: 1)
Ответ на: комментарий от foozzi

Ты надеешься на интернет в monitor mode? Ну если сможешь - я думаю ты можешь рассчитывать на должность с зарплатой в несколько раз выше текущей.

cvv ★★★★★ ()
Последнее исправление: cvv (всего исправлений: 1)
Ответ на: комментарий от foozzi



Загуглил, у ребят на backtrack такие карточки были:



Плохо гуглил! гугли еще aircrack-ng, reaver ну или что там еще карту в режиме монитора юзает.

julixs ★★ ()
Ответ на: комментарий от julixs
sudo airmon-ng check

далее киляю все процессы которые он мне выдал

sudo airmon-ng stop wlp9s0
тут я получил режим монитора, запуская airgeddon и при сканировании сети получаю:
Выбрано сканирование целей (необходим режим монитора) 

Выбранный интерфейс wlp9s0mon в режиме монитора. Сканирование может быть выполнено 

После запуска, нажмите [Ctrl+C] для остановки... 
Нажмите клавишу [Enter] для продолжения...
airgeddon.sh: строка 9218: /tmp/nws-01.csv: Нет такого файла или каталога

Сети не найдены 

foozzi ★★★ ()
Ответ на: комментарий от foozzi

sudo airmon-ng stop wlp9s0

выводит из monitor mode,

sudo airmon-ng start wlp9s0

А зачем ты меняешь режимы до запуска airgeddon? Он сам может это делать.

гы. его еще и русифицировалиО_о

julixs ★★ ()
Последнее исправление: julixs (всего исправлений: 1)
Ответ на: комментарий от julixs

он на русском, и ругается что монитор не врублен...

foozzi ★★★ ()
Ответ на: комментарий от julixs

собственно нужно было руками прямо в airgeddon переводить, что бы он свои tmp файлы сам создал, если порытся, есть ручное включение монитора. Thx.

foozzi ★★★ ()
Ответ на: комментарий от foozzi

В airgeddon стал писать, что сети не найдены, но до этого всё работало (fedora), запустил kali с флешки, запустил в своём хомяке airgeddon, всё работает. Как решить проблему?

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.