LINUX.ORG.RU

Неправильно настроен автологин в archlinux

 ,


0

2

Доброго всем. В VirtualBox установлен ArchLinux, автологин настроен по этой инструкции: http://archlinux.org.ru/forum/topic/16498/

3. Последний шаг заключается в том, чтобы посредством Systemd сделать автологин нужного пользователя в нужную виртуальную консоль, а дальше всё будет по цепочке тех шагов, которые описаны выше. Для этого нам требуется создать нужный Unit для Systemd:

# systemctl edit getty@ttyNomerVirtConsole
и там вписать следующий код
[Service]
ExecStart=
ExecStart=-/usr/bin/agetty --autologin Username --noclear %I $TERM
Здесь NomerVirtConsole - это номер нужной виртуальной консоли, она должна быть равна переменной из шага 2. А переменная Username соответственно имя нашего пользователя для которого всё это затевалось.

Поторопился и после копипаста так и осталось Username.

Теперь при загрузке ошибка, ручной логин системой не предлагается:

User not known to the underlying authentication module

Как можно исправить ситуацию?

Загрузиться в «режим восстановления», примонтировать корень в rw, исправить, перезагрузиться.

mandala ★★★★ ()
Ответ на: комментарий от mandala

Не понятно, как перезагрузиться в режим восстановления, в меню grub2 такого пункта нет.
Подцепил файл диска к другой виртуальной машине, примонтировал, что нужно исправить?

carabo ()
Ответ на: комментарий от carabo

Поторопился и после копипаста так и осталось Username.

Вот это и поправить.

mandala ★★★★ ()
Ответ на: комментарий от carabo

Загрузиться в «режим восстановления»

В Grub2 войти в режим редактирования пункта (нажать e) и добавить параметр single. Должно получиться что-то похожее на:

boot/vmlinuz-4.9.0-1-amd64 root=UUID=1bd8dd67-f4c5-47c4-ba23-f64571369124 ro single 

Нажать Ctrl-x или F10 для применения и загрузки. Это не затрагивает файл конфигурации.

Ну и для понимания:https://wiki.archlinux.org/index.php/Systemd_(Русский)#.D0.A6.D0.B5.D0.BB.D0.B8

mandala ★★★★ ()
Последнее исправление: mandala (всего исправлений: 1)
Ответ на: комментарий от carabo

https://wiki.archlinux.org/index.php/Systemd_%28Русский%29#.D0.94.D0.B8.D0.B0...

Добавь к параметрам ядра при загрузке опции (в грубе нажав клавишу 'e', я писал выше как это делать), т.к. сейчас вывод отсутствует:

systemd.log_level=debug systemd.log_target=kmsg log_buf_len=1M
mandala ★★★★ ()
Последнее исправление: mandala (всего исправлений: 1)
Ответ на: комментарий от carabo

А это то откуда вылезло?

Загрузись добавив к опциям ядра просто цифру 1, и выполни команду

journalctl -b -1

mandala ★★★★ ()
Ответ на: комментарий от carabo

Ты там не починился еще?

Если нет, то исходя из журнала тебе надо переключиться в соседнюю tty (должно работать), залогиниться под рутом и выполнить (или опять загрузить в single добавив к опциясм ядра 1):

systemctl set-default multi-user.target
systemctl enable getty@tty1 (или какой ты там юнит руками удалил)

Перезагрузиться и заново этот автологин настроить — инструкция рабочая.

mandala ★★★★ ()
Последнее исправление: mandala (всего исправлений: 1)
Ответ на: комментарий от mandala

Спасибо, это решение помогло починить загрузку, автологин тоже настроил.

carabo ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.