LINUX.ORG.RU

Не открывается личный кабинет провайдера

 , ,


1

1

Не могу получить доступ к кабинету провайдера. Если напрямую подключить кабель к компьютеру, то все нормально открывается. Если же пустить, как обычно, через роутер, то не открывается только кабинет провайдера, все остальное работает нормально. Логично предположить, что проблема заключается в роутере. Роутер D-Link DIR-825 с установленным OpenWrt 15.05.1.

# cat /etc/config/dhcp
config dnsmasq
	option domainneeded '1'
	option boguspriv '1'
	option authoritative '1'
	option readethers '1'
	option leasefile '/tmp/dhcp.leases'
	option resolvfile '/tmp/resolv.conf.auto'
	option localservice '1'
	option local '/kini.ws/'
	option domain 'kini.ws'
	option nonegcache '1'
	option filterwin2k '1'
	option expandhosts '1'
	option strictorder '1'
	option rebind_protection '1'
	list rebind_domain 'my.multi-net.ru'
	list rebind_domain 'stat.multi-net.ru'

config dhcp 'lan'
	option interface 'lan'
	option leasetime '12h'
	option dhcpv6 'server'
	option ra 'server'
	option start '1'
	option limit '254'
	option ra_management '1'
	list dhcp_option '6,8.8.8.8,89.105.158.150,89.105.144.35'

config dhcp 'wan'
	option interface 'wan'
	option ignore '1'

config odhcpd 'odhcpd'
	option maindhcp '0'
	option leasefile '/tmp/hosts/odhcpd'
	option leasetrigger '/usr/sbin/odhcpd-update'

config dhcp 'guest'
	option leasetime '12h'
	option interface 'guest'
	option start '1'
	option limit '254'
	option ra 'server'
	option dhcpv6 'server'
	option ra_management '1'
	list dhcp_option '6,8.8.8.8,192.168.2.1'
# cat /etc/config/firewall
config defaults
	option syn_flood '1'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'REJECT'
	option drop_invalid '1'

config zone
	option name 'lan'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'ACCEPT'
	option network 'lan'

config zone
	option name 'wan'
	option output 'ACCEPT'
	option masq '1'
	option network 'wan henet wan6'
	option input 'REJECT'
	option forward 'REJECT'
	option mtu_fix '1'

config forwarding
	option src 'lan'
	option dest 'wan'

config rule
	option name 'Allow-DHCP-Renew'
	option src 'wan'
	option proto 'udp'
	option dest_port '68'
	option target 'ACCEPT'
	option family 'ipv4'

config rule
	option name 'Allow-Ping'
	option src 'wan'
	option proto 'icmp'
	option icmp_type 'echo-request'
	option family 'ipv4'
	option target 'ACCEPT'

config rule
	option name 'Allow-IGMP'
	option src 'wan'
	option proto 'igmp'
	option family 'ipv4'
	option target 'ACCEPT'

config rule
	option name 'Allow-DHCPv6'
	option src 'wan'
	option proto 'udp'
	option src_ip 'fe80::/10'
	option src_port '547'
	option dest_ip 'fe80::/10'
	option dest_port '546'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-MLD'
	option src 'wan'
	option proto 'icmp'
	option src_ip 'fe80::/10'
	list icmp_type '130/0'
	list icmp_type '131/0'
	list icmp_type '132/0'
	list icmp_type '143/0'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-ICMPv6-Input'
	option src 'wan'
	option proto 'icmp'
	list icmp_type 'echo-request'
	list icmp_type 'echo-reply'
	list icmp_type 'destination-unreachable'
	list icmp_type 'packet-too-big'
	list icmp_type 'time-exceeded'
	list icmp_type 'bad-header'
	list icmp_type 'unknown-header-type'
	list icmp_type 'router-solicitation'
	list icmp_type 'neighbour-solicitation'
	list icmp_type 'router-advertisement'
	list icmp_type 'neighbour-advertisement'
	option limit '1000/sec'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-ICMPv6-Forward'
	option src 'wan'
	option dest '*'
	option proto 'icmp'
	list icmp_type 'echo-request'
	list icmp_type 'echo-reply'
	list icmp_type 'destination-unreachable'
	list icmp_type 'packet-too-big'
	list icmp_type 'time-exceeded'
	list icmp_type 'bad-header'
	list icmp_type 'unknown-header-type'
	option limit '1000/sec'
	option family 'ipv6'
	option target 'ACCEPT'

config include
	option path '/etc/firewall.user'

config rule
	option src 'wan'
	option dest 'lan'
	option proto 'esp'
	option target 'ACCEPT'

config rule
	option src 'wan'
	option dest 'lan'
	option dest_port '500'
	option proto 'udp'
	option target 'ACCEPT'

config zone
	option name 'guest'
	option input 'ACCEPT'
	option forward 'REJECT'
	option output 'ACCEPT'
	option network 'guest'

config forwarding
	option dest 'wan'
	option src 'guest'
# cat /etc/config/network
config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd8d:80fa:ba79::/48'

config interface 'lan'
	option ifname 'eth0.1'
	option force_link '1'
	option type 'bridge'
	option proto 'static'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option ipaddr '192.168.1.1'

config interface 'wan'
	option ifname 'eth1'
	option _orig_ifname 'eth1'
	option _orig_bridge 'false'
	option proto 'dhcp'

config interface 'wan6'
	option ifname 'eth1'
	option proto 'dhcpv6'
	option reqaddress 'try'
	option reqprefix 'auto'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '0 1 2 3 5t'

config interface 'henet'
	option proto '6in4'
	option peeraddr '216.218.221.42'
	option ip6addr '2001:470:35:21::2/64'
	option ip6prefix '2001:470:36:21::/64'
	option tunnelid '275730'
	option username '********'
	option password '********'

config interface 'guest'
	option type 'bridge'
	option _orig_ifname 'wlan0-1 wlan1-1'
	option _orig_bridge 'true'
	option proto 'static'
	option ipaddr '192.168.2.1'
	option netmask '255.255.255.0'
	option ip6assign '64'
root@dir-825:~# nslookup my.multi-net.ru
Server:    127.0.0.1
Address 1: 127.0.0.1 localhost

Name:      my.multi-net.ru
Address 1: 185.26.216.11 my.multi-net.ru
root@dir-825:~# netstat -r
Kernel IP routing table
Destination     Gateway         Genmask         Flags   MSS Window  irtt Iface
default         host41-95-170-1 0.0.0.0         UG        0 0          0 eth1
95.170.188.40   *               255.255.255.248 U         0 0          0 eth1
95.170.188.41   *               255.255.255.255 UH        0 0          0 eth1
192.168.1.0     *               255.255.255.0   U         0 0          0 br-lan
192.168.2.0     *               255.255.255.0   U         0 0          0 br-guest
216.218.221.42  host41-95-170-1 255.255.255.255 UGH       0 0          0 eth1
root@dir-825:~# ping -c 5 my.multi-net.ru
PING my.multi-net.ru (185.26.216.11): 56 data bytes

--- my.multi-net.ru ping statistics ---
5 packets transmitted, 0 packets received, 100% packet loss

При подключенном напрямую к компьютеру кабеле картина несколько меняется:

C:\Users\Ольга>netstat -r
===========================================================================
Список интерфейсов
16...00 1b b1 f4 8c 00 ......Сетевой адаптер Broadcom 802.11n
14...00 0b 6b 72 1e 8c ......Устройства Bluetooth (личной сети)
11...e8 11 32 21 4a 42 ......Marvell Yukon 88E8040 Family PCI-E Fast Ethernet Controller
1...........................Software Loopback Interface 1
12...00 00 00 00 00 00 00 e0 Адаптер Microsoft ISATAP
15...00 00 00 00 00 00 00 e0 Адаптер Microsoft ISATAP #2
17...00 00 00 00 00 00 00 e0 Адаптер Microsoft ISATAP #3
===========================================================================

IPv4 таблица маршрута
===========================================================================
Активные маршруты:
Сетевой адрес Маска сети Адрес шлюза Интерфейс Метрика
0.0.0.0 0.0.0.0 192.168.1.1 192.168.1.2 281
0.0.0.0 0.0.0.0 172.21.234.129 172.21.234.154 20
127.0.0.0 255.0.0.0 On-link 127.0.0.1 306
127.0.0.1 255.255.255.255 On-link 127.0.0.1 306
127.255.255.255 255.255.255.255 On-link 127.0.0.1 306
172.21.234.128 255.255.255.224 On-link 172.21.234.154 276
172.21.234.154 255.255.255.255 On-link 172.21.234.154 276
172.21.234.159 255.255.255.255 On-link 172.21.234.154 276
192.168.1.0 255.255.255.0 On-link 192.168.1.2 281
192.168.1.2 255.255.255.255 On-link 192.168.1.2 281
192.168.1.255 255.255.255.255 On-link 192.168.1.2 281
224.0.0.0 240.0.0.0 On-link 127.0.0.1 306
224.0.0.0 240.0.0.0 On-link 172.21.234.154 276
224.0.0.0 240.0.0.0 On-link 192.168.1.2 281
255.255.255.255 255.255.255.255 On-link 127.0.0.1 306
255.255.255.255 255.255.255.255 On-link 172.21.234.154 276
255.255.255.255 255.255.255.255 On-link 192.168.1.2 281
===========================================================================
Постоянные маршруты:
Сетевой адрес Маска Адрес шлюза Метрика
0.0.0.0 0.0.0.0 192.168.1.1 По умолчанию
===========================================================================

IPv6 таблица маршрута
===========================================================================
Активные маршруты:
Метрика Сетевой адрес Шлюз
1 306 ::1/128 On-link
11 276 fd8d:80fa:ba79:10::b8a/128
On-link
11 276 fe80::/64 On-link
11 276 fe80::f0ea:215a:97c8:813d/128
On-link
1 306 ff00::/8 On-link
11 276 ff00::/8 On-link
===========================================================================
Постоянные маршруты:
Отсутствует
C:\Users\Ольга>netstat -r > netstat.log

C:\Users\Ольга>nslookup my.multi-net.ru
╤хЁтхЁ: google-public-dns-a.google.com
Address: 8.8.8.8

Не заслуживающий доверия ответ:
╚ь : my.multi-net.ru
Address: 185.26.216.11

С маршрутизатора не пингуется только 185.26.216.11, остальные адреса, допустим 185.26.216.1 пингуются? 

″traceroute -I -n 185.26.216.11″ что-нибудь выдаёт?

P.S. ИМХО, под линусом лучше показывать вывод команд ″ip addr″, ″ip route″, ″iptables-save″, чем файлы конфигурации.

mky ★★★★★ ()
Ответ на: комментарий от mky

Да, пингуется:

root@dir-825:~# ping -c 5 185.26.216.1
PING 185.26.216.1 (185.26.216.1): 56 data bytes
64 bytes from 185.26.216.1: seq=0 ttl=63 time=0.765 ms
64 bytes from 185.26.216.1: seq=1 ttl=63 time=0.765 ms
64 bytes from 185.26.216.1: seq=2 ttl=63 time=0.717 ms
64 bytes from 185.26.216.1: seq=3 ttl=63 time=0.874 ms
64 bytes from 185.26.216.1: seq=4 ttl=63 time=0.580 ms

--- 185.26.216.1 ping statistics ---
5 packets transmitted, 5 packets received, 0% packet loss
round-trip min/avg/max = 0.580/0.740/0.874 ms
root@dir-825:~# traceroute -I -n 185.26.216.11
traceroute to 185.26.216.11 (185.26.216.11), 30 hops max, 38 byte packets
 1  95.170.188.41  0.605 ms  0.327 ms  0.362 ms
 2  89.105.158.131  0.224 ms  0.621 ms  0.720 ms
 3  *  *  *
 4  *  *  *
 5  *  *^C

Дальше одни звезды, проверял не раз.

kini ()

жуть какая.

сохрани конфиг и попробуй с чистым. если с компа идет то первая мысль о MAC адресе. только обычно тырнет вообще не робит если пров на MAC глядит, но может тут только кабинет по нему...

mos ★★☆☆☆ ()
Ответ на: комментарий от kini

185.26.216.11 это ″host41-95-170-1″, через который default маршрут? То есть для openwrt выдаётся «белый» ip адрес, а при подключении напрямую из винды 172.21.234.154?

mky ★★★★★ ()
Ответ на: комментарий от mky

Нет, «host41-95-170-1» - шлюз по умолчанию 95.170.188.41. Адрес 185.26.216.11 принадлежит новому кабинету провайдера. Старый, кстати, доступен по прежнему, но после авторизации на нем идет перенаправление на новый. И да, для роутера выдается «белый» IP 95.170.188.45.

kini ()
Ответ на: комментарий от mos

Не хотелось бы сбрасывать настройки. Роутер переделан как программно, так и физически. Настройка займет достаточно продолжительное время. Оставлю на крайний случай

kini ()
Ответ на: комментарий от mky

Проверил еще раз. Да, для роутера выдается IP 95.170.188.45, а для винды расклад меняется:

Ethernet adapter Подключение по локальной сети:

   DNS-суффикс подключения . . . . . : multi-net.ru
   Описание. . . . . . . . . . . . . : Marvell Yukon 88E8040 Family PCI-E Fast Ethernet Controller
   Физический адрес. . . . . . . . . : E8-11-32-21-4A-42
   DHCP включен. . . . . . . . . . . : Да
   Автонастройка включена. . . . . . : Да
   IPv6-адрес. . . . . . . . . . . . : fd8d:80fa:ba79:10::b8a(Основной) 
   Аренда получена. . . . . . . . . . : 18 июня 2016 г. 19:55:47
   Срок аренды истекает. . . . . . . . . . : 2 августа 2152 г. 17:02:22
   Локальный IPv6-адрес канала . . . : fe80::f0ea:215a:97c8:813d%11(Основной) 
   IPv4-адрес. . . . . . . . . . . . : 172.21.234.154(Основной) 
   Маска подсети . . . . . . . . . . : 255.255.255.224
   Аренда получена. . . . . . . . . . : 24 июня 2016 г. 19:44:42
   Срок аренды истекает. . . . . . . . . . : 28 июня 2016 г. 10:32:44
   Основной шлюз. . . . . . . . . : 172.21.234.129
   DHCP-сервер. . . . . . . . . . . : 89.105.158.146
   IAID DHCPv6 . . . . . . . . . . . : 250089778
   DUID клиента DHCPv6 . . . . . . . : 00-01-00-01-1E-F6-E7-AC-E8-11-32-21-4A-42
   DNS-серверы. . . . . . . . . . . : 89.105.158.150
                                       89.105.144.35
   NetBios через TCP/IP. . . . . . . . : Включен

kini ()

Лапшу и тред не читал, но вангую, что пров выдает dns через dhcp, а на роутере выставлен 8.8.8.8 или что-то типа того. Т.к. домен прова локальный получается облом.

no-such-file ★★★★★ ()
Ответ на: комментарий от no-such-file

<b>no-such-file</b> Да, «восьмерки» выдаются в локалку, равно как и DNS провайдера. Даже без «восьмерок» все равно не работает. Да и пинг с роутера до сервера с кабинетом работал бы тогда.

Как и предполагалось, смена mac-адреса на роутере на mac-адрес ноутбука позволил открывать кабинет. Смена протокола на статику со сменой шлюза (через который кабинет открывается) ничего не дала.

kini ()
Ответ на: комментарий от kini

Первый раз вижу такого «злобного» провайдера, который левому mac-адресу выдаёт «белый» ip адрес и выпускает в инет. Поди ещё мегабайты не считает/полосу не ограничивает.

mky ★★★★★ ()
Ответ на: комментарий от mky

Этот «злобный» провайдер позволяет зарегистрировать несколько mac-адресов, чем я и воспользовался :) Так что «левых» mac-ов нет

kini ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.