LINUX.ORG.RU

монтирование flash(usb-storage) - ВСПОМОЖИТЕ!!


0

0

Что-то я совсем задолбался ковыряться,- башка не соображает по теме более.
hal,dbus,pmount,ivman установлены.
Теперь цитаты.
1. /etc/fstab:
------------
/dev/olympus /mnt/olympus msdos noauto,rw,user 0 0
------------

2. /etc/ivman/IvmConfigMappings.xml:
-----------
<ivm:Map device="/dev/sda1" maps="/dev/olympus" />
----------


3. /etc/udev/rules.d/udev.rules:
------------
BUS="usb", SYSFS{serial}="124709356", KERNEL="sd?0", NAME="%k", SYMLINK="olympus" GROUP="hal"
BUS="usb", KERNEL="*[!0-9]", PROGRAM="/bin/cat /proc/ide/%k/media", RESULT="olympus*", NAME="%k",GROUP="hal", MODE="0660"
-----------


Всё в общем-то монтируется нормально, но , в kde есть такая штука как media:/ , когда я в конквероре пытаюсь обратиться к фотику через эту самую media(mount на значке дивайса), он пишет, что согласно mtab уже смонтировано в соотв-й директорий(/mnt/olympus)
Если я делаю kio_media_mounthelper /dev/olympus && konqueror /mnt/olympus, то я получаю, то чего добиваюсь - захожу в смонтированный диск флешки и в последующем имею возможность сделать kio_media_mounthelper -u /dev/olympus - т.е. эта процедура срабатывает нормально.
Как добиться, чтобы и через обращение к media:/ всё происходило корректно(ведь в случае с разделами ЖД,которые там же в медиа отображаются, всё отлично)?

Re: монтирование flash(usb-storage) - ВСПОМОЖИТЕ!!

Сейчас свежим взглядом обнаружил одну ошибочку здесь:
BUS="usb", KERNEL="*[!0-9]", PROGRAM="/bin/cat /proc/_ide_/%k/media",...

но и в исправленном виде на ход дела это не влияет:(

Re: монтирование flash(usb-storage) - ВСПОМОЖИТЕ!!

начиная с версии 3.5, кеды научились самостоятельно работать с hal'ом, посему отруби ivman за ненадобностью.

home_user ★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.