LINUX.ORG.RU

обновился тут до 2.6.15.2. Теперь не запускается init


0

0

Решил обновить ядро с 2.6.13 (собственно из-за FUSE + MPPE). При загрузке 2.6.15.2 дело доходит до надписей:
ext2_fill_super: mounting ext3 filesystem as ext2
VFS: mounted root (ext2 filesystem) readonly

.. и все. Вроде как после этого должен запускаться init, а его нет. 
Я не очень понял смысл сообщения "mounting ext3 filesystem as ext2", потому что в fstab раздел описаны вот так:
/dev/hdc1      /boot    ext2    defaults        1 2
Это ide-шный винт на матери с VIA KT133. Для чипсета и файловых систем все в ядре включено. Данное сообщение не появляется при загрузке 2.6.13.

в grub загрузка описана вот так:
title   (2.6.15.2)
	root (hd0,0)
	kernel /vmlinuz-2.6.15.2 ro acpi=on root=/dev/hdc6 init=/sbin/bootchartd
	initrd /initrd-2.6.15.2.img

Кто с подобным сталкивался - как это лечится? 
anonymous

Re: обновился тут до 2.6.15.2. Теперь не запускается init

udev обновил?

UVV ★★★★★ ()

Re: обновился тут до 2.6.15.2. Теперь не запускается init

Обновил:

$ rpm -qa |grep udev

udev-071-0.FC4.2

Ожидаемого результата не получил. Подумал на bootchart, но замена init=/sbin/init и просто убирание этого параметра из grub результата тоже не дало. Логи естественно пустые, т.к. корневой раздел не монтируется в r/w.. да вообще никак не монтируется. Что еще может быть причиной?

anonymous ()

Re: обновился тут до 2.6.15.2. Теперь не запускается init

отбой, мой косяк. Не включил CONFIG_BLK_DEV_INITRD=y Не зря обновился - на 2.6.15 не собирается ltmodem, отвалился named, будет теперь чем заняться :)

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.