LINUX.ORG.RU

Установка новых пакетов


0

0

При попытке установить .rpm с дровами принтера начинает ругаться на неправипльные зависимости libxml и libglade вопрос куда копать ? что-нибудь связанное с версиями может быть ? стоит centos 4.1 просьба не пинать совсем уж, ибо только начал ... По поиску не нгашел ничего подходящего....


Re: Установка новых пакетов

напиши точно как ругается

arax ()
Ответ на: Re: Установка новых пакетов от arax

Re: Установка новых пакетов

Вот дословно:
[root@crt Canon]# rpm -ivh bjfilteri250-2.3-0.i386.rpm
ошибка: Неудовлетворенные зависимости:
        libglade.so.0 нужен для bjfilteri250-2.3-0.i386
        libxml.so.1 нужен для bjfilteri250-2.3-0.i386
[root@crt Canon]# 

CRT ()

Re: Установка новых пакетов

Надо установить пакеты libxml и libglade из своего дистрибутива.

suser ()
Ответ на: Re: Установка новых пакетов от suser

Re: Установка новых пакетов

У меня пакеты libglade2-2.4.0-5.i386.rpm и libxml2-2.6.16-6.i386.rpm и при попытке установки он пишет что они уже установлены

CRT ()
Ответ на: Re: Установка новых пакетов от CRT

Re: Установка новых пакетов

Залезь в /usr/lib/ и сделай симлинки с соответствующими именами,
а потом если rpm -ivh * не прокатит то rpm -ivh --nodeps --force *

iRunix ★★★★ ()
Ответ на: Re: Установка новых пакетов от CRT

Re: Установка новых пакетов

>У меня пакеты libglade2-2.4.0-5.i386.rpm и libxml2-2.6.16-6.i386.rpm и при попытке установки он пишет что они уже установлены

Симлинки тебе не помогут, ему нужны первые версии данных библиотек, и я сильно сомневаюсь, что они бинарно совместимы со вторыми. Т.е ищи libglade-x.x.x-x.i386.rpm и libxml-x.x.x-x.i386.rpm

arax ()
Ответ на: Re: Установка новых пакетов от Demetrio

Re: Установка новых пакетов

libglade и libglade2 - РАЗНЫЕ пакеты.
Нужно искать либо libglade в бинарниках для вашего дистрибутива, либо собирать его самостоятельно из libglade-*.src.rpm.
То же справедливо и для второго пакета.
Что касается симлинков, то они могут помочь, а могут и наоборот навредить.
Что касается наличие записей о libglade.so и о второй библиотеке, то это обходится с помощью --nodeps при установке.
Но учитывая уровень ваших вопросов, я вам рисковать не советую, лучше поставьте libglade и второй пакет.

archont ★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.