LINUX.ORG.RU

не могу скомпилить драйвера для Skystar2


0

0

Господа, поможите кто может. Надо скомпилить дрова для SkyStar2 но при компиляции вылезает одна и таже ошибка. /usr/src/linux-2.4.21-20.EL/include/linux/modules/videodev.ver:8:1: warning: this is the location of the previous definition In file included from saa7146_core.c:37: ../compat.h:62:1: warning: "video_devdata" redefined In file included from /usr/src/linux-2.4.21-20.EL/include/linux/modversions.h:337, from <command line>:1: /usr/src/linux-2.4.21-20.EL/include/linux/modules/videodev.ver:6:1: warning: this is the location of the previous definition saa7146_core.c: In function `saa7146_core_command': saa7146_core.c:378: warning: passing arg 1 of `remap_page_range_R5a76d065' makes pointer from integer without a cast saa7146_core.c:378: incompatible type for argument 4 of `remap_page_range_R5a76d065' saa7146_core.c:378: too few arguments to function `remap_page_range_R5a76d065' make[4]: *** [saa7146_core.o] Error 1 make[4]: Leaving directory `/home/DVB/driver/av7110' make[3]: *** [_modsubdir_av7110] Error 2 make[3]: Leaving directory `/home/DVB/driver' make[2]: *** [_mod_/home/DVB/driver] Error 2 make[2]: Leaving directory `/usr/src/linux-2.4.21-20.EL' make[1]: *** [here] Error 2 make[1]: Leaving directory `/home/DVB/driver' make: *** [dvb] Error 2

Система RH9. очень нада....

Re: не могу скомпилить драйвера для Skystar2

а ядро обязательно 2.4.21-20 нужно? у меня на 2.6.10 отлично работает (дрова в ядре уже есть). Кстати, собирал на 2.4.29 (Slackware 10.1), тоже работает. Прввда, помоему, там если make clean перед сборкой дров не сделать, тоже ругается, но точно не помню.

Про 2.6.Х написано здесь: http://www.linux.org.ru/jump-message.jsp?msgid=1201680

Почитай еще http://www.itelsat.info/ и http://forum.planetsky.com/ мож там че будет (там чтото точно есть). И вообще на странички провайдеров спутникового инета позаходи, там в форумах найдешь...

samson ★★ ()
Ответ на: Re: не могу скомпилить драйвера для Skystar2 от samson

Re: не могу скомпилить драйвера для Skystar2

>а ядро обязательно 2.4.21-20 нужно

у меня на 2.4.19 всё великолепно работает .......

зайди на gs.ru >спутниковый ннет , скачай дрова патченные ядерным котом

anonymous ()
Ответ на: Re: не могу скомпилить драйвера для Skystar2 от anonymous

Re: не могу скомпилить драйвера для Skystar2

одно из вестно точно что дрова с linux tv 1.1.1a и 1.1.1 под 2.4.19 скомпилить мне не удолось в силу выше изложенных вами причин , правда както очень давно , месяца 3 назад после не хитрои модификации мэйк файла , удалось избавиться от компиляции проблемных , и к томуже не нужных модулей , в итоге всё скомпилилось >;-> , попробуй более ранние версии дров с линух тв ,,, ну надеюсь что вы ето делаете в папочке для 2.4

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.