LINUX.ORG.RU

QT 2.2.2 не могу собрать


0

0

Сабж - make выдает ошибки в kernel/qapplication.cpp пробовал в ём покопаться но заё***ся на исходе второго дня.

Попробывал установить 2.3.1 скачал с тролльтеч, результат - таже жопа,только с ручкой. kernel/kpsprinter.cpp:4567: 'XGetFontPath' андекларед.

Черканите пожалуйста откуда можно качнуть библиотеки, которые реально бы собирались или скажите чё не так?

конфигурирую я так: ./configure -platform linux-g++ -qt-libpng -system-jpeg

ASP Linux ядро 2.2.19

Сижу жду,смотрю порнуху,пью пиво.


Re: QT 2.2.2 не могу собрать

У меня тоже наблюдалась проблема но, и я делал так:
./configure --no-g++-exceptions (Что-то в этом духе посмотри через --help) А далее включал всяки там жпеги и прочую лажу. Помогло
всё стало работать, кстати гсс-3.0 у меня стоит !!! :))

DEathq3 ()

Re: QT 2.2.2 не могу собрать

парни (не в тему немного ) а что потом делать после того как собрал эти библиотеки мне сказали что надо готовые (после компиляции) библиотеки (которые находяться в каталоге ~/qt-2.2.4/lib) поместить в /usr/lib а потом сделать ldconfig ну я это делаю а что дальше происходит ? у меня одна прога(или даже не одна :( ) без КУ ТЭ 2.2.2 не хочет работать помогите плз

globus ()
Ответ на: Re: QT 2.2.2 не могу собрать от globus

The same thing

Дело в том что это и моя проблема тоже :)) Есть прога, (а конкретно camstream) для обработки потоков данных с Web камеры. Так вот,ей надо qt=>qt-2.2.2. -"Ха!!!" ,подумал я, -"у меня already qt 2.2.4, сейчас всё будит рулить!!!". Но нет, эта гадина не находит нужные ей библиотеки. -"Ладно" думаю. -"Соберу специально для тебя qt-2.2.2" ну и дальше понятно.

После сборки qt, куда их деть,на мой взгляд твоё личное рутовое дело, главное чтобы в переменных окружения правильная ссылочка стояла. если я ошибаюсь,скажите.

Запущу ка я Sambу и в папку pub буду класть картинки для Вынь юзеров вот так.:))

deVitos ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.