LINUX.ORG.RU

Installation failed wicd

 , ,


0

1

* ERROR: net-misc/wicd-1.7.2.4-r2::gentoo failed (install phase):
* Installation failed with CPython 2.7 in distutils_installation() function
*
* Call stack:
* ebuild.sh, line 93: Called src_install
* environment, line 4886: Called distutils_src_install
* environment, line 1272: Called python_execute_function '-s' 'distutils_installation'
* environment, line 3263: Called die
* The specific snippet of code:
* die «${failure_message}»;

Кто-нибудь знает как это лечить?

а у тебя python-distutils (или как там оно в генте называется) установлено?

Siado ★★★★★ ()
Ответ на: комментарий от postgred

Вы целиком лог сборки пакета посмотрите.

Ну и возможно вам поможет вызов

python-updater

kostik87 ★★★★★ ()
Последнее исправление: kostik87 (всего исправлений: 1)
Ответ на: комментарий от Siado

Вроде, да. По крайней мере все пакеты, в которых есть distutils я поставил)

postgred ()
Ответ на: комментарий от kostik87

python-updater - пробовал
В полном логе нашел только эти ошибки
warning: install_lib: byte-compiling is disabled, skipping.

error: can't copy 'translations/ca/LC_MESSAGES/wicd.mo': doesn't exist or not a regular file

postgred ()
Ответ на: комментарий от postgred

Выложите лог сборки целиком на pastebin сервис, а ссылку сюда.

kostik87 ★★★★★ ()
Ответ на: комментарий от postgred

Ну и здесь собирается и если бы корректно отрабатывали скрипты portage, а не «ругались»:

Replacing values in scripts=wicd.in scripts/wicd
Traceback (most recent call last):
  File «/usr/lib/python-exec/python2.7/pybabel», line 5, in <module>
    from pkg_resources import load_entry_point
  File «/usr/lib64/python2.7/site-packages/pkg_resources.py», line 3007, in <module>
    working_set.require(__requires__)
  File «/usr/lib64/python2.7/site-packages/pkg_resources.py», line 728, in require
    needed = self.resolve(parse_requirements(requirements))
  File «/usr/lib64/python2.7/site-packages/pkg_resources.py», line 626, in resolve
    raise DistributionNotFound(req)
pkg_resources.DistributionNotFound: pytz>=0a
Traceback (most recent call last):
  File «/usr/lib/python-exec/python2.7/pybabel», line 5, in <module>
    from pkg_resources import load_entry_point
  File «/usr/lib64/python2.7/site-packages/pkg_resources.py», line 3007, in <module>
    working_set.require(__requires__)
  File «/usr/lib64/python2.7/site-packages/pkg_resources.py», line 728, in require
    needed = self.resolve(parse_requirements(requirements))
  File «/usr/lib64/python2.7/site-packages/pkg_resources.py», line 626, in resolve
    raise DistributionNotFound(req)
pkg_resources.DistributionNotFound: pytz>=0a
Traceback (most recent call last):
  File «/usr/lib/python-exec/python2.7/pybabel», line 5, in <module>
    from pkg_resources import load_entry_point
  File «/usr/lib64/python2.7/site-packages/pkg_resources.py», line 3007, in <module>
    working_set.require(__requires__)
  File «/usr/lib64/python2.7/site-packages/pkg_resources.py», line 728, in require
    needed = self.resolve(parse_requirements(requirements))
  File «/usr/lib64/python2.7/site-packages/pkg_resources.py», line 626, in resolve
    raise DistributionNotFound(req)
pkg_resources.DistributionNotFound: pytz>=0a
Traceback (most recent call last):
  File «/usr/lib/python-exec/python2.7/pybabel», line 5, in <module>
    from pkg_resources import load_entry_point
  File «/usr/lib64/python2.7/site-packages/pkg_resources.py», line 3007, in <module>
    working_set.require(__requires__)
  File «/usr/lib64/python2.7/site-packages/pkg_resources.py», line 728, in require
    needed = self.resolve(parse_requirements(requirements))
  File «/usr/lib64/python2.7/site-packages/pkg_resources.py», line 626, in resolve
    raise DistributionNotFound(req)
pkg_resources.DistributionNotFound: pytz>=0a
Traceback (most recent call last):
  File «/usr/lib/python-exec/python2.7/pybabel», line 5, in <module>
    from pkg_resources import load_entry_point
  File «/usr/lib64/python2.7/site-packages/pkg_resources.py», line 3007, in <module>
    working_set.require(__requires__)
  File «/usr/lib64/python2.7/site-packages/pkg_resources.py», line 728, in require
    needed = self.resolve(parse_requirements(requirements))
  File «/usr/lib64/python2.7/site-packages/pkg_resources.py», line 626, in resolve
    raise DistributionNotFound(req)
pkg_resources.DistributionNotFound: pytz>=0a
Traceback (most recent call last):
  File «/usr/lib/python-exec/python2.7/pybabel», line 5, in <module>
    from pkg_resources import load_entry_point
  File «/usr/lib64/python2.7/site-packages/pkg_resources.py», line 3007, in <module>
    working_set.require(__requires__)
  File «/usr/lib64/python2.7/site-packages/pkg_resources.py», line 728, in require
    needed = self.resolve(parse_requirements(requirements))
  File «/usr/lib64/python2.7/site-packages/pkg_resources.py», line 626, in resolve
    raise DistributionNotFound(req)
pkg_resources.DistributionNotFound: pytz>=0a
Traceback (most recent call last):
  File «/usr/lib/python-exec/python2.7/pybabel», line 5, in <module>
    from pkg_resources import load_entry_point
  File «/usr/lib64/python2.7/site-packages/pkg_resources.py», line 3007, in <module>
    working_set.require(__requires__)
  File «/usr/lib64/python2.7/site-packages/pkg_resources.py», line 728, in require
    needed = self.resolve(parse_requirements(requirements))
  File «/usr/lib64/python2.7/site-packages/pkg_resources.py», line 626, in resolve
    raise DistributionNotFound(req)
то точно так же бы корректно всё установилось и работало.

Вперёд в google, ищите причину проблем, так же можете сходить на gentoo.ru и в http://bugs.gentoo.org/ поискать решение.

Вы ещё что-нибудь ставили в систему в обход portage ?

kostik87 ★★★★★ ()
Ответ на: комментарий от postgred

Попробуйте переключиться на python3, выполнить python-updater, ну и попробовать заново поставить, возможно перед установкой попробуйте:

emerge -auvDN world

kostik87 ★★★★★ ()

Решение

Кажется, проблема была в том, что wicd и urwid были собраны разными версиями python. Выбрал python 2.6 как основной, python-updater, затем emerge -val world. После всех этих манипуляций wicd смог, наконец, установится.

postgred ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.