LINUX.ORG.RU
ФорумGames

Enemy-Territory + ArchLinux + x86_64


0

0

Имеется 64-х битный ArchLinux.
Стянул с AUR bin32-enemy-territory, собрал пакет, установил его...
В зависимостях установились lib32-libgl lib32-libxext.

Как я понимаю этого достаточно для корректной работы 32-х битной игрушки под 64-хбитной системой.

Но вот при запуске вылезает следующее:

~ $ /usr/bin/enemy-territory
ET 2.60b linux-i386 May 8 2006
----- FS_Startup -----
Current search path:
/home/groove/.etwolf/etmain
/opt/bin32-enemy-territory/etmain/pak2.pk3 (22 files)
/opt/bin32-enemy-territory/etmain/pak1.pk3 (10 files)
/opt/bin32-enemy-territory/etmain/pak0.pk3 (3725 files)
/opt/bin32-enemy-territory/etmain/mp_bin.pk3 (6 files)
/opt/bin32-enemy-territory/etmain

----------------------
3763 files in pk3 files
execing default.cfg
couldn't exec language.cfg
couldn't exec autoexec.cfg
Hunk_Clear: reset the hunk ok

------- Input Initialization -------
Joystick is not active.
------------------------------------
Bypassing CD checks
----- Client Initialization -----
----- Initializing Renderer ----
-------------------------------
----- Client Initialization Complete -----
----- R_Init -----
...loading libGL.so.1: QGL_Init: dlopen libGL.so.1 failed: libXdamage.so.1: wrong ELF class: ELFCLASS64
failed
----- CL_Shutdown -----
RE_Shutdown( 1 )
-----------------------
----- CL_Shutdown -----
-----------------------
Sys_Error: GLimp_Init() - could not load OpenGL subsystem

~ $

Кто-нибудь сталкивался?

anonymous

Re: Enemy-Territory + ArchLinux + x86_64

сменить дистриб на 32bita ?

eR ★★★★★ ()

Re: Enemy-Territory + ArchLinux + x86_64

А lib32-libxdamage установлен?

anonymous ()
Ответ на: Re: Enemy-Territory + ArchLinux + x86_64 от eR

Re: Enemy-Territory + ArchLinux + x86_64

>сменить дистриб на 32bita ?

Лучше на 16Бит M$DOS или ваще 8Бит TR-DOS.

anonymous ()

Re: Enemy-Territory + ArchLinux + x86_64

1. отключи всякие compizы, если есть

2. выстави в иксах и в игрушке одинаковое разрешение, цветность

> .loading libGL.so.1: QGL_Init: dlopen libGL.so.1 failed: libXdamage.so.1: wrong ELF class: ELFCLASS64

отключи этот модуль в xorg.conf/пересобери иксы/дрова на видеокарту/ядро

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.