LINUX.ORG.RU
ФорумGames

Не запускаются игры через стим

 ,


0

2

Загрузил циву 5ю, нажимаю играть - и ничего. Никаких надписей или ошибок нет. Просто не запускается. Аналогично и с другими играми. Пробовал запускать через терминал, пишет только вот это

steam steam://rungameid/8930
Running Steam on arch  32-bit
STEAM_RUNTIME is enabled automatically

★★★★★

Сча, libastral скомпилирую.

roman77 ★★★★★ ()

убедись, что установлен видеодрайвер. Если система 64-битная, убедись что дополнительно установлен 32-битный видеодрайвер

router ★★★★★ ()

пишет только вот это w1nner@archlinux

посмотрел в свой хрустальный шар и увидел свежайшие иксы с драйверами. интел, небось?

registrant ★★★★★ ()
Ответ на: комментарий от registrant

Ответ на: комментарий от router 24.07.2014 13:46:54

Блоб нвидии стоит, система i686.

w1nner ★★★★★ ()

Только указанное пишет и вылетает, или ты не весь лог привел?

kravich ★★★★ ()
Ответ на: комментарий от kravich

При запуске из гуя вообще ничего не пишет. В каталоге Desktop нашел ярлыки для игр и скопировал путь запуска - вот что потом вывелось в консоль - то и написал. Это полный лог.

w1nner ★★★★★ ()
Ответ на: комментарий от w1nner

запусти стим из консоли, затем игру в нем, и скинь полный лог

kravich ★★★★ ()

Попробуй зайти туда, где лежат файлы игры и запустить исполняемый файл через консоль (не стимом).

Moonshine ()
Ответ на: комментарий от kravich

Запустил через консоль стим, потом запустил цивилизацию. Вот лог

w1nner ★★★★★ ()

Стим перезапусти, у меня такое тоже иногда бывает.

nickionn ★☆ ()
Ответ на: комментарий от w1nner

попробуй отключи в настройках стима их game overlay Settings -> In-Game -> Enable Steam overlay while in-game

anonymous ()
Ответ на: комментарий от w1nner

Вот лог

ERROR: ld.so: object '/home/w1nner/.local/share/Steam/ubuntu12_64/gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS64): ignored. ERROR: ld.so: object '/home/w1nner/.local/share/Steam/ubuntu12_64/gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS64): ignored.

По ходу оно.

Вот тут в самом конце чувак описывает такую же проблему с Civ5. Решением указывает удаление bumblebee и установку nvidia-prime. Уж не знаю насколько это корректное решение.

Я уже вроде видел описание этой проблемы на стим-форумах, фикса, емнип, там не было. Для интелов писали, что помогает запуск с какими-то параметрами, для остальных - не в курсе.

xxblx ★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.