LINUX.ORG.RU

crossdev и armv4tl-softfloat-linux-gnueabi

 ,


0

2

Не получается установить armv4tl-softfloat-linux-gnueabi на gentoo x64. Ошибка такая

sudo crossdev -S armv4tl-softfloat-linux-gnueabi
Password:
----------------------------------------------------------------------------
 * crossdev version:      20120913
 * Host Portage ARCH:     amd64
 * Target Portage ARCH:   arm
 * Target System:         armv4tl-softfloat-linux-gnueabi
 * Stage:                 4 (C/C++ compiler)
 * ABIs:                  default

 * binutils:              binutils-[stable]
 * gcc:                   gcc-[stable]
 * headers:               linux-headers-[stable]
 * libc:                  glibc-[stable]

 * CROSSDEV_OVERLAY:      /var/lib/layman/calculate
 * PORT_LOGDIR:           /var/log/portage
 * PORTAGE_CONFIGROOT:    
 * Portage flags:         
  _  -  ~  -  _  -  ~  -  _  -  ~  -  _  -  ~  -  _  -  ~  -  _  -  ~  -  _ 
 * leaving sys-devel/binutils in /var/lib/layman/calculate
 * leaving sys-devel/gcc in /var/lib/layman/calculate
 * leaving sys-kernel/linux-headers in /var/lib/layman/calculate
 * leaving sys-libs/glibc in /var/lib/layman/calculate
 * leaving sys-devel/gdb in /var/lib/layman/calculate
 * leaving metadata/layout.conf alone in /var/lib/layman/calculate
  _  -  ~  -  _  -  ~  -  _  -  ~  -  _  -  ~  -  _  -  ~  -  _  -  ~  -  _ 
 * Log: /var/log/portage/cross-armv4tl-softfloat-linux-gnueabi-binutils.log
 * Emerging cross-binutils ...

 * binutils failed :(
 * If you file a bug, please attach the following logfiles:
 * /var/log/portage/cross-armv4tl-softfloat-linux-gnueabi-info.log
 * /var/log/portage/cross-armv4tl-softfloat-linux-gnueabi-binutils.log.xz
 * /var/calculate/tmp/portage/cross-armv4tl-softfloat-linux-gnueabi/binutils*/temp/binutils-config.logs.tar.xz

★★★★★

Ну а собственно в log файлах то что?
Интересует в частности /var/log/portage/cross-armv4tl-softfloat-linux-gnueabi-binutils.log.xz

Micky53 ()
Ответ на: комментарий от Micky53

в принципе проблему решил, просто устанавливая каждый ebuild в ручную. Но теперь не собирается gcc вываливаясь на ошибке gcc_src_unpack: command not found

Landgraf ★★★★★ ()
Ответ на: комментарий от Micky53

gcc 4.3.4, сейчас попробую установить его новее в arm

Landgraf ★★★★★ ()

поместил вот это в скрипт

export ARCH=arm
export CROSS_COMPILE=arm-none-linux-gnueabi-
 
# Add toolchain's path to your $PATH variable
export PATH=~/fadevel/arm-2010.09/bin:$PATH
 
# This to allows programs compile
export CFLAGS="-O3 -march=armv4t -mtune=arm920t" 
и запускал его перед компиляцией.

Отсюда скачал arm-linux-gcc http://www.friendlyarm.net/dl.php?file=arm-linux-gcc-4.4.3.tgz

Landgraf ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.