LINUX.ORG.RU

QSqlDatabase: QMYSQL driver not loaded


0

1

Подсобите в данной проблеме. Интернет говорит, что необходимо собрать драйвер для mysql. где то нарыл в нете, что для убунту есть спец пакет, libqt4-sql-mysql который и есть плагин для работы с mysql. После утановки пакета проблема не исчезла. В нете полноценной исчерпывающей рускоязычной информации по данному вопросу найти не удалось. Больно все абстрактно: утадовить mysql-devel пакет, который может и иначе называться, заголовочные файлы, короче мутный вопрос. =) Прошу пролить свет на этот вопрос людей опытных. =)


Ответ на: комментарий от MikeDM

Проблема в запуске скомпилированного кода. Собственно вот процесс компиляции:

root@101302-10002:/home/utilites/hosting_controller# make
make: Nothing to be done for `first'.
root@101302-10002:/home/utilites/hosting_controller# make
g++ -c -m64 -pipe -O2 -Wall -W -D_REENTRANT -DQT_NO_DEBUG -DQT_GUI_LIB -DQT_CORE_LIB -DQT_SHARED -I/usr/local/Trolltech/Qt-4.8.4/include/QtSql -I/usr/local/Trolltech/Qt-4.8.4/include/QtCore -I/usr/local/Trolltech/Qt-4.8.4/include/QtNetwork/ -I/usr/local/Trolltech/Qt-4.8.4/include -o logger.o logger.cpp
g++ -c -m64 -pipe -O2 -Wall -W -D_REENTRANT -DQT_NO_DEBUG -DQT_GUI_LIB -DQT_CORE_LIB -DQT_SHARED -I/usr/local/Trolltech/Qt-4.8.4/include/QtSql -I/usr/local/Trolltech/Qt-4.8.4/include/QtCore -I/usr/local/Trolltech/Qt-4.8.4/include/QtNetwork/ -I/usr/local/Trolltech/Qt-4.8.4/include -o main.o main.cpp
main.cpp: In function ‘int main()’:
main.cpp:53:5: warning: unused variable ‘data_control_int’ [-Wunused-variable]
g++ -c -m64 -pipe -O2 -Wall -W -D_REENTRANT -DQT_NO_DEBUG -DQT_GUI_LIB -DQT_CORE_LIB -DQT_SHARED -I/usr/local/Trolltech/Qt-4.8.4/include/QtSql -I/usr/local/Trolltech/Qt-4.8.4/include/QtCore -I/usr/local/Trolltech/Qt-4.8.4/include/QtNetwork/ -I/usr/local/Trolltech/Qt-4.8.4/include -o parameters_load.o parameters_load.cpp
g++ -c -m64 -pipe -O2 -Wall -W -D_REENTRANT -DQT_NO_DEBUG -DQT_GUI_LIB -DQT_CORE_LIB -DQT_SHARED -I/usr/local/Trolltech/Qt-4.8.4/include/QtSql -I/usr/local/Trolltech/Qt-4.8.4/include/QtCore -I/usr/local/Trolltech/Qt-4.8.4/include/QtNetwork/ -I/usr/local/Trolltech/Qt-4.8.4/include -o smtp.o smtp.cpp
smtp.cpp: In member function ‘QString Smtp::SendLineAndGrab(QString)’:
smtp.cpp:218:6: warning: unused variable ‘real’ [-Wunused-variable]
g++ -c -m64 -pipe -O2 -Wall -W -D_REENTRANT -DQT_NO_DEBUG -DQT_GUI_LIB -DQT_CORE_LIB -DQT_SHARED -I/usr/local/Trolltech/Qt-4.8.4/include/QtSql -I/usr/local/Trolltech/Qt-4.8.4/include/QtCore -I/usr/local/Trolltech/Qt-4.8.4/include/QtNetwork/ -I/usr/local/Trolltech/Qt-4.8.4/include -o sql.o sql.cpp
sql.cpp: In function ‘QSqlQuery InsertSQL(QString, QString, QSqlDatabase)’:
sql.cpp:40:1: warning: control reaches end of non-void function [-Wreturn-type]
sql.cpp: In function ‘QSqlQuery SelectSQL(QString, QString, QSqlDatabase)’:
sql.cpp:28:1: warning: control reaches end of non-void function [-Wreturn-type]
g++ -c -m64 -pipe -O2 -Wall -W -D_REENTRANT -DQT_NO_DEBUG -DQT_GUI_LIB -DQT_CORE_LIB -DQT_SHARED -I/usr/local/Trolltech/Qt-4.8.4/include/QtSql -I/usr/local/Trolltech/Qt-4.8.4/include/QtCore -I/usr/local/Trolltech/Qt-4.8.4/include/QtNetwork/ -I/usr/local/Trolltech/Qt-4.8.4/include -o moc_smtp.o moc_smtp.cpp
g++ -m64 -Wl,-O1 -Wl,-rpath,/usr/local/Trolltech/Qt-4.8.4/lib -o hosting_controller logger.o main.o parameters_load.o smtp.o sql.o moc_smtp.o    -L/usr/local/Trolltech/Qt-4.8.4/lib -lQtCore -lQtSql -lQtNetwork

А затем вот запуск скомпилированного файла:

root@101302-10002:/home/utilites/hosting_controller# ./hosting_controller
QSqlDatabase: QMYSQL driver not loaded
QSqlDatabase: available drivers: QSQLITE
QSqlDatabase: an instance of QCoreApplication is required for loading driver plugins
Aeooe ()
Ответ на: комментарий от MikeDM

Перезагрузка не решила проблему. Хотелось бы узнать проблему поближе. Где при запуске ищется плагин mysql? Как выглядит плагин mysql? Возможно не прописан корректный путь для поиска плагина?

Aeooe ()
Ответ на: комментарий от Aeooe

Я не понял, ты Qt качал с сайта проекта? Зачем, если можно из репозитория установить? Это как бы не венда.

Видимо, в этом и проблема, при установке из репозитория как раз всё нормально ищется. А если из другого места ставил, то нужно ковырять, чтобы она нашла. Ну и плюс может возникнуть несовместимость (хотя у qt это не так часто встречается).

Ttt ☆☆☆☆☆ ()
Ответ на: комментарий от MikeDM

Может пересобрать плагин вручную? Правда не вся картина сего действа сложилась у меня в голове =)

Aeooe ()
Ответ на: комментарий от Aeooe

С большой долей вероятности она у тебя частично стоит, т.к. требуется для работы приложений. И в процессе установки новых пакетов установятся и другие компоненты. Так что да, если нет нужды разрабатывать на отличной от системной версии, нужно установить dev-компоненты qt из репозитория (если не ошибаюсь, пакет, ставящий всё, называется qt4-sdk).

Ttt ☆☆☆☆☆ ()
Ответ на: комментарий от Ttt

Ну попробуем. Меня изначально испугал размер пакета sdk ~800мб. Ксати вопрос не по теме. Моя прога использует только QtSql, QtNetwork, QtCore. Возможно есть «рецепт» как поставить только эти компоненты библиотеки?

Aeooe ()
Ответ на: комментарий от Aeooe

Ну смотри среди зависимостей (там они правда многоэтажные) и ставь те, которые тебе нужны.

Ttt ☆☆☆☆☆ ()
Ответ на: комментарий от Aeooe

ты поставил не из реп сбе Qt4 и еще удивляешься. епрст. удали все что руками понаставил и поставь из реп.

MikeDM ★★★★★ ()
Ответ на: комментарий от pztrn

поставил из репозитория и вот новая проблемка выскочила:

<code>Unable to load library icui18n «Cannot load library icui18n: (libicui18n.so.48: cannot open shared object file: No such file or directory)»</code>

Что это за либа вообще? В чем проблемка?

Aeooe ()
Ответ на: комментарий от Aeooe
pztrn@pztrn:~$ aptitude search libicu
p   libicu-dev                                                      - Development files for International Components for Unicode               
i A libicu48                                                        - компоненты интернационализации для Unicode                               
p   libicu48-dbg                                                    - International Components for Unicode                                     
p   libicu4j-4.4-java            pztrn@pztrn:~$ aptitude search libicu
p   libicu-dev                                                      - Development files for International Components for Unicode               
i A libicu48                                                        - компоненты интернационализации для Unicode                               
p   libicu48-dbg                                                    - International Components for Unicode                                     
p   libicu4j-4.4-java                                               - Library for Unicode support and internalisation                          
p   libicu4j-java                                                   - Library for unicode support and internalisation                                    - Library for Unicode support and internalisation                          
p   libicu4j-java                                                   - Library for unicode support and internalisation 
pztrn ★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.