LINUX.ORG.RU

собрать модуль ядра под 2.4


0

1

собстно сабж.

под 2.6 все собирается нормально.

под 2.4 http://img259.imageshack.us/img259/7135/selection001w.png

Makefile:

 
# obj-m is a list of what kernel modules to build.  The .o and other
# objects will be automatically built from the corresponding .c file -
# no need to list the source files explicitly.

obj-m += main.o 

# KDIR is the location of the kernel source.  The current standard is
# to link to the associated source tree from the directory containing
# the compiled modules.
KDIR  := /lib/modules/$(shell uname -r)/build

# PWD is the current working directory and the location of our module
# source files.
PWD   := $(shell pwd)

# default is the default make target.  The rule here says to run make
# with a working directory of the directory containing the kernel
# source and compile only the modules in the PWD (local) directory.
default:
	$(MAKE) -C $(KDIR) M=$(PWD) modules

подскажите в чем проблемма.

no such file or derictory

найди файл.

bhfq ★★★★★ ()
Ответ на: комментарий от bhfq

КЭП ? : )

видимо я как-то не так собираю дров т.к. аналогичная проблемма на centos и debian. Уже сутки бьюсь % ) В общем если кто-то стакивался с сабжем выложите плз свой Makefile или скажите что не так.

nisedeath ()

мля, как вы достали со скриншотами текста
мог ещё в .flv выкладывать

anonymous ()
Ответ на: комментарий от anonymous

ну просто debian 3.1 на виртулке весит. влом было туда сюда гонять лог % )

nisedeath ()
Ответ на: комментарий от nisedeath

лурко#б, почему ты можешь копипастить с луркморе, а лог выкладываешь как скриншот?

Rzhepish ()
Ответ на: комментарий от nisedeath

debian 3.1 на виртулке весит

И много весит? Пару кило есть?

anonymous ()

2.4 и 2.6 имеют разные API и несовместимы. Ты уверен что то что ты собираешь расчитано на 2.4?

true_admin ★★★★★ ()

под 2.6 все собирается нормально.

под 2.4 http://img259.imageshack.us/img259/7135/selection001w.png

идрить. Действительно, странно, что этот модуль не собирается для ядра со слегка другим API, правда?

nisedeath

Ник свой сначала правильно напиши, болван!

anonymous ()
Ответ на: комментарий от true_admin

ага. в общем я разобрался в чем дело. начиная с 2.6 модули ядра подругому компилятся. Впринцепи это я итак знал, только не мог понять как раньше было, поэтому и спросил.

2anonymous ну тут я могу лишь сказать пнх : ) Умника из себя строишь, а на самом деле видно, что дурачок. Залогинься хотябы.

Тему считаю исчерпавщей себя. разочарован ответами некоторых личностей.

nisedeath ()
Ответ на: комментарий от nisedeath

Нужно быть Über-гением, чтоб не додуматься посмотреть в экзамплы к книжке Linux-Device-Drivers-v2

Rzhepish ()
Ответ на: комментарий от Rzhepish

Смысл LMAO — «смеюсь жопой» ты походу не только смеешься но еще и думаешь жопой : ) прекращай писать шлак.

nisedeath ()
Ответ на: комментарий от anonymous

сынок, посмотри на мсвс 3.0 и и больше не говори глкпости.. Только умоляю, не говори, что её не используют, контора наша давеча её купила и водрузила куда надо.

GreyDoom ★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.