LINUX.ORG.RU

Gtk + Ecllipse Как ?


0

2

Решил тут научится программировать под Gtk+, естественно столкнулся с проблемой.
Как правильно настроить eclipse на работу с Gtk+?
Я сделал вот так:
# pkg-config --cflags gtk+-2.0

-pthread -I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/libpng14  
Далее добавил все пути в С/С++ General->Paths and Symbols->Includes->GNU C++
pkg-config --libs gtk+-2.0
-pthread -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lgio-2.0 -lpangoft2-1.0 -lgdk_pixbuf-2.0 -lpangocairo-1.0 -lcairo -lpango-1.0 -lfreetype -lfontconfig -lgobject-2.0 -lgmodule-2.0 -lgthread-2.0 -lrt -lglib-2.0
В C/C++ Build->Settings->Tool setings->GCC C++ Linker->Libraries->Libraries добавил gtk-x11-2.0
Попробовал добавить в код #include <gtk/gtk.h>, при нажатии <CTRL>+<BR> выводится огромный список функций, но нет самой нужной - gtk_init, видать что то не подцепилось.

★★★★★

>при нажатии <CTRL>+<BR> выводится огромный список функций

Каких, например?

но нет самой нужной - gtk_init

Из всех функций gtk эта - самая ненужная (для автокомптита). Пишется во всех программах одинаково в точке входа.

Я в своё время делал так же и через какое-то время всё работало :) А вообще, Eclipse зело тормозной при работе с Gtk. После 4-5 компиляций начинал тупить, так что на следующие можно было идти за чаем. И это для относительно небольшого проекта!

yoghurt ★★★★★ ()
Ответ на: комментарий от yoghurt

А вообще, Eclipse зело тормозной при работе с Gtk.

При работе с Qt он тоже очень тормозной.

Для разнообразия я бы посоветовал ТС попробовать QtCreator+CMake. Может понравится больше. Я вот создавал gtkmm проект в нем. Сильно конфигурить ничего надо, прописал правильно CMakeList.txt и QtCreator сам все увидел. В Эклипсе чтобы сделать тоже самое надо было прописать мильен инклюдов (или pkg-config, но тогда Эклипс не видит путей).

Компилировал проект вроде быстро (правда он был небольшим). Список автодополнения всплывал с секундной задержкой (когда в родном Qt показывал мгновенно).

Единственный недостаток - нужно ручками править файл CMakeList.txt, если хочешь добавить или переименовать файлы в дереве проекта.

pathfinder ★★★ ()
Ответ на: комментарий от pathfinder

Забыл сказать, автодополнение работало полностью корректно. Я не видел никаких глюков, которых в Эклипсе было полно.

pathfinder ★★★ ()

Ещё попробуй эклипс запускать из обычной сановской явы (не OpenJDK) и убери лишние анализаторы. Зайди в «Windows/Preferences». Там в «С\С++/Editor/Content Assist/Advanced» убери все галочки, кроме «Parsing-based Proporsals». Если там стояло много анализаторов, то после этого должно работать намного быстрее и меньше глючить.

pathfinder ★★★ ()
Ответ на: комментарий от pathfinder

QtCreator + Gtk? — ну и извращенец же вы, батенька. Как среда не айс, только из-за комплексности QtCreator и используют. Я использую NetBeans/ Code::Blocks с Gtk.

CrossFire ★★★★★ ()
Ответ на: комментарий от yoghurt

Какого то черта не цепляются includ-ы из gtk.h
Нашел что gtk_init() есть в gtkmain.h который в свою очередь включен в через include gtk.h и содержит эту gtk_init().
Как только подключаю gtkmain.h, eclipse сразу видит gtk_init? в чем проблема ?

deterok ★★★★★ ()

Ура!

Похоже проблема была в eclipse.
Как только скомпилировал с включенным заголовком gtkmain.h, а потом его убрал, все заработало

deterok ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.