LINUX.ORG.RU

Установка пакета ipk на Ubuntu


0

0

Подскажите, плз, как мне установить вот %D1%8D%D1%82%D0%BE%D1%82]http://ipkg.nslu2-linux.org/feeds/optware/syno1142mv6281/cross/unstable/mysql... ipk пакет на Ubuntu 9.10. dpkg не признает этот пакет за свой, естественно. Мне его нужно установить, чтоб кросс-компилировать приложения под NAS - этому приложению нужны заголовочные файлы mysql.


>Мне его нужно установить, чтоб кросс-компилировать приложения под NAS - этому приложению нужны заголовочные файлы mysql.

мм, а разве он будет чем-то отличаться от родных хидеров?

lazyklimm ★★★★★ ()
Ответ на: комментарий от lazyklimm

Не знаю. Я тож думал, что не будет. Но разработчик приложения, которое я пытаюсь скомпилировать, говорит, что нужны именно хидеры для arm.

LA_ ()
Ответ на: комментарий от vga

Что-то я не очень понимаю какие из тех шагов применимы к моему случаю. Не могли бы Вы это пояснить?

LA_ ()

Распакуйте в $HOME, потом пропишите где надо пути.

anon_666 ()
Ответ на: комментарий от LA_

Вот эти

* Add required packages to toolchain (-dev is for includes)

examples: opkg-target install libusb-1.0 opkg-target install libusb-1.0-dev opkg-target install gpsd opkg-target install gpsd-dev

vga ★★ ()
Ответ на: комментарий от LA_

Ну то есть opkg-target install mysql-dev и есть конечный ответ на вопрос. Но для того, чтобы получилось что-либо кросскомпилить, нужно выполнить все шаги, естественно.

vga ★★ ()
Ответ на: комментарий от LA_

>хидеры для arm.

внезапно, у убунты есть порт для arm с кошерными deb-ками

lazyklimm ★★★★★ ()
Ответ на: комментарий от lazyklimm

поясните, пожалуйста, ваш ответ. порт - в данном случае это другая версия убунты? если она для arm, то как её запустить на обычном ПК? или можно взять библиотеки от неё для компиляции? где их тогда можно взять и как установить под обычную убунту?

LA_ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.