LINUX.ORG.RU

Perl 5.34.0 модули

 


0

1

Установил на VPS с Ubuntu 20.04 Perl 5.34.0, пытаюсь запустить написанный на Perl форум, появилось следующее:

Software error:

Can’t locate Paths.pm in @INC (you may need to install the Paths module) (@INC contains: /opt/perl5/perls/perl5.34.0/lib/site_perl/5.34.0/x86_64-linux /opt/perl5/perls/perl5.34.0/lib/site_perl/5.34.0 /opt/perl5/perls/perl5.34.0/lib/5.34.0/x86_64-linux /opt/perl5/perls/perl5.34.0/lib/5.34.0)

где можно найти этот Paths.pm? Я перерыл весь metacpan.org, нашёл два модуля содержащие Paths.pm, это Log::Parallel::Paths и Labyrinth::Paths, я их установил, но это не помогло, пожалуйста помогите.

очевидно Paths.pm относитьтся к форуму

раньше perl автоматически добавлял в @INC текущую директорию

теперь руками, например через указание переменной окружения PERL5LIB или PERL_USE_UNSAFE_INC=1

perldoc perlrun

anonymous ()
Ответ на: комментарий от anonymous

Perl 5.34.0 устанавливал в ручную в папку opt, там же находятся ВСЕ его модули. Раньше стоял Perl 5.30.0, пытался ставить на него этот же форум и такой проблемы не возникало (там возникли проблемы с другим недостающим модулем которого нет в 5.30 но есть в 5.34, поэтому поставил 5.34).

Nordik2 ()

где можно найти этот Paths.pm?

попробуй
find / -name Paths.pm

pru-mike ★★ ()

Покажи строку, которая вызывает ошибку.

level1 ★★ ()
Для того чтобы оставить комментарий войдите или зарегистрируйтесь.