LINUX.ORG.RU

Нужна помощь с PKGBUILD

 , , ,


1

2

Из рача выпилили весь набор gstreamer0.10, я попробовал сделать импорт этих пакетов в AUR, но половина из них перестала собиратся, там такие странные ошибки, которые я не могу исправить сам, например в gstreamer0.10-good и gstreamer0.10-ffmpeg:

In file included from /usr/include/gstreamer-0.10/gst/gst.h:32:0,
from gstadder.h:26,
from gstadder.c:46:
/usr/include/gstreamer-0.10/gst/gstversion.h:48:27: Fehler: expected declaration specifiers or »...« before »(« token
#define GST_VERSION_MAJOR (0)
^
gstadder.c:1329:21: Anmerkung: bei Substitution des Makros »GST_VERSION_MAJOR«
GST_PLUGIN_DEFINE2 (GST_VERSION_MAJOR,
^~~~~~~~~~~~~~~~~
В gstreamer0.10-ugly
Error:

gstasf.c:35:1: warning: ‘plugin_init’ defined but not used [-Wunused-function]
plugin_init (GstPlugin * plugin)
^~~~~~~~~~~
make[3]: *** [Makefile:612: libgstasf_la-gstasf.lo] Error 1
make[3]: Leaving directory '/tmp/yaourt-tmp-cedric/aur-gstreamer0.10-ugly-plugins/src/gst-plugins-ugly/gst/asfdemux'

вчера получил аналогичный ерор на gstreamer0.10-ffmpeg. Как потом оказалось этот пакет у меня вообще не использовался. Видимо какая-то зависимость раньше была, хотя я удаляю через yaourt -Rs А так в системе используются gst-plugins-*
Попробуй, может и у тебе уже тоже не нужни эти либы

kiotoze ★★★★ ()
Ответ на: комментарий от kiotoze

Некоторые пакеты не хотят ставится, потому что явно указывают в зависимостях именно один из gstreamer0.10*, я их именно из-за этого схоронил в AUR.
Эта ошибка у тебя как раз и возникла потому что в раче их долго не обновляли, а потом вообще выкинули, так пакеты сейчас вообще не собираются, хотя они идентичны тем, что были в официальной репе.

yurikoles ★★★ ()
Последнее исправление: yurikoles (всего исправлений: 5)

Это что, крыса без регулятора громкости будет? Для пульсы же он кривой.

Deleted ()
Ответ на: комментарий от vs220

Во это только те, что требуютобычный базовый пакет gstreamer0.10. У других пакетов тоже есть аналогичные списки. Инфа с АУРа.

aftershotpro2
aftershotpro3
anoise
anoise-community-extension1
anoise-community-extension2
anoise-community-extension3
banshee-community-extensions
crossover (requires gstreamer0.10) (optional, i686)
dike
enigma2
eradio-git
firefox-eme-free-bin (requires gstreamer0.10) (optional)
firefox-esr-bin (requires gstreamer0.10) (optional)
firestorm-bin (requires gstreamer0.10) (optional)
floola (requires gstreamer0.10) (optional)
gamine
genymotion
gnome-gmail-notifier
indicator-remindor
ivideon-server-headless
knowthelist-git
kokua-opensim (requires gstreamer0.10) (optional)
kokua-secondlife (requires gstreamer0.10) (optional)
lib32-gstreamer0.10
libnice-git (optional)
libnice-git (make)
minbar
miro
miro
monkey-bubble
moodbar
netsurf-git (requires gstreamer0.10) (optional)
palemoon-git (make)
parrillada
perl-gstreamer
rk-desktop-gnome
rsb-gstreamer-stable-git
singularityviewer (requires gstreamer0.10) (optional)
singularityviewer-alpha (requires gstreamer0.10) (optional)
singularityviewer-test (requires gstreamer0.10) (optional)
singularityviewer32 (requires gstreamer0.10) (optional)
spectrum3d
vitunes-git (requires gstreamer0.10) (optional)
wahcade (requires gstreamer0.10) (optional)
webcamstudio-git
wickr-bin
yage

yurikoles ★★★ ()
Последнее исправление: yurikoles (всего исправлений: 2)

Выкинь каку. Всё без них работает.

post-factum ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.