LINUX.ORG.RU

Ошибка в QtCreator при сборке

 


0

1

При попытке сборки проекта в QtCreator вываливается ошибка ":-1: error: The Qt version is invalid: Qt version is not properly installed, please run make install". В гугле мне посоветовали поставить девелоперские библиотеки qt4, но они мне не очень-то нужны (т.е. я не собираюсь писать приложения с Qt), можно ли как-то запустить сборку без них?

т.е. я не собираюсь писать приложения с Qt

Вы делаете проект в креаторе, но проект не Qt? Что используете cmake или qmake?

no-such-file ★★★★★ ()
Последнее исправление: no-such-file (всего исправлений: 1)
Ответ на: комментарий от kostik1

Какой у тебя дистрибутив, я тебе постараюсь написать полные команды для сборки.

А тьфу, не так прочитал вопрос. Нужно в настройках qtcreator в kits указать qmake. Для этого установить все qt dev tools твоего дистрибутива.

А если не хочешь совсем qt ставить, тогда вот http://shinnok.com/rants/2011/07/18/using-the-qt-creator-ide-with-non-qt-proj... там в настройках твоего проекта нужно изменить последовательность команд нужными тебе.

bhfq ★★★★★ ()
Последнее исправление: bhfq (всего исправлений: 2)
Ответ на: комментарий от kostik1

я так понимаю, мне нужен cmake?

Было бы логично, но вообще, не обязательно.

В .pro файле такие строчки-то есть?

CONFIG += console
CONFIG -= app_bundle
CONFIG -= qt
no-such-file ★★★★★ ()
Ответ на: комментарий от no-such-file

Да я уже в общем-то cmake начал использовать. Но если в .pro добавить эти строчки, ошибка не пропадает.

kostik1 ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.