LINUX.ORG.RU

Обновился до Ubuntu 13.10. Странные глюки с иксами.


0

1

13.10. С nvidia-блобом вообще не взлетает. Выдаёт ошибку загрузки glamoregl.so

С nouveau первый раз после загрузки иксы не стартуют вообще. Вываливается на экран окошко с «The system is running in low-graphics mode», в логах пусто.

Если переключиться в консоль и сделать «start lightdm», то запускается всё нормально с поправкой на то, что при старте 15 секунд тормозит. В syslog потом появляется:

Oct 29 11:46:25 z9 kernel: [  295.142711] RPC: AUTH_GSS upcall timed out.
Oct 29 11:46:25 z9 kernel: [  295.142711] Please check user daemon is running.

И ниже до кучи:

Oct 29 11:46:26 z9 kernel: [  296.389435] nouveau E[   PFIFO][0000:01:00.0] DMA_PUSHER - ch 2 [Xorg[16472]] get 0x0020037900 put 0x002003b168 ib_get 0x00000008 ib_put 0x00000053 state 0x80004861 (err: INVALID_CMD) push 0x00406040
Oct 29 11:46:26 z9 kernel: [  296.479569] nouveau E[   PFIFO][0000:01:00.0] DMA_PUSHER - ch 2 [Xorg[16472]] get 0x002002fa6c put 0x0020036fcc ib_get 0x000000fa ib_put 0x00000101 state 0x80004861 (err: INVALID_CMD) push 0x00406040
Oct 29 11:46:26 z9 kernel: [  296.970222] nouveau E[   PFIFO][0000:01:00.0] DMA_PUSHER - ch 2 [Xorg[16472]] get 0x0020030eb8 put 0x0020035610 ib_get 0x000002f8 ib_put 0x00000311 state 0x8000e684 (err: INVALID_CMD) push 0x00406040
Oct 29 11:46:26 z9 kernel: [  296.980675] nouveau E[  PGRAPH][0000:01:00.0] DATA_ERROR BEGIN_END_ACTIVE
Oct 29 11:46:26 z9 kernel: [  296.980678] nouveau E[  PGRAPH][0000:01:00.0]  DATA_ERROR
Oct 29 11:46:26 z9 kernel: [  296.980680] nouveau E[  PGRAPH][0000:01:00.0] ch 2 [0x001fae9000 Xorg[16472]] subc 7 class 0x8297 mthd 0x1360 data 0x00000001
Oct 29 11:46:26 z9 kernel: [  296.980693] nouveau E[  PGRAPH][0000:01:00.0] DATA_ERROR BEGIN_END_ACTIVE
Oct 29 11:46:26 z9 kernel: [  296.980695] nouveau E[  PGRAPH][0000:01:00.0]  DATA_ERROR
Oct 29 11:46:26 z9 kernel: [  296.980698] nouveau E[  PGRAPH][0000:01:00.0] ch 2 [0x001fae9000 Xorg[16472]] subc 7 class 0x8297 mthd 0x1340 data 0x00008006
Oct 29 11:46:26 z9 kernel: [  296.980710] nouveau E[  PGRAPH][0000:01:00.0] DATA_ERROR BEGIN_END_ACTIVE
Oct 29 11:46:26 z9 kernel: [  296.980711] nouveau E[  PGRAPH][0000:01:00.0]  DATA_ERROR
Oct 29 11:46:26 z9 kernel: [  296.980713] nouveau E[  PGRAPH][0000:01:00.0] ch 2 [0x001fae9000 Xorg[16472]] subc 7 class 0x8297 mthd 0x1344 data 0x00004001
Oct 29 11:46:26 z9 kernel: [  296.980726] nouveau E[  PGRAPH][0000:01:00.0] DATA_ERROR BEGIN_END_ACTIVE
Oct 29 11:46:26 z9 kernel: [  296.980728] nouveau E[  PGRAPH][0000:01:00.0]  DATA_ERROR
Oct 29 11:46:26 z9 kernel: [  296.980730] nouveau E[  PGRAPH][0000:01:00.0] ch 2 [0x001fae9000 Xorg[16472]] subc 7 class 0x8297 mthd 0x1348 data 0x00004001
Oct 29 11:46:26 z9 kernel: [  296.980741] nouveau E[  PGRAPH][0000:01:00.0] DATA_ERROR BEGIN_END_ACTIVE
Oct 29 11:46:26 z9 kernel: [  296.980742] nouveau E[  PGRAPH][0000:01:00.0]  DATA_ERROR
Oct 29 11:46:26 z9 kernel: [  296.980743] nouveau E[  PGRAPH][0000:01:00.0] ch 2 [0x001fae9000 Xorg[16472]] subc 7 class 0x8297 mthd 0x134c data 0x00008006
Oct 29 11:46:26 z9 kernel: [  296.980753] nouveau E[  PGRAPH][0000:01:00.0] DATA_ERROR BEGIN_END_ACTIVE
Oct 29 11:46:26 z9 kernel: [  296.980754] nouveau E[  PGRAPH][0000:01:00.0]  DATA_ERROR
Oct 29 11:46:26 z9 kernel: [  296.980755] nouveau E[  PGRAPH][0000:01:00.0] ch 2 [0x001fae9000 Xorg[16472]] subc 7 class 0x8297 mthd 0x1350 data 0x00004001
Oct 29 11:46:26 z9 kernel: [  296.980764] nouveau E[  PGRAPH][0000:01:00.0] DATA_ERROR BEGIN_END_ACTIVE
Oct 29 11:46:26 z9 kernel: [  296.980766] nouveau E[  PGRAPH][0000:01:00.0]  DATA_ERROR
Oct 29 11:46:26 z9 kernel: [  296.980767] nouveau E[  PGRAPH][0000:01:00.0] ch 2 [0x001fae9000 Xorg[16472]] subc 7 class 0x8297 mthd 0x1358 data 0x00004001
Oct 29 11:46:39 z9 blueman-mechanism: Exiting 

Через некоторое время, уже во время нормальной с виду работы в syslog сыплется тот же самый поток сообщений о timeout AUTH_GSS.

Куда копать?

★★★★★

Судя по гуглу, «RPC: AUTH_GSS upcall timed out» — это от NFS. Но NFS работает нормально. Вероятно, с проблемой иксов не связано?

KRoN73 ★★★★★ ()
Ответ на: комментарий от inn

CTRL+F по 0x001fae9000

Тонна дампов. Но что это значит? И проблема, вроде, январская, а в 13.04 всё было ок.

KRoN73 ★★★★★ ()

Выдаёт ошибку загрузки glamoregl.so

Блобу не нужно glamor, насколько я понимаю. Даже вредно. Попробуй закомментировать все упоминания в xorg.conf и xorg.conf.d/

i-rinat ★★★★★ ()
Ответ на: комментарий от i-rinat

Попробуй закомментировать все упоминания в xorg.conf и xorg.conf.d/

У меня вообще нет xorg.conf, уже много лет, как чистый автодетект :)

KRoN73 ★★★★★ ()
Ответ на: комментарий от KRoN73

У меня вообще нет xorg.conf, уже много лет, как чистый автодетект :)

Блоб nvidia умеет автоопределение? (Проверить не на чем. У AMD не работает).

i-rinat ★★★★★ ()
Ответ на: комментарий от i-rinat

Блоб nvidia умеет автоопределение?

Много лет :) По крайней мере на Ubuntu. На Gentoo у меня древний xorg.conf ещё со второй половины 2000-х.

Ubuntu на nVidia у меня на автоопределении с момента, как я её стал плотно использовать, а это где-то с ~2011-го.

KRoN73 ★★★★★ ()

как же вы надоели вечно у вас все ломается может просто использовать нормальную ос например freebsd на худой конец windows 7 мучаете сами себя как при царском режиме

anonymous ()
Ответ на: комментарий от KRoN73

Но вот точно чего не умеет блоб nvidia — так это EGL без иксов. Потому и glamoregl не работает. Надо его как-нибудь отвадить.

https://bugs.launchpad.net/ubuntu/ source/glamor-egl/ bug/1232658

i-rinat ★★★★★ ()
Последнее исправление: i-rinat (всего исправлений: 1)

Обновился до Ubuntu 13.10.

Странные глюки

добро пожаловать в клуб!

reprimand ★★★★★ ()
Ответ на: комментарий от i-rinat

Но вот точно чего не умеет блоб nvidia

Да чёрт с ним, с блобом, для начала бы под nouveau научиться стартовать без тормозов и с первого раза. Явно же что-то в системных процессах не то. Потом, когда уже запустилось, сейчас nouveau вполне сносно работает.

KRoN73 ★★★★★ ()

Ага. glamoregl починили. Пришёл апдейт.

nouveau я поспешил назвать безглючным. Через 10..40 минут работы иксы виснут так, что мышка бегает, но в консоль не переключиться. Спасает только Alt-SysRq.

Блоб завёлся, но баги те же самые. Долгая, 15-20 секунд пауза на старте, с вероятностью 50/50 (сработает или нет), или заведётся, или выкинет «The system is running in low-graphics mode». При чём в отличие от nouveau в этом случае в консоль не переключиться, появляется чёрный экран, мигающий курсор и тишина. Опять Alt-SysRq. Если же стартует, то работает с виду нормально.

KRoN73 ★★★★★ ()

Пока разбираюсь с сабжем, при очередном зависе залез, чтобы забрать логи в резервную Ubuntu 11.10. Блин, сказка, а не система. Всё пашет, всё без глюков, всё быстро, красиво…

KRoN73 ★★★★★ ()
Ответ на: комментарий от alexeiz

А лучше до версии, когда unity еще не было.

Так там с Gnome Fallback ещё совершенно нормальный :)

Ну так это... обновись до Ubuntu 11.10

Кучи софта уже нет.

KRoN73 ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.