LINUX.ORG.RU

GRUB и UEFI

 , ,


0

1

Доброго времени суток. Такое дело: Имеется дуалбут Windows и Arch Linux, также UEFI-железо. При установке Linux, я положил GRUB в раздел загрузки UEFI, также установил os-prober, и создал конфиг граба(grub-mkconfig). При создании конфига, граб нашел образы Linux, а вот винду не нашел, т.к. её загрузчик в UEFI разделе отсутствовал. Можно ли как-то вручную засунуть какие-нибудь файлы загрузчика Windows8 в UEFI раздел, а потом запустить grub-mkconfig?

Если Windows установлен в Legacy-режиме, то нет. Если Windows установлен в UEFI-режиме, то надо добавить путь к UEFI-загрузчику Windows в конфиг граба.

Andrew ★★★ ()
Ответ на: комментарий от Andrew

Линух и Винда оба в uefi-режиме. А как называется файл загрузчика, не подскажите? И как его добавить, конфиг вроде как командой генерируется.

realZiel ()
Ответ на: комментарий от Andrew

Блин, почти сработало, но по умолчанию грузится всё равно винда. Я имею ввиду то, что в меню граб появился шиндовс, но что бы загрузить граб, нужно при загрузке жать F9 и выбирать его, иначе грузится виндошный загрузчик. Можно как-то поменять порядок?

realZiel ()
Ответ на: комментарий от realZiel

Можно. В настройке бут меню или бивиса, или через efibootmgt. Но зачем тебе граб? Лучше использовать напрямую бут менеджер бивиса

vasily_pupkin ★★★★★ ()
Ответ на: комментарий от vasily_pupkin

Да в том-то и дело, что граба в бут меню нет. Есть просто выбор источника загрузки по нажатии F9(там порядок не изменяется, ноут hp envy dv6), а вот в самом меню биоса есть только os manager, это загрузчик винды. А можно поподробнее по efibootmgr?

realZiel ()
Ответ на: комментарий от realZiel

Запусти efibootmgr с правами суперльзователя, появится список и возле каждого пункта порядочный номер, среди них должен быть «grub» или «Arch Linux». Чтобы сделать grub дефолтным загрузчиком выполни sudo efibootmgr -o NNNN, NNNN, NNNN, NNNN (NNNN - это порядковый номер пункта загрузки, соответственно первым напиши порядковый номер граба, а потом можно все остальные)

Andrew ★★★ ()
Последнее исправление: Andrew (всего исправлений: 2)
Ответ на: комментарий от Andrew

Команду выполнил, вроде бы граб встал на первое место, но после перезагрузки опять запустился шиндовс, оказывается весь порядок загрузчиков опять стал прежним :(

realZiel ()
Ответ на: комментарий от realZiel

Можно также попробовать снести все пункты загрузки к чертям, кроме граба: efibootmgr -B NNNN

Andrew ★★★ ()
Последнее исправление: Andrew (всего исправлений: 1)
Ответ на: комментарий от Andrew

Получается :

efibootmgr -B код удаляемого загрузчика
На это выводит:
You must specify a boot entry to delete (see the -b option)

realZiel ()
Ответ на: комментарий от Andrew

Удалил раздел, первый раз обрадовался - грузился граб, на вторую перезагрузку, загрузчик 8 внезапно ожил, и всё началось снова. Может знаете другие способы?

realZiel ()
Ответ на: комментарий от realZiel

Ну, попробуй полистать мануал по твоей мат.плате, может быть по какой-то клавише таки настраивается порядок загрузки в биосе. Ну или удаляй 8ку совсем, тогда гарантировано будет грузиться grub :D

Andrew ★★★ ()
Ответ на: комментарий от realZiel

Да, кстати, я слышал что можно добавить линукс пунктом в загрузчик винды, но я не знаю можно ли это проделать с UEFI-загрузчиками.

Andrew ★★★ ()
Ответ на: комментарий от realZiel

Ладно, буду юзать бут меню биоса, только придется каждый раз жать f9, ну не так уж страшно.

realZiel ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.