LINUX.ORG.RU

Плохой звук в наушниках

 , , ,


1

2

Сабж.

Есть ноутбук lenovo g480 c fedora 18 и

00:1b.0 Audio device: Intel Corporation 7 Series/C210 Series Chipset Family High Definition Audio Controller (rev 04)
	Subsystem: Lenovo Device 3977
	Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
	Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 0, Cache Line Size: 64 bytes
	Interrupt: pin A routed to IRQ 45
	Region 0: Memory at db610000 (64-bit, non-prefetchable) [size=16K]
	Capabilities: [50] Power Management version 2
		Flags: PMEClk- DSI- D1- D2- AuxCurrent=55mA PME(D0+,D1-,D2-,D3hot+,D3cold+)
		Status: D0 NoSoftRst- PME-Enable- DSel=0 DScale=0 PME-
	Capabilities: [60] MSI: Enable+ Count=1/1 Maskable- 64bit+
		Address: 00000000fee0f00c  Data: 4122
	Capabilities: [70] Express (v1) Root Complex Integrated Endpoint, MSI 00
		DevCap:	MaxPayload 128 bytes, PhantFunc 0, Latency L0s <64ns, L1 <1us
			ExtTag- RBE- FLReset+
		DevCtl:	Report errors: Correctable- Non-Fatal- Fatal- Unsupported-
			RlxdOrd- ExtTag- PhantFunc- AuxPwr- NoSnoop-
			MaxPayload 128 bytes, MaxReadReq 128 bytes
		DevSta:	CorrErr- UncorrErr- FatalErr- UnsuppReq- AuxPwr+ TransPend-
		LnkCap:	Port #0, Speed unknown, Width x0, ASPM unknown, Latency L0 <64ns, L1 <1us
			ClockPM- Surprise- LLActRep- BwNot-
		LnkCtl:	ASPM Disabled; Disabled- Retrain- CommClk-
			ExtSynch- ClockPM- AutWidDis- BWInt- AutBWInt-
		LnkSta:	Speed unknown, Width x0, TrErr- Train- SlotClk- DLActive- BWMgmt- ABWMgmt-
	Capabilities: [100 v1] Virtual Channel
		Caps:	LPEVC=0 RefClk=100ns PATEntryBits=1
		Arb:	Fixed- WRR32- WRR64- WRR128-
		Ctrl:	ArbSelect=Fixed
		Status:	InProgress-
		VC0:	Caps:	PATOffset=00 MaxTimeSlots=1 RejSnoopTrans-
			Arb:	Fixed- WRR32- WRR64- WRR128- TWRR128- WRR256-
			Ctrl:	Enable+ ID=0 ArbSelect=Fixed TC/VC=01
			Status:	NegoPending- InProgress-
		VC1:	Caps:	PATOffset=00 MaxTimeSlots=1 RejSnoopTrans-
			Arb:	Fixed- WRR32- WRR64- WRR128- TWRR128- WRR256-
			Ctrl:	Enable+ ID=1 ArbSelect=Fixed TC/VC=22
			Status:	NegoPending- InProgress-
	Capabilities: [130 v1] Root Complex Link
		Desc:	PortNumber=0f ComponentID=00 EltType=Config
		Link0:	Desc:	TargetPort=00 TargetComponent=00 AssocRCRB- LinkType=MemMapped LinkValid+
			Addr:	00000000fed1c000
	Kernel driver in use: snd_hda_intel
С динамиков звук отличный, претензий нет. Но вот когда вставляю наушники (хз какие, были в комплекте с телефоном Xperia Active), саму музыку или шум слышно более-менее, как будто в каком-то камерном зале, что-ли. А слова, вообще не разобрать. В то же время если по usb подключить no-name звуковую, купленную на ближайшем рынке за 15 юаней, а в нее эти наушники, то звук просто отличный! Пробовал настраивать pulseaudio/alsa, все без толку. Оно либо вообще не работает тогда, либо ничего не меняется. В чем может быть проблема ? Проверить на оффтопике возможности нету, ибо установлен онтопик :)

★★★★★

саму музыку или шум слышно более-менее, как будто в каком-то камерном зале, что-ли. А слова, вообще не разобрать.

два канала накладываются в противофазе друг на друга, возможно у у самого ноута монофонический выход, возможно наушники к гнезду неплотно прилегают, возможно с моделями для модуля ядра snd_hda_audio нужно поколдовать

lazyklimm ★★★★★ ()
Ответ на: комментарий от lazyklimm

возможно у у самого ноута монофонический выход,

А как это проверить ? Вход совмещенный, т.е. и для наушников,и для микрофона. Сами же наушники тоже с микрофоном.
Наушники прилегают хорошо :)

joy4eg ★★★★★ ()
Ответ на: комментарий от joy4eg

два канала накладываются в противофазе друг на друга

Это точно. Просто в разъеме на ноуте распайка не такая как на Xperia Active.

MaZy ★★★★★ ()
Ответ на: комментарий от MaZy

Хм... подключил другие наушники, с виду самые обычные. Звук действительно пришел в норму.

joy4eg ★★★★★ ()
Ответ на: комментарий от lazyklimm

не коротит, а неправильно распаян. обычная ситуация для телефонных ушей. переходник стоит 2 юаня

anonymous ()
9 сентября 2013 г.
Ответ на: комментарий от lazyklimm

Заглушаем одну линию и звук начинает играть как надо

zcasper ()
15 января 2015 г.

Столкнулся с такой же проблемой, mint 16, asrock с ALC662, звук из наушников - низы срезаны, голос вырезается почти целиком, общий звук будто в туалете сижу. В alsa-mixer поставил на канале Front баланс влево - звук действительно стал лучше, на ютубе ролики стало возможно слушать, но надо сделать нормально. Видимо, что-то с snd_hda_audio делать.

Гарнитура в переднем порту, но нормальная - 2 разъёма, классический вход, классический выход. В винде работала нормально.

dragonflybsd ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.