LINUX.ORG.RU

Локализация KDE 4.9


0

1
midori@linux:~$ sudo aptitude install language-pack-kde-ru kde-l10n-ru language-pack-kde-ru-base 
Следующие НОВЫЕ пакеты будут установлены:        
  kde-l10n-ru language-pack-kde-ru language-pack-kde-ru-base{b} 
0 пакетов обновлено, 3 установлено новых, 0 пакетов отмечено для удаления, и 1 пакетов не обновлено.
Необходимо получить 25,6 MБ архивов. После распаковки 50,2 MБ будет занято.
Следующие пакеты имеют неудовлетворённые зависимости:
 language-pack-kde-ru-base : Зависит: language-pack-kde-ru (>= 1:12.04+20120801) но будет установлен 1:12.04+20120417.
                             Конфликтует: language-pack-kde-ru (< 1:12.04+20120801) но будет установлен 1:12.04+20120417.
Следующие действия разрешат зависимости:

     Оставить для следующих пакетов их текущие версии:
1)     kde-l10n-ru [Не установлен]                    
2)     language-pack-kde-ru [Не установлен]           
3)     language-pack-kde-ru-base [Не установлен]      



Принять данное решение? [Y/n/q/?] 
Ни одного пакета не будет установлено, обновлено или удалено.
0 пакетов обновлено, 0 установлено новых, 0 пакетов отмечено для удаления, и 1 пакетов не обновлено.
Необходимо получить 0 Б архивов. После распаковки 0 Б будет занято.
                                                 
midori@linux:~$ 
midori@linux:~$ sudo apt-get install language-pack-kde-ru kde-l10n-ru language-pack-kde-ru-base 
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Некоторые пакеты невозможно установить. Возможно, вы просите невозможного,
или же используете нестабильную версию дистрибутива, где запрошенные вами
пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, поможет вам:

Пакеты, имеющие неудовлетворённые зависимости:
 language-pack-kde-ru-base : Зависит: language-pack-kde-ru (>= 1:12.04+20120801) но 1:12.04+20120417 будет установлен
                             Конфликтует: language-pack-kde-ru (< 1:12.04+20120801) но 1:12.04+20120417 будет установлен
E: Невозможно исправить ошибки, у вас отложены (held) битые пакеты.
midori@linux:~$ 

Что бы это могло быть?

★★★★★

у меня похожая ситуация была при установке Open Office на федору

swlabr ()
Ответ на: комментарий от om-nom-nimouse

Сегодня вот что aptitude пишет:

No packages will be installed, upgraded, or removed.
0 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B of archives. After unpacking 0 B will be used.
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
        LANGUAGE = "",
        LC_ALL = (unset),
        LANG = "ru_RU.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
Чую дело во мне.

cinyflo ★★★★★ ()

У меня при попытке поставить русскую локаль на 4.9 выдаёт ошибку. Забил, поставил Xfce. На VM поставил mini.iso, на него накатил уже вышедший к тому времени 4.9.2, решил порешать проблемку таким образом. Но проблемки не обнаружилось, всё встало с ходу. Обрадовался, решил снова поставить на десктоп. И что вы думаете, та же проблема при установке локализации! Куда копать?

cinyflo ★★★★★ ()
Ответ на: комментарий от cinyflo

У меня при попытке поставить русскую локаль на 4.9 выдаёт ошибку.

Поставь нормальный вменяемый дистрибутив. Например Арч, с русификацией кед там никаких проблем.

И что вы думаете, та же проблема при установке локализации! Куда копать?

Что-то явно поломано в системе.

neocrust ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.