LINUX.ORG.RU

Как узнать, почему иксы грузят проц под 99.9% ?

 


0

1
$ top                                                                                                                 
top - 22:54:37 up  1:47,  3 users,  load average: 1.12, 1.15, 1.14
Tasks: 204 total,   3 running, 201 sleeping,   0 stopped,   0 zombie
Cpu(s):  8.6%us, 18.0%sy,  0.0%ni, 72.1%id,  1.2%wa,  0.1%hi,  0.0%si,  0.0%st
Mem:   3919552k total,  1581456k used,  2338096k free,    69856k buffers
Swap:  6127608k total,        0k used,  6127608k free,   370708k cached

  PID USER      PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+  COMMAND
 1771 root      20   0  334m 103m  74m R 99.8  2.7 105:47.12 X
 2076 elf       20   0  881m  21m  14m S  2.0  0.6   2:08.72 knotify4
 2547 elf       20   0  481m  47m  20m S  1.3  1.3   1:50.02 chrome
 2498 elf       20   0 1080m 112m  19m S  1.0  2.9   0:48.80 chrome
 2116 elf        9 -11  505m 7808 6384 S  0.7  0.2   1:39.34 pulseaudio

Это при том, что кроме хрома, а в нем ЛОРа и гмыла больше ничего не запущено. Перезапуск иксов помогает, после чего процессора кушает в пределах 1-6%.

Куда копать?

OS CentOS 6 Дров на видео - проприетарный fgrlx.

★★★★★

Перезапуск иксов помогает, после чего процессора кушает в пределах 1-6%.


Гм, а за какое время опять начинается 99?

takino ★★★★★ ()
Ответ на: комментарий от takino

Не понятно за какое. Один раз присмотрел загрузку под 99%, когда просто по инету серфил. Кильнул иксы, все нормализировалось. Другой раз просто отошел на часок от компутера, оставил его рабочим (браузер запущен небыл), как пришел - снова иксы грузят 99%. DE - кеда, всякие непомуки и аконади отключены.

Siado ★★★★★ ()
Ответ на: комментарий от Siado

попробуй посмотреть htop'ом, он более подробно деревья процессов показывает.

во время загрузки киляй не иксы, а запущенный софт. Если после килла браузера все нормальизуется - разбираться надо будет с браузером, а не с over9000 приложений в системе.

я основные траблы замечаю: 1. за флешом, он тупо сбоит иногда. 2. по памяти при использовании Java приложений. К примеру VirtualBox + Eclipse могут без проблем оставить без памяти систему с 4Гб ОЗУ.

BaBL ★★★★★ ()
Ответ на: комментарий от Siado

Я не говорю юзать постоянно. На время поставить, и попробовать воспроизвести проблему.

vova7890 ★★★ ()
Ответ на: комментарий от Siado

Хм. >knotify4

Это KDE?

Тогда у меня было тоже самое с ATI.
Единственный вариант решения - либо прибить иксы, либо перезапустить kwin. Баг я тогда не отправлял в багтрекер.

takino ★★★★★ ()

Прибить knotify4, и всего делов.

anonymous ()

Изучать systemtap вестимо..

anonymous ()

Дров на видео - проприетарный fgrlx.

</thread>

anonymous ()
Ответ на: комментарий от cr0x

Причина - убогое KDE, а не fgrlx. У меня такое тоже было на Archlinuxe! с kde4, тоже грузил проц идиотский knotify4. Снес Arch, поставил Debian gnome2+compiz, сверху накинул блоб и проблем не стало сразу, причем блоб ставил той же версии что и в арче. Вот такие вот дела, избавился сразу от двух велосипедов - арч и кде.

Xe0N ()

У меня похожие симпотмы были при анимации клизмоидов, особенно при анимации иконок в системном трее.

Jurik_Phys ★★★★★ ()

Для решения проблемы во-первых нужно:

# killall knotify4

во-вторых:

kdesu systemsettings → Внешний вид → Тонкая настройка → Графические эффекты → Низкое разрешение экрана и небольшая нагрузка на процессор.

или в ~/.kde/share/config/kdeglobals изменить:

[KDE-Global GUI Settings]

GraphicEffectsLevel=7

на

[KDE-Global GUI Settings]

GraphicEffectsLevel=0

truelock ()
Ответ на: комментарий от Siado

Ну, получилось неочевидное, но менее «выпиливательное» решение, которое родилось в рамках настройки декораций окон QtCurve.

truelock ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.