LINUX.ORG.RU

[gentoo] не собирается awesome


0

1
[ 23%] Generating manpages/de/man1/awesome-client.1.gz
Note: Writing awesomerc.5
[ 23%] Generating manpages/de/man5/awesomerc.5.gz
[ 62%] Built target man
make: *** [all] Error 2
emake failed
 * ERROR: x11-wm/awesome-3.4.8 failed (compile phase):
 *   Make failed!
 * 
 * Call stack:
 *     ebuild.sh, line   85:  Called src_compile
 *   environment, line 2538:  Called cmake-utils_src_make 'all'
 *   environment, line  653:  Called die
 * The specific snippet of code:
 *           emake "$@" || die "Make failed!";
 * 
 * If you need support, post the output of 'emerge --info =x11-wm/awesome-3.4.8',
 * the complete build log and the output of 'emerge -pqv =x11-wm/awesome-3.4.8'.
 * The complete build log is located at '/var/tmp/portage/x11-wm/awesome-3.4.8/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/x11-wm/awesome-3.4.8/temp/environment'.
 * S: '/var/tmp/portage/x11-wm/awesome-3.4.8/work/awesome-3.4.8'

emerge --info http://pastebin.com/Wr5upDJr
build.log http://pastebin.com/hqByXXSa

Пробовал даунгрейдить cmake, пробовал собрать все версии awesome, которые нашел в репах - результат один и сборка фейлится на одном и том же месте.

Есть идеи у кого-нибудь?

UPD: РЕШЕНО!

Тупо сделал eix-sync, поставил на сборку снова, и приехала новая версия lua, с которой все нормально собралось.

★★★★★

Ответ на: комментарий от havelite

битый ебилд? скачай новый

Там их 4ре штуки, в официальных то репах :)
Каждая фейлит на этом месте.

tazhate ★★★★★ ()
Ответ на: комментарий от tazhate

Подозрительно, но никакой новой информации.
Попробуйте руками собрать, может какой-то библиотеки не хватает в системе, наличие которой не проверяется в ./configure

fads ★★ ()
Ответ на: комментарий от fads

Подозрительно, но никакой новой информации.

Глянь вверх. Решено, спасибо :)

tazhate ★★★★★ ()
Ответ на: комментарий от fads

fads

Подозрительно, но никакой новой информации.

да ну?

build.log

/var/tmp/portage/x11-wm/awesome-3.4.8/work/awesome-3.4.8/common/luaclass.h:70:59: error: array type has incomplete element type

вообще вся это фигня из-за несовместимости lua ABI в последней версии. https://bugs.gentoo.org/show_bug.cgi?id=406985

do0dlez ★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.