LINUX.ORG.RU

[opensuse] Дистрибутив, собранный через SuseStudio зависает на запуске KDM.


0

1

Сабж. Все проходит нормально до момента запуска KDM. Зависает на одной из последних стадий, как показывает полоса загрузки. /etc/init.d/xdm restart не помогает. ctrl+alt+backspace+релогин- тоже. Что можно сделать?


Да. Я добавил gdm только ради обхода этой проблемы, но это крайне тупое решение.

anonymous ()
Ответ на: комментарий от anonymous

То есть, такая проблема действительно имеет место быть не только у меня?

Vekt ()

попробуй xdm, может для запуска КДМ чего то не хватает в ситеме, либы там какой или еще чего! а то может и кеды не загрузятся!

ipwww ★★ ()

У меня на слаке такое было, пока не потер конфиги от более новой версии кед.

f1xmAn ★★★★★ ()

Что можно сделать?

Для начала почитать ~/.xsession-errors и /var/log/Xorg.0.log

P.S. С таким уровнем знаний на неофициальные сборки, и какие-то эксперименты не следует даже и дёргаться. Овладейте для начала базовыми навыками, лучше всего на каком-нибудь Slackware-based дистрибутиве, или на крайний случай подойдёт ArchLInux.

anonymous ()
Ответ на: комментарий от kitar

Настройки в /etc/inittab и /etc/slim.conf, попробуй если сможешь залогиниться, а потом разбирайся с KDM.

kitar ★★★★★ ()
Ответ на: комментарий от kitar

Мб и есть, но не слышал о такой. Ща тестану, сек

Vekt ()
Ответ на: комментарий от kitar

по-умолчанию он то и стоит, если я правильно понял суть. Там и xdm и kdm есть, запускается dm либо через /etc/init.d/xdm start либо через kdm ttyX

Vekt ()
Ответ на: комментарий от Vekt

Сделай так, чтобы он не запускался при загрузке или удали пакет с ntp.

После зависона если дать из текстовой консоли init 3, потом init 5 - запускается?

Nxx ★★★★★ ()
Ответ на: комментарий от Nxx

ntp нету. если дать init 3- зависает на попытке вырубить kdm. если дать ядру параметр init 3 а потом после запуска сделать init 5- запуск KDE все так же зависает.

Vekt ()
Ответ на: комментарий от Nxx

Может быть так, что системе что-то еще необходимо для запуска? я помню, в Арче у меня Кеды без ttf-dejavu не взлетали.

Vekt ()
Ответ на: комментарий от anonymous

в 1 файле жалобы на недоступность неких эффектов, потом какие-то траблы непомука, потом QDbusObjectPath: Invalid Path : «„„“ два раза, потом Object::connect : No such signal QDbusAbstractInterface::Changed() потом kdebuildsyscoca4 running во 2 файле FBDEV(0): FBLIOBLANK: Invalid Argument Раз пять

Vekt ()

Путем долгих подборов выяснилось, что проблема с локализацией.(Сборка с русским языком и русской раскладкой не взлетает, сборка с русским языком и английской раскладкой не взлетает, та же сборка с английскими языком и раскладкой взлетает.) Спасибо всем, кто помогал.

Vekt ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.