LINUX.ORG.RU

не работает задний микрофонный вход (фронтальный работает)


0

1

Всем привет!

Очень хочу чтобы работал задний вход. То что на передней панели компа работает, а задний никак. Пытаюсь настроить через gnome-control-center. Вот front microphone пашет, а просто microphone нет. Может что-то в alsa надо подкрутить? Судя по alsamixer mic boost и input source нормально выставлены, capture на максимуме. Куда вообще копать? (я в этом лох).

OS: ubuntu 12.04 amd64

$ lspci 
00:00.0 Host bridge: Intel Corporation 4 Series Chipset DRAM Controller (rev 03)
00:01.0 PCI bridge: Intel Corporation 4 Series Chipset PCI Express Root Port (rev 03)
00:02.0 VGA compatible controller: Intel Corporation 4 Series Chipset Integrated Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation 4 Series Chipset Integrated Graphics Controller (rev 03)
00:03.0 Communication controller: Intel Corporation 4 Series Chipset HECI Controller (rev 03)
00:03.2 IDE interface: Intel Corporation 4 Series Chipset PT IDER Controller (rev 03)
00:03.3 Serial controller: Intel Corporation 4 Series Chipset Serial KT Controller (rev 03)
00:19.0 Ethernet controller: Intel Corporation 82567LM-3 Gigabit Network Connection (rev 02)
00:1a.0 USB controller: Intel Corporation 82801JD/DO (ICH10 Family) USB UHCI Controller #4 (rev 02)
00:1a.1 USB controller: Intel Corporation 82801JD/DO (ICH10 Family) USB UHCI Controller #5 (rev 02)
00:1a.2 USB controller: Intel Corporation 82801JD/DO (ICH10 Family) USB UHCI Controller #6 (rev 02)
00:1a.7 USB controller: Intel Corporation 82801JD/DO (ICH10 Family) USB2 EHCI Controller #2 (rev 02)
00:1b.0 Audio device: Intel Corporation 82801JD/DO (ICH10 Family) HD Audio Controller (rev 02)
00:1c.0 PCI bridge: Intel Corporation 82801JD/DO (ICH10 Family) PCI Express Port 1 (rev 02)
00:1c.1 PCI bridge: Intel Corporation 82801JD/DO (ICH10 Family) PCI Express Port 2 (rev 02)
00:1d.0 USB controller: Intel Corporation 82801JD/DO (ICH10 Family) USB UHCI Controller #1 (rev 02)
00:1d.1 USB controller: Intel Corporation 82801JD/DO (ICH10 Family) USB UHCI Controller #2 (rev 02)
00:1d.2 USB controller: Intel Corporation 82801JD/DO (ICH10 Family) USB UHCI Controller #3 (rev 02)
00:1d.7 USB controller: Intel Corporation 82801JD/DO (ICH10 Family) USB2 EHCI Controller #1 (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev a2)
00:1f.0 ISA bridge: Intel Corporation 82801JDO (ICH10DO) LPC Interface Controller (rev 02)
00:1f.2 RAID bus controller: Intel Corporation 82801 SATA Controller [RAID mode] (rev 02)
00:1f.3 SMBus: Intel Corporation 82801JD/DO (ICH10 Family) SMBus Controller (rev 02)
04:00.0 FireWire (IEEE 1394): nee Agere Systems nee Lucent Microelectronics FW322/323 (rev 70)

Ответ на: комментарий от adzeitor

ничего, спасибо что попытался.

Щас вот даже и не знаю что крутить. Может порт не в том режиме? Он вроде совмещён с line. Может драйвер неправильно определяет что там микрофон подключен?

true_admin ★★★★★ ()
Ответ на: комментарий от adzeitor

там же в панеле управления уровень отображается, в скайпе чекаю и щас в audacity записи делаю.

true_admin ★★★★★ ()

А в alsamixer'е точно на нем муте не стоит? А то я с этим муте чуть карточку в ремонт не понес.

aleks13 ()
Ответ на: комментарий от aleks13

да, всё перепроверил много раз. Нигде mute нету, всё на максимум выкручено, capture device стоит mic.

Может быть что порт как-то незароучен (видел такое старых багрепортах) или там он стоит как line-in?

true_admin ★★★★★ ()

У меня наоборот не работал фронтальный. Помогло явное указание модели, передав параметр.

В файл /etc/modprobe.d/alsa (может быть немного другой) добавить строку.

options hda-sound-intel model=3stack

Вместо 3stack попробуй подставит другую модель. Полный список моделей.

Поиграйся с этим параметром, посмотри на изменение поведения, авось поможет.

Xenon ★★★ ()
Ответ на: комментарий от aleks13

В профилях устройств попробуй стерео инпут.

это где? Я в гномо-центре такого не вижу. Собстно, оно стерео, а как в моно переключить непонятно. Хочу моно потому что в инете пишут что это иногда помогает.

true_admin ★★★★★ ()
Ответ на: комментарий от Xenon

спасибо, что-то не запахало :(. Даже pavucontrol ставил и с каналами игрался, пофиг.

Под виндой всё без проблем пашет, значит дело в дровах. Ладно, хрен с этим :(.

true_admin ★★★★★ ()
Ответ на: комментарий от aleks13

аааа, это пробовал.

Я только боюсь как бы я не упустил какую-либо комбинацию. Возможно, проблема имеет решение, но я уже заипался тыкаться в слепую. Уже даже pavucontrol истыкал, без толку.

true_admin ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.